Compartilhar via


O Microsoft Office para de responder quando você tenta abrir ou salvar um arquivo

Sintomas

Se você executar um dos seguintes procedimentos em um dos programas do Microsoft Office listados no final deste artigo, o programa poderá parar de responder (suspenso) por um longo tempo:

  • Clique na lista Salvar na caixa de diálogo Salvar como .
  • Clique na lista Pesquisar na caixa de diálogo Abrir .

Se você clicar em Cancelar ou tentar fechar a caixa de diálogo, o programa ainda não responderá.

Motivo

Esse problema poderá ocorrer se qualquer uma das seguintes condições for verdadeira:

  • Quando o computador está conectado a um ou mais compartilhamentos de rede mapeados que são inexistentes ou que estão atualmente offline.
  • Quando uma ou mais unidades mapeadas são persistentes e a unidade está em um domínio que não é confiável.
  • Quando a unidade mapeada está localizada em um computador lento ou de nível inferior. Um computador de nível inferior é quando o sistema operacional do computador tem uma versão anterior do Microsoft Windows do que o computador que você está usando).
  • Quando uma unidade mapeada é conectada em uma WAN (Rede de Ampla Área).
  • Quando uma unidade é uma unidade removível inacessível.

Resolução

Para resolve esse problema, você deve desconectar todas as unidades de rede que têm qualquer uma das condições declaradas na seção "Causa". Para fazer isso, execute as etapas a seguir.

Nota Como há várias versões do Microsoft Windows, as etapas a seguir podem ser diferentes em seu computador. Se estiverem, consulte a documentação do produto para concluir essas etapas.

  1. Clique com o botão direito do mouse em Meu Computador e clique em Desconectar Unidade de Rede.
  2. Na caixa de diálogo Desconectar Unidade de Rede , clique na letra da unidade que você deseja desconectar e clique em OK.
  3. Repita as etapas 1 e 2 até que todas as unidades de rede offline sejam desconectadas. Se você não tiver certeza sobre uma unidade específica, siga estas etapas:
    1. Clique em Iniciar e em Executar.

    2. Na caixa Abrir, digite o seguinte e pressione ENTER\nome do computador\nome do compartilhamento

      Onde o nome do computador é o nome do servidor que está compartilhando o recurso e o nome do compartilhamento é o nome do recurso compartilhado que você deseja usar.

      Se o recurso não estiver disponível, você receberá uma mensagem de erro semelhante à seguinte:

      O nome da rede não pode ser encontrado.

Como alternativa, você pode tentar exibir o conteúdo da unidade na Explorer do Windows.

Solução alternativa

Para contornar esse comportamento, use um dos métodos a seguir.

Método 1: não use conexões persistentes

Ao conectar uma unidade mapeada, clique para limpar a caixa Reconectar no logon marcar. Ao limpar essa caixa de marcar, a unidade mapeada não será conectada na próxima vez que você fizer logon no computador. Consulte a seção "Mais informações" para obter mais informações sobre como mapear uma unidade de rede.

Método 2: usar um script de logon do usuário

Se puder, use um script de logon para conectar um usuário aos servidores apropriados sempre que o usuário fizer logon. Verifique se o script mapeia a unidade em um estado não persistente. Se a unidade não estiver disponível conforme o script de logon for executado, a unidade não será mapeada. Esse comportamento impede o problema.

Método 3: usar espelhamento de servidor

Se a conexão estiver por meio de uma WAN (Rede de Ampla Área), considere implementar o espelhamento do servidor. O espelhamento de servidor duplica um servidor distante localmente. Em seguida, mapeie sua unidade para o servidor local duplicado. Fazer isso pode reduzir o tempo de espera conectando-se a um servidor local.

Método 4: usar um atalho para o local da rede

Use um atalho na área de trabalho do Microsoft Windows ou em Minha Rede Places para se conectar ao local de rede desejado.

Informações adicionais

Cada local em uma lista é verificado para verificar se ele está disponível e se você tem permissões de acesso ao executar os dois procedimentos a seguir nos programas do Microsoft Office:

  • Você tenta abrir ou salvar um arquivo.
  • Você acessa a lista Pesquisar ou Salvar.

Se qualquer unidade mapeada estiver em um estado documentado na seção "Causa", levará algum tempo para que a condição seja detectada e resolvida pelo programa do Office. Para evitar esse comportamento, você deve desconectar essa unidade mapeada. Você pode procurar a disponibilidade da unidade a qualquer momento no Windows Explorer. Se a unidade estiver disponível, mapeie a unidade de rede novamente mais tarde.

Para mapear uma unidade para um recurso que está online novamente, siga estas etapas:

  1. Clique com o botão direito do mouse em Meu Computador e clique em Mapear Unidade de Rede.

  2. Na caixa Unidade, clique na letra da unidade que você deseja usar para a unidade de rede.

  3. Na caixa Pasta, digite o seguinte \nome do computador\nome do compartilhamento

    Onde o nome do computador é o nome do servidor que está compartilhando o recurso e o nome do compartilhamento é o nome do recurso compartilhado que você deseja usar.

  4. Para tornar a unidade mapeada não persistente, clique para limpar a caixa Reconectar em logon marcar.

  5. Clique em Concluir.

Se você estiver tentando se conectar a recursos em outras redes, entre em contato com o administrador de rede. Unidades de rede que não existem mais, que não são mais compartilhadas ou unidades removíveis inacessíveis devem ser permanentemente desconectadas para evitar afetar o desempenho dos produtos do Office.