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Este artigo fornece uma solução para um problema em que o Email Router não envia emails do Microsoft Dynamics devido a permissões.
Aplica-se a: Microsoft Dynamics 365 Customer Engagement Online
Número original do KB: 4494727
Sintomas
Ao usar o Dynamics 365 Email Router para enviar emails de uma instância do Dynamics 365, o email pode entrar em um estado de Envio Pendente e nunca ser realmente enviado:
Os logs de exceção do Dynamics Email Router podem mostrar o seguinte erro:
Ocorreu um erro ao verificar se as mensagens de email de saída para processar:
https://disco.crm.dynamics.com/\<OrgName>
. System.ServiceModel.FaultException'1[Microsoft.Xrm.Sdk.OrganizationServiceFault]: o usuário não tem o privilégio de enviar como. (O detalhe da falha é igual aos detalhes da exceção:Código de erro: 0x8004480D
Mensagem: O usuário não tem privilégio de enviar como.
Motivo
Esse comportamento pode ter funcionado sem a necessidade dessas permissões em versões anteriores do aplicativo Dynamics 365. Devido às alterações introduzidas no modelo de segurança em determinadas iterações das versões 8.2.2 e 9.x, essas permissões devem ser concedidas explicitamente para que o E-mail Router envie e-mails para outro usuário.
Resolução
O usuário que envia esse email deve permitir que emails sejam enviados de outros usuários do Dynamics em suas opções pessoais:
A conta que está sendo usada pelo E-mail Router também deve ter a permissão Enviar e-mail como outro usuário no Dynamics: