Compartilhar via


Erro "Crystal Print Engine Error 536" ou "System Message 7014" ao tentar imprimir ou visualizar um relatório personalizado no Microsoft Dynamics SL

Este artigo fornece várias resoluções para um problema no qual você recebe duas mensagens de erro ao imprimir ou visualizar um relatório personalizado.

Aplica-se a: Microsoft Dynamics SL
Número original do KB: 897023

Sintomas

Ao imprimir um relatório personalizado ou visualizar um relatório personalizado antes de imprimi-lo no Microsoft Dynamics SL, você recebe as seguintes mensagens de erro:

Erro do mecanismo de impressão Crystal: 536 - Erro no arquivo. Não é possível conectar: parâmetros de logon incorretos.

Mensagem do sistema 7014: Falha na execução do relatório com o erro 536.

Motivo

Esse problema ocorre por um ou mais dos seguintes motivos.

Causa 1

O parâmetro Conexão confiável no arquivo de relatório é definido como 1. Consulte a Resolução 1.

Causa 2

A conexão ODBC (Open Database Connectivity) na estação de trabalho está corrompida. Consulte a Resolução 2.

Causa 3

O relatório está apontando para dois bancos de dados diferentes. Consulte a Resolução 3.

Causa 4

A conta de entrada E7F575915A2E4897A517779C0DD7CE no SQL Server 2005 ou no SQL Server 2008 está desabilitada ou tem uma senha incorreta. Consulte a Resolução 4.

Resolução

Para resolver esse problema, use a resolução apropriada.

Resolução 1

Para resolver esse problema, defina o parâmetro Conexão Confiável no arquivo de relatório como 0 (zero). Para fazer isso, siga estas etapas:

  1. Comece Crystal Reports 10 para Solomon.

  2. Selecione Abrir, selecione o relatório personalizado e, em seguida, selecione Abrir.

  3. No menu Banco de Dados, selecione Definir Local da Fonte de Dados.

  4. Na caixa de diálogo Configurar Local da Fonte de Dados, expanda Fonte de Dados Atual: Propriedades.

  5. Em Fonte de Dados Atual: Propriedades, localize o parâmetro Conexão Confiável: 1 .

    Observação

    Se o parâmetro Conexão Confiável não estiver listado, a opção Conexão Confiável não foi selecionada quando o relatório foi criado e não é a causa do erro.

  6. Clique com o botão direito do mouse em Conexão Confiável: 1 e selecione Editar.

  7. Tipo 0.

  8. Selecione Fechar.

  9. Selecione Salvar.

Resolução 2

Para resolver esse problema, exclua as conexões ODBC do Microsoft Dynamics SL. Em seguida, deixe o Microsoft Dynamics SL recriar as conexões. Para fazer isso, siga estas etapas:

  1. Selecione Iniciar, Painel de Controle, Ferramentas Administrativas e, em seguida, selecione Fontes de Dados (ODBC).
  2. Na guia DSN do usuário, remova todos os itens que apontam para os bancos de dados do aplicativo Microsoft Dynamics SL.
  3. Na guia System DSN, remova todos os itens que apontam para os bancos de dados do aplicativo Microsoft Dynamics SL.
  4. Execute novamente o relatório no Microsoft Dynamics SL. As conexões ODBC são recriadas automaticamente quando você executa um relatório no Microsoft Dynamics SL.

Resolução 3

Para resolver esse problema, redefina a fonte de dados no Crystal Reports. Para fazer isso, siga estas etapas:

  1. Comece Crystal Reports 10 para Solomon.
  2. Selecione Abrir, selecione o relatório personalizado e, em seguida, selecione Abrir.
  3. No menu Banco de Dados, selecione Definir Local da Fonte de Dados.
  4. Na caixa Substituir por, expanda Criar Nova Conexão e, em seguida, expanda ODBC (RDO).
  5. Selecione seu banco de dados do Microsoft Dynamics SL e, em seguida, selecione Avançar.
  6. Insira suas informações de login. Não marque a caixa de seleção Conexão Confiável .
  7. Selecione Concluir.
  8. Selecione o banco de dados na caixa Substituir por . Em seguida, selecione o banco de dados na caixa Fonte de Dados Atual.
  9. Selecione Atualizar.
  10. Se você tiver vários bancos de dados na caixa Fonte de Dados Atual, repita as etapas 8 e 9 para cada banco de dados.
  11. Selecione Salvar e saia do Crystal Reports.

Resolução 4

Para resolver esse problema, habilite a conta de entrada E7F575915A2E4897A517779C0DD7CE no SQL Server 2005 ou no SQL Server 2008 e execute o cenário de atualização Sincronizar Todas as Propriedades e Segurança na tela Manutenção de Banco de Dados (98.290.00) no Microsoft Dynamics SL. Para fazer isso, siga estas etapas:

  1. Inicie o SQL Server Management Studio e conecte-se ao servidor que hospeda os bancos de dados do Microsoft Dynamics SL.
  2. No painel Pesquisador de Objetos , expanda Segurançae Logons.
  3. Em Logons, clique com o botão direito do mouse em E7F575915A2E4897A517779C0DD7CE e selecione Propriedades.
  4. No painel Selecionar uma página, selecione Status e, em seguida, selecione Habilitado em Logon.
  5. Selecione OK e feche o SQL Server Management Studio.
  6. No Painel de Controle, selecione Ferramentas Administrativas e, em seguida, selecione Manutenção de Banco de Dados do Microsoft Dynamics SL.
  7. Conecte-se à instância do SQL Server que está hospedando os bancos de dados do Microsoft Dynamics SL.
  8. Selecione a aba Atualizar banco de dados.
  9. Na lista Cenários de Atualização, selecione Sincronizar Toda a Propriedade e Segurança e, em seguida, selecione Atualizar Banco de Dados.
  10. Na parte inferior da tela Manutenção do banco de dados (98.290.00), confirme que a barra de progresso foi concluída e, em seguida, selecione Fechar.