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Erro 3266 ou 3013 ao executar um backup de banco de dados em disco ou fita ou uma restauração de banco de dados de disco ou fita

Este artigo fornece ajuda para resolver o erro 3266 ou 3013 que ocorre quando você executa um backup de banco de dados em disco ou fita ou uma restauração de banco de dados de disco ou fita.

Número original do KB: 290787

Sintomas

Quando você executa um backup de banco de dados em disco ou fita, ou uma restauração de disco ou fita, a seguinte mensagem de erro pode ocorrer:

Servidor SQL Server 7.0:

Msg 3266, Nível 16, Estado 1, Linha 1
O banco de dados de marca de arquivo flexível do Microsoft Tape Format (MTF) no dispositivo de backup 'devicename' não pode ser lido, inibindo o acesso aleatório.
Servidor: Msg 3013, Nível 16, Estado 1, Linha 1
Operação de backup ou restauração terminando de forma anormal.

Servidor SQL Server 2000:

Msg 3266, Nível 16, Estado 1, Linha 1
Os dados de backup em 'devicename' estão formatados incorretamente. Os backups não podem ser anexados, mas os conjuntos de backup existentes ainda podem ser usados.
Servidor: Msg 3013, Nível 16, Estado 1, Linha 1
BACKUP DATABASE está sendo encerrado de forma anormal.

Servidor SQL Server 2005:

Mensagem 3013, Nível 16, Estado 1, Linha 1
Os dados de backup no final de 'devicename' estão formatados incorretamente. Os conjuntos de backup da mídia podem estar danificados e inutilizados. Para determinar os conjuntos de backup da mídia, use RESTORE HEADERONLY. Para determinar a utilidade dos pacotes de backup, utilize RESTORE VERIFYONLY. Se todos os conjuntos de backup estiverem incompletos, reformate a mídia usando BACKUP WITH FORMAT, o que destrói todos os conjuntos de backup.
Servidor: Msg 3013, Nível 16, Estado 1, Linha 1

BACKUP DATABASE está sendo encerrado de forma anormal.

Motivo

Não foi possível ler uma marca de arquivo no dispositivo de backup. Existem muitos motivos pelos quais você pode encontrar um erro de marca de arquivo. Algumas das razões incluem o seguinte:

  • Uma falha de mídia pode ocorrer no dispositivo onde o backup está localizado.

  • Uma falha de gravação pode ocorrer durante a criação do backup.

    Por exemplo, pode ocorrer uma perda de conectividade durante um backup de rede. Ou uma falha do caminho de E/S para liberar a gravação no disco pode ocorrer depois que a gravação no disco foi relatada ao SQL Server como bem-sucedida.

Solução alternativa

Para permitir que o SQL Server execute novos backups no dispositivo de backup, você deve excluir ou apagar manualmente o dispositivo usando o seguinte comando:

BACKUP DATABASE mydatabase TO DISK='C:\MyDatabase.bak' with FORMAT

Se a mensagem de erro ocorrer durante uma operação de restauração, pode ser possível recuperar outros conjuntos de backup do dispositivo especificando o número do arquivo. Por exemplo, se três (3) backups estiverem em um (1) dispositivo de backup, os conjuntos de backup 1 e 2 poderão ser usados. Para determinar se vários conjuntos de backup estão em um dispositivo, execute o seguinte código no Analisador de Consultas:

RESTORE HEADERONLY FROM DISK='C:\MyDatabase.bak'

Cada conjunto de backup tem uma entrada na saída. Para indicar um conjunto de backup específico, use este código:

RESTORE DATABASE mydatabase FROM DISK='C:\MyDatabase.bak' WITH FILE = FileNumber

Observação

FileNumber é o número do conjunto de backup que você deseja restaurar.

Mais informações

A lista a seguir contém observações importantes sobre backups e SQL Server.

  • Depois que o SQL Server detecta um erro de marca de arquivo em um dispositivo, o SQL Server não grava informações adicionais no dispositivo.

  • O SQL Server armazena todos os backups no formato de fita da Microsoft, seja o backup feito em disco ou em fita. O Microsoft Tape Format usa marcas de arquivo para armazenar informações como o tamanho do bloco e o número de blocos em um backup, além de outras informações sobre o backup. O Microsoft Tape Format também usa marcas de arquivo para delimitar backups em um dispositivo de backup. O fato de uma marca de arquivo estar ausente ou danificada sugere que pelo menos um backup no dispositivo não é válido.

  • Embora você possa restaurar alguns conjuntos de backup do dispositivo danificado, você deve verificar a integridade do banco de dados restaurado.

  • O SQL Server registra detalhes de êxito ou falha durante uma operação de backup ou restauração no log de erros do SQL Server e nas tabelas de histórico de backup no banco de dados do sistema msdb.

  • Se você tiver um erro 3266 ao restaurar um log de transações ou um backup de banco de dados, investigue os seguintes logs para obter mais informações:

    • log de erros do SQL Server
    • Tabelas de backup e restauração de histórico
    • Log de eventos do aplicativo
    • Log de eventos do sistema

Se não houver detalhes da falha nesses logs, talvez você tenha experimentado uma falha não relatada. Você deve entrar em contato com o Atendimento Microsoft se precisar de ajuda.