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Aplica-se a: ✔️ VMs do Windows
Este artigo descreve o loop de reinicialização que pode ocorrer em uma máquina virtual (VM) do Windows no Microsoft Azure.
Sintoma
Ao usar o Diagnóstico de inicialização para obter as capturas de tela de uma VM, você descobre que a máquina virtual está inicializando, mas o processo de inicialização está sendo interrompido e o processo está reiniciando.
Motivo
O loop de reinicialização ocorre devido às seguintes causas:
Causa 1
Há um serviço de terceiros sinalizado como crítico e não pode ser iniciado. Isso faz com que o sistema operacional seja reinicializado. Para resolve esse problema, consulte Solução para causa 1.
Causa 2
Algumas mudanças foram feitas no sistema operacional. Normalmente, eles estão relacionados a uma instalação de atualização, instalação de aplicativo ou uma nova política. Você pode ter que verificar os seguintes logs para obter detalhes adicionais:
- Logs de evento
- CBS.logWindows
- Update.log
Para resolver esse problema, consulte Solução para a causa 2.
Causa 3
Uma corrupção de hive do registro pode causar esse problema. Para resolver esse problema, consulte Solução para a causa 3.
Solução
Dica
Se você tiver um backup recente da VM, tente restaurar a VM do backup para corrigir o problema de inicialização.
Para resolver esse problema, faça backup do disco do sistema operacional e anexe o disco do sistema operacional a uma VM de resgate e siga as opções de solução apropriadas ou tente as soluções uma a uma.
Solução para a causa 1
Depois que o disco do sistema operacional estiver conectado a uma VM em funcionamento, certifique-se de que o disco esteja sinalizado como Online no console de Gerenciamento de Disco e anote a letra da unidade da partição que contém a pasta \Windows.
Se o disco estiver definido como Offline, defina-o como Online.
Crie uma cópia da pasta \Windows\System32\config caso seja necessário reverter as alterações.
Na VM de resgate, abra o Editor do Registro do Windows (regedit).
Selecione a chave HKEY_LOCAL_MACHINE e, em seguida, selecione Arquivo>Carregar Hive no menu.
Navegue até o arquivo SYSTEM na pasta \Windows\System32\config.
Selecione Abrir, digite BROKENSYSTEM para o nome, expanda a chave HKEY_LOCAL_MACHINE e você verá uma chave adicional chamada BROKENSYSTEM.
Verifique de qual ControlSet o computador está inicializando. Você verá seu número de chave na seguinte chave de registro.
HKEY_LOCAL_MACHINE\BROKENSYSTEM\Select\Current
Verifique qual é a criticidade do serviço do agente VM por meio da seguinte chave de registro.
HKEY_LOCAL_MACHINE\BROKENSYSTEM\ControlSet00x\Services\RDAgent\ErrorControl
Se o valor da chave de registro não estiver definido como 2, vá para a próxima mitigação.
Se o valor da chave de registro estiver definido como 2, altere o valor de 2 para 1.
Se alguma das seguintes chaves existir e tiver o valor 2 ou 3, altere esses valores para 1 de acordo:
HKEY_LOCAL_MACHINE\BROKENSYSTEM\ControlSet00x\Services\AzureWLBackupCoordinatorSvc\ErrorControl
HKEY_LOCAL_MACHINE\BROKENSYSTEM\ControlSet00x\Services\AzureWLBackupInquirySvc\ErrorControl
HKEY_LOCAL_MACHINE\BROKENSYSTEM\ControlSet00x\Services\AzureWLBackupPluginSvc\ErrorControl
Selecione a chave BROKENSYSTEM e, em seguida, selecione Arquivo>Descarregar Hive no menu.
Desanexe o disco do sistema operacional da VM de solução de problemas.
Remova o disco da VM de solução de problemas e aguarde cerca de 2 minutos para que o Azure libere esse disco.
Se o problema for corrigido, talvez seja necessário reinstalar o RDAgent (WaAppAgent.exe).
Solução para a Causa 2
Restaure a VM para a última configuração válida, siga as etapas em Como iniciar a VM do Windows do Azure com a última configuração válida.
Solução para a Causa 3
Observação
O procedimento a seguir deve ser usado apenas como último recurso. Embora a restauração do regback possa restaurar o acesso à máquina, o sistema operacional não é considerado estável, pois há dados perdidos no registro entre o registro de data e hora da seção e o dia atual. Você precisa criar uma nova VM e fazer planos para migrar dados.
Depois que o disco estiver conectado a uma VM de solução de problemas, verifique se o disco está sinalizado como Online no console de gerenciamento de disco.
Crie uma cópia da pasta \Windows\System32\config caso seja necessário reverter as alterações.
Copie os arquivos da pasta \Windows\System32\config\regback e substitua os arquivos da pasta \Windows\System32\config.
Remova o disco da VM de solução de problemas e aguarde cerca de 2 minutos para que o Azure libere esse disco.
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