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Este artigo ajuda você a resolver um problema em que os termos restantes de direitos não diminuem conforme o esperado no Microsoft Dynamics 365 Customer Service.
No Dynamics 365 Customer Service, há dois cenários de redução dos termos de direitos.
Cenário 1
Quando o campo Tipo de Alocação de um direito é definido como Número de casos, você pode definir o campo Diminuir Restante em como Criação de Ocorrência ou Resolução de Ocorrência.
- Se você selecionar Criação de caso, os Termos restantes serão reduzidos quando um novo caso for criado.
- Se você selecionar Resolução de caso, os Termos restantes serão reduzidos quando o caso for resolvido.
Por exemplo:
Diminuir Restante em é definido como Criação de Caso e Total de Termos é dado como 10.
- Crie um novo caso adicionando direitos.
- Quando o caso é criado, 1 termo é deduzido e o número de Termos Restantes é 9.
Diminuir Restante em é definido como Resolução de Casos e Total de Termos é dado como 10.
- Crie um novo caso adicionando direitos e resolva-o.
- Depois que o caso é resolvido, 1 prazo é deduzido e o número de Prazos Restantes é 9.
Cenário 2
Quando o campo Tipo de Alocação de um direito é definido como Número de horas, o campo Diminuir Restante em pode ser definido somente como Resolução de Caso.
Por exemplo:
- Crie uma atividade no formulário de ocorrência que deve ser concluída antes de resolver a ocorrência, com o campo de duração definido como 30 minutos.
- Após a resolução do caso, o prazo é deduzido 0,5 e os Termos Restantes são 9,5.
Aqui, o cálculo Diminuir Restante em funciona como:
1hour (60min) = 1 term
30min = 0.5 term
Se Restringir com base nos termos de direito estiver definido como Sim, os agentes não poderão criar casos com direitos quando os Termos restantes forem menores que zero ou quando o prazo restante de um canal for menor que zero.
Sintomas
Os termos restantes de um direito não estão diminuindo conforme o esperado.
Causa
Determinadas configurações afetam o comportamento dos termos restantes do direito.
Resolução 1
Verifique se os termos Não diminuir direito estão selecionados no formulário de caso. Nesse caso, os termos restantes não serão diminuídos quando um caso for criado ou resolvido. Para permitir que os termos restantes sejam diminuídos, desmarque Não diminuir os termos de direito.
Resolução 2
- Entre em sua instância do Dynamics 365 Customer Engagement (on-premises).
- Vá para Configurações>Configurações>avançadas Personalizações>Personalize o sistema para abrir a solução padrão.
- Desabilite todos os plug-ins personalizados, fluxos de trabalho e código de .js personalizado nas entidades de direito e caso.
- Remova a camada ativa personalizada para as entidades de ocorrência e direito.
- Remova a camada ativa personalizada do campo decremententitlementterm na entidade de caso.