Observação
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Este artigo fornece uma solução para um erro que pode ocorrer quando você procura alguns clientes na janela Consulta de Gerenciamento de Recebíveis.
Aplica-se a: Microsoft Dynamics GP
Número original do KB: 864730
Sintomas
Ao procurar alguns clientes na janela Consulta de Gerenciamento de Recebíveis, você pode receber a seguinte mensagem de erro:
Violação da restrição PRIMARY KEY 'pk1003255' tentativa de inserir uma chave duplicada.
Causa
Há um registro duplicado no Gerenciamento de Recebíveis violando uma chave primária na tabela. O mesmo registro está nas tabelas Trabalho e Aberto, Aberto e Histórico ou Trabalho e Histórico.
Solução
Para resolver esse problema, siga estas etapas:
Identificar registros duplicados
Identifique registros duplicados nas tabelas de Gerenciamento de Recebíveis por conta própria. As tabelas são:
- RM10301 - Arquivo de Trabalho de Vendas do RM
- RM10201 - Ficha de Trabalho de Recebimentos de Caixa
- RM20101 - RM Abrir arquivo
- RM30101 - Arquivo de histórico RM
Existe uma Solução Automatizada disponível para executar esta tarefa intitulada "Duplicatas de Recebíveis".
Observação
A Solução Automatizada só encontrará e relatará quaisquer registros duplicados existentes entre as tabelas. Isso não corrigirá o problema. Você deve determinar quais registros são duplicados e, em seguida, excluir manualmente esses registros depois de pesquisar qual registro está incorreto.
Excluir registros duplicados
Depois de determinar quais registros são duplicados, pesquise-os para determinar qual registro é válido e exclua manualmente o registro duplicado usando o SQL Server Management Studio. Se você quiser ajuda para excluir registros duplicados, entre em contato com seu parceiro, suporte técnico do Microsoft Dynamics pelo telefone 1-8888-477-7877 ou abra um caso de suporte pago.