Compartilhar via


Ocorre uma exceção quando você entra em um aplicativo configurado para o Azure B2C

Versão original do produto: Microsoft Entra ID
Número original do KB: 3092592

Sintomas

Ao tentar se inscrever ou entrar em um aplicativo configurado para o Microsoft Azure B2C, você recebe a seguinte mensagem de erro:

Erro de servidor no aplicativo '/'"

O código de status de resposta não indica êxito: 404 (Não Encontrado)

Descrição: ocorreu uma exceção sem tratamento durante a execução da solicitação da Web atual. Examine o rastreamento de pilha para obter mais informações sobre o erro e em que ponto ele ocorreu no código.

Detalhes da exceção: System.Net.WebException: o servidor remoto retornou um erro. 404 (Não encontrado)

Source Error:
Linha 106: {
Linha 107: ...
Linha 108: OpenIdConnectConfiguration config = await mgr. GetConfigurationAsync();
Linha 109: ...
Linha 110: }

Motivo

Esse problema ocorrerá se a configuração Nome da Política para entrada, redefinição de senha ou o perfil do usuário estiver ausente ou incorreta no arquivo web.config do aplicativo.

Resolução

Para resolver esse problema, siga estas etapas:

  1. Abra o arquivo web.config do seu aplicativo.

  2. Neste arquivo, verifique o seguinte:

    • A chave do aplicativo ida:SignInPolicyId existe e você substituiu o valor pelo nome da política de entrada fornecida no Portal de Administração do Azure B2C.
    • A chave do aplicativo ida:PasswordResetPolicyId existe e você substituiu o valor pelo nome da política de entrada fornecida no Portal de Administração do Azure B2C.
    • A chave do aplicativo ida:UserProfilePolicyId existe e você substituiu o valor pelo nome da política de entrada fornecida no Portal de Administração do Azure B2C.

    O arquivo web.config deve ser semelhante ao seguinte:

    <appSettings>
    ...
    <add key="ida:SignInPolicyId" value="B2C_Signin_Policy">
    <add key="ida:PasswordResetPolicyId" value="B2C_PasswordReset_Policy">
    <add key="ida:UserProfilePolicyId" value="B2C_UserProfile_Policy">
    ...
    </appSettings>
    

Entre em contato conosco para obter ajuda

Se você tiver dúvidas ou precisar de ajuda, crie uma solicitação de suporte ou peça ajuda à comunidade de suporte do Azure. Você também pode enviar comentários sobre o produto para a comunidade de comentários do Azure.