Observação
O acesso a essa página exige autorização. Você pode tentar entrar ou alterar diretórios.
O acesso a essa página exige autorização. Você pode tentar alterar os diretórios.
Aplica-se a: Power Apps
Sintomas
Quando você seleciona o botão Voltar ou o botão Salvar e Fechar em um aplicativo da Interface Unificada, não há resposta. Por exemplo, ao selecionar um dos botões em uma página de registro de entidade, você espera ser retornado à página anterior. No entanto, pode ser necessário selecionar o botão várias vezes até que o programa navegue até a página desejada.
Causa
O histórico do navegador é compartilhado por aplicativos da Interface Unificada e iFrames de formulários de aplicativos. Se você criar scripts personalizados em um iFrame que permitam o redirecionamento de navegação ou autenticação, o iFrame adicionará entradas extras de histórico ao histórico do navegador. Ao selecionar o botão Voltar ou o botão Salvar e Fechar em uma página de registro de entidade, você é direcionado para a entrada do histórico que foi adicionada pelos scripts personalizados do iFrame em vez da entrada do aplicativo Interface Unificada. Para navegar até a página anterior, você deve selecionar o botão várias vezes para forçar o programa a navegar pelas entradas de histórico que foram adicionadas pelos scripts personalizados do iFrame.
Solução alternativa
Ao criar scripts personalizados em iFrames, gerencie a propriedade Window.history para remover quaisquer entradas de histórico extras ou inesperadas listadas antes da entrada de navegação regressiva correta.