Observação
O acesso a essa página exige autorização. Você pode tentar entrar ou alterar diretórios.
O acesso a essa página exige autorização. Você pode tentar alterar os diretórios.
Este artigo fornece uma solução alternativa para resolver o erro "Não foi possível estabelecer relação de confiança para o canal seguro SSL/TLS" no Power Automate para área de trabalho.
Aplica-se a: Power Automate para desktop versão 2.35 ou posterior
Sintomas
Ações no Power Automate para área de trabalho, como Invocar serviço Web ou Obter senha do CyberArk, podem falhar durante o runtime com o seguinte erro:
System.Net.Http.HttpRequestException: ocorreu um erro ao enviar o pedido. >--- System.Net.WebException: a conexão subjacente foi fechada: não foi possível estabelecer uma relação de confiança para o canal seguro SSL/TLS.
Em alguns casos, o problema pode ocorrer quando uma ferramenta de inspeção de tráfego de rede, como o Fiddler, é instalada no computador.
Motivo
O Power Automate para área de trabalho valida o status dos certificados HTTPS para verificar sua validade, incluindo se eles são revogados ou inválidos. Esse erro pode ocorrer nas seguintes condições:
Um certificado na cadeia foi revogado ou marcado como inválido.
As empresas que usam a inspeção de pacotes para auditar sua infraestrutura de rede podem não permitir que os usuários entrem, pois a CRL (Lista de Revogação de Certificados) pode não ter sido definida ou inacessível.
Ferramentas como o Fiddler podem instalar um certificado autoassinado no sistema com um status de revogação desconhecido. Nesses casos, se a chave do Registro CertificateRevocationCheck estiver definida como Abrangente, o Power Automate para área de trabalho rejeitará o certificado e o erro será gerado.
Solução Alternativa
Os administradores podem permitir que usuários com certificados inválidos usem essas ações seguindo as etapas em Configurar o Power Automate para área de trabalho para verificar se há certificados revogados.