Mensagem de erro ao acessar um dispositivo de armazenamento USB após a retomada da suspensão

Este artigo fornece uma solução para um erro que ocorre quando você acessa um dispositivo de armazenamento USB após a retomada da suspensão.

Aplicável ao: Windows 10 - todas as edições
Número de KB original: 323754

Sintomas

Se você tentar usar um dispositivo de armazenamento USB (Barramento Serial Universal) imediatamente após retomar o computador da suspensão, poderá receber a seguinte mensagem de erro:

X :\ A unidade não está acessível. A solicitação não pôde ser executada devido a um erro de dispositivo de E/S.

Você continua recebendo a mensagem de erro ao tentar usar o dispositivo de armazenamento USB até remover e recolocar o dispositivo ou reiniciar o computador. Esse problema pode ocorrer com qualquer dispositivo de armazenamento USB, como unidades de disco disquete, discos rígidos ou unidades CD-ROM.

Motivo

Esse problema ocorre com alguns dispositivos de armazenamento USB 1.x que são anexados a um controlador USB 2.0 no Windows 2000 com a atualização USB 2.0 instalada.

Resolução

Para resolve esse problema, obtenha e instale o arquivo de Usbhub.sys atualizado do hotfix.

Solução alternativa

Para resolver esse problema, aguarde aproximadamente 10 segundos depois de retomar seu computador antes de tentar usar o dispositivo de armazenamento USB 1.x.

Se você não usar nenhum dispositivo USB 2.0 no computador, outra solução alternativa será desativar o controlador USB 2.0 em Gerenciador de Dispositivos. Depois de desativar o controlador USB 2.0, o problema descrito anteriormente neste artigo com dispositivos USB 1.x não ocorre.

Status

A Microsoft confirmou que esse é um problema nos produtos da Microsoft listados no início deste artigo.

Mais informações

Depois de aplicar o hotfix mencionado anteriormente neste artigo, os seguintes comportamentos mudam:

  • Se você tentar usar um dispositivo de armazenamento USB 1.x imediatamente após retomar seu computador, o problema ainda poderá ocorrer. No entanto, o problema não ocorrerá se você tentar usar o dispositivo de armazenamento novamente em alguns segundos.

  • Logo após retomar o computador, você poderá receber uma mensagem de Remoção Insegura do Dispositivo que menciona o dispositivo USB 1.x. Você pode fechar essa caixa com segurança. Essa mensagem ocorre devido a um problema de tempo do Windows que envolve a ativação da pilha de driver do controlador complementar USB e da pilha EHCI (interface avançada do Controlador de Host) após a retomada da suspensão.

    Se o driver do hub raiz do controlador complementar ligar primeiro, os dispositivos USB 1.x que foram anexados às portas do hub raiz quando o computador entrou em suspensão não serão mais anexados. Portanto, o driver informa Plug and Play que o dispositivo foi removido. Isso ocorre porque os dispositivos foram roteados para o controlador EHCI quando o Sinalizador de Configuração foi definido, mas eles não estão atualmente anexados ao controlador complementar.

    Quando o driver do hub raiz do controlador EHCI (para USB 2.0) aumenta mais tarde, as portas do hub raiz são redefinidas e os dispositivos USB 1.x são roteados de volta para os controladores complementares. O hub do controlador complementar enumera os dispositivos novamente. Em seguida, eles são detectados e se tornam funcionais.

    Isso não afeta dispositivos USB 2.0 porque eles sempre permanecem anexados ao controlador EHCI.

Coleta de dados

Se você precisar de ajuda do suporte da Microsoft, recomendamos coletar as informações seguindo as etapas mencionadas em Coletar informações usando o TSS para problemas relacionados à implantação.