Compartilhar via


Erro "A operação expirou" ao criar uma partição usando o console de Gerenciamento de Disco ou DiskPart.exe

Este artigo ajuda a corrigir o erro "A operação expirou" ao criar uma partição usando o console ou DiskPart.exe Gerenciamento de disco.

Aplica-se a: Windows Server 2012 R2, Windows Server 2008 R2 Service Pack 1
Número original do KB: 2826890

Sintomas

  • Ao tentar criar um novo volume no Gerenciamento de disco (diskmgmt.msc), você pode receber a seguinte mensagem de erro:

    A operação não foi concluída porque a exibição do console de Gerenciamento de Disco não está atualizada. Atualize o modo de exibição usando a tarefa de atualização. Se o problema persistir, feche o console de Gerenciamento de Disco e reinicie o Gerenciamento de Disco ou reinicie o computador.

  • Se você tentar criar uma nova partição usando Diskpart.exe, poderá receber uma mensagem de erro semelhante às seguintes:

    Erro do serviço de disco virtual:
    A operação atingiu o tempo limite.

    O Diskpart fez referência a um objeto que não está atualizado.
    Atualize o objeto usando o comando RESCAN.
    Se o problema persistir, saia do DiskPart e reinicie o DiskPart ou reinicie o computador.

  • Além disso, você pode ver uma janela pop-up com as seguintes informações:

    Encontrou novo hardware
    O Windows precisa instalar o software de driver para o seu dispositivo desconhecido

Causa

Esses problemas ocorrem se o volume.inf estiver ausente da %Systemroot%\inf pasta.

Solução

Para resolver o problema, execute as seguintes etapas:

  1. Abra um prompt de comando com privilégios elevados. Para fazer isso, clique em Iniciar, clique em Todos os Programas, clique em Acessórios, clique com o botão direito do mouse em Prompt de Comando e clique em Executar como administrador.

  2. No prompt de comando, digite o seguinte comando e pressione Enter: sfc /verifyonly

  3. Se o comando acima retornar informando que os problemas foram encontrados, digite o seguinte comando e pressione Enter. Deixe a operação de comando ser concluída:
    sfc /scannow

  4. Abra o Windows Explorer e navegue até a %Systemroot%\inf pasta

  5. Verifique se o arquivo volume.inf foi substituído. Se o arquivo não for substituído, você precisará copiar volume.inf de outro computador executando a mesma versão do Windows, a mesma versão do Service Pack e a mesma arquitetura de CPU.

Coleta de dados

Se você precisar de ajuda do suporte da Microsoft, recomendamos coletar as informações seguindo as etapas mencionadas em Coletar informações usando o TSS para problemas relacionados à implantação.