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As configurações do Serviço de Tempo do Windows não são preservadas durante uma atualização in-loco para o Windows Server 2016 ou Windows 10 versão 1607

Este artigo descreve um problema no qual as configurações do Serviço de Tempo do Windows são desabilitadas no registro após a atualização para o Windows Server 2016 ou Windows 10 versão 1607.

Número original do KB: 3201265

Sintomas

Quando você faz uma atualização in-loco nos seguintes caminhos de atualização de sistemas operacionais, o serviço de Tempo do Windows não preserva sua configuração. Em vez disso, ele mostra os valores padrão para um servidor de grupo de trabalho ou estação de trabalho.

Atualizar a partir do Fazer upgrade para
Windows Server 2012 R2 ou Windows Server 2012 Windows Server 2016
Windows 7, Windows 8 ou Windows 8.1 Windows 10, versão 1607

Funções afetadas

Após a conclusão da atualização in-loco, as funções a seguir podem ser afetadas.

Controladores de domínio

Os controladores de domínio (DC) que hospedam a função de emulador PDC são o servidor de horário autoritativo padrão para o domínio. Normalmente, ele é configurado para sincronizar com uma fonte de tempo altamente precisa. Todos os outros DCs no domínio sincronizam seu tempo com o PDC.

Depois de fazer uma atualização in-loco, o PDC perde sua conexão com o servidor de horário externo com o qual está configurado para sincronizar. Ele também não anuncia mais que é um servidor de horário.

Todos os outros DCs no domínio não anunciam mais que são servidores de horário e não usam mais a hierarquia de domínio para sincronizar seu tempo. Portanto, a configuração de tempo pode não estar mais sincronizada com a configuração de seus pares e os membros do domínio não podem mais sincronizar seu tempo.

Você pode observar o seguinte aviso na saída DCDIAG:

Aviso: <DCNAME> não está anunciando como um servidor de horário

Você também pode observar que o controlador de domínio não responde às solicitações do cliente NTP. Ele inclui falhas que ocorrem quando você testa a disponibilidade do servidor NTP usando a w32tm.exe /stripchart ferramenta. Por exemplo, a saída de texto pode ser semelhante à seguinte saída:

c:>w32tm /stripchart /computer: <DCName> Tracking <DCName> [10.1.1.100:123]. A hora atual é 28/10/2016 09:00:00. 09:00:00 erro: 0x800705B4:

Membros do Domínio

Os servidores membros do domínio e os computadores atualizados não estão mais configurados para usar a hierarquia de domínio para sincronizar seu tempo. Em vez disso, eles sincronizarão seu tempo com o time.windows.com site.

Servidor de Horário Autoritativo

Os computadores Windows configurados manualmente como um Servidor de Tempo Autoritativo perdem sua configuração. Portanto, os dispositivos configurados para usar esses computadores para sincronizar seu tempo podem não sincronizar.

Você também pode observar que o servidor NTP autoritativo não responde às solicitações do cliente NTP. Ele inclui falhas que ocorrem quando você testa a disponibilidade do servidor NTP usando a w32tm.exe /stripchart ferramenta. Por exemplo, a saída de texto pode ser semelhante à seguinte saída:

c:>w32tm /stripchart /computer:<myAuthoritativeTimeServer> Rastreando <myAuthoritativeTimeServer> [10.1.1.100:123]. A hora atual é DateTime>.< <Erro de data e hora> : 0x800705B4:

Observação

Esse problema não deve ocorrer quando você faz uma atualização in-loco dos seguintes sistemas operacionais:

  • Windows 10 versão 1507 até Windows 10 versão 1511
  • Windows 10 versão 1511 até Windows 10 versão 1607
  • Windows Server 2016 Technical Preview 5 (TP5) até Windows Server 2016 (RTM)

Motivo

É um problema conhecido nos caminhos de atualização do Windows listados na seção "Sintomas". Esse problema ocorre porque os valores do Registro para o serviço de Tempo do Windows não são preservados durante uma atualização. Portanto, todos os valores do serviço de Tempo do Windows são revertidos para o estado padrão de um Servidor Membro do Grupo de Trabalho ou de um computador autônomo.

Solução alternativa

Importante

Esta seção, método ou tarefa contém etapas que descrevem como modificar o Registro. Entretanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, certifique-se de seguir essas etapas com atenção. Para proteção acrescida, faça backup do Registro antes de modificá-lo. Em, é possível restaurar o Registro caso ocorra um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, acesse o seguinte artigo da Base de Dados de Conhecimento Microsoft:
322756 Como fazer o backup e a restauração do Registro no Windows

Observação

Em DCs e computadores ingressados no domínio, o serviço Netlogon deve estar em execução antes que o serviço W32time possa ser iniciado. Depois de atualizar o sistema, verifique se o Netlogon está em execução antes de tentar qualquer uma dessas soluções alternativas.

Como solução alternativa para esse problema, use um dos seguintes métodos.

Método 1

Antes de atualizar para Windows 10 versão 1607 ou Windows Server 2016, faça backup manualmente do conteúdo na chave do Registro w32time . Para fazer isso, siga estas etapas:

  1. Abra a caixa Executar pressionando a tecla do logotipo do Windows +R.

  2. Digite regedit e pressione Enter.

  3. Localize e selecione a seguinte entrada do Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\

  4. Selecione Exportação de arquivo>.

  5. Na caixa de diálogo Exportar Arquivo do Registro, selecione o local onde deseja salvar a cópia de backup e digite um nome para o arquivo de backup no campo Nome do arquivo.

  6. Selecione Salvar.

  7. Salve a configuração do W32time para validação executando os seguintes comandos em um prompt de comando com privilégios elevados:

    Net start w32time w32tm /query /configuration /verbose > PreUpgradeW32timeConfiguration.txt
    

Agora você pode atualizar o computador para o Windows Server 2016 ou Windows 10 versão 1607. Após a conclusão da atualização, siga estas etapas para restaurar o conteúdo na chave do Registro w32time:

  1. Abra a caixa Executar pressionando a tecla do logotipo do Windows +R.

  2. Digite regedit e pressione Enter.

  3. Abra a caixa Executar pressionando a tecla do logotipo do Windows +R.

  4. Digite regedit e pressione Enter.

  5. No Editor do Registro, selecione Importação de Arquivo>.

  6. Na caixa de diálogo Importar Arquivo do Registro, selecione o local onde você salvou a cópia de backup, selecione o arquivo de backup e selecione Abrir.

  7. Saia do Editor do Registro.

  8. Execute o seguinte comando para remover um gatilho de serviço preterido:

    reg delete HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\TriggerInfo\1 /f
    
  9. Reinicie o serviço W32time para permitir que ele use a nova configuração. Para fazer isso, execute os seguintes comandos em um prompt de comando com privilégios elevados:

    net stop w32time
    
    net start w32time
    

Método 2

Se você estiver enfrentando problemas que afetam o Serviço de Tempo do Windows após a atualização para o Windows Server 2016 ou Windows 10 versão 1607, siga estas etapas para registrar w32tm.exenovamente .

Observação

Este procedimento restaura as configurações padrão apropriadas para a função de computador. Ele não restaura nenhuma personalização feita pelo administrador.

Em um prompt de comando com privilégios elevados, execute a seguinte sequência de comandos:

net stop w32time

w32tm.exe /unregister

w32tm.exe /register

net start w32time

Método 3

Se você estiver enfrentando problemas que afetam o Serviço de Tempo do Windows após a atualização para o Windows Server 2016 ou Windows 10 versão 1607, siga estas etapas para restaurar suas configurações da pasta Windows.old.

Importante

As etapas a seguir devem ser executadas apenas por usuários avançados.

  1. Exporte a chave do Registro da pasta Windows.old.

    1. Abra a caixa Windows Run pressionando a tecla do logotipo do Windows + R.

    2. Digite regedit e pressione Enter.

    3. Localize e clique em HKEY_LOCAL_MACHINE.

    4. No menu Arquivo, clique em Carregar Hive.

    5. Localize e clique no C:\Windows.old\Windows\System32\Config\System arquivo e, em seguida, clique em Abrir.

    6. Na caixa de diálogo Carregar Hive, digite Offline e clique em OK.

    7. Expanda Offline.

    8. Localize e clique na seguinte subchave do Registro: ControlSet001\Services\W32Time\

    9. Clique em Exportar arquivo>.

    10. Na caixa de diálogo Exportar Arquivo do Registro, selecione o local em um disco rígido local onde você deseja salvar o Registro e digite um nome para o arquivo de backup no campo Nome do arquivo.

    11. Clique em Save (Salvar).

    12. Localize e clique na seguinte subchave do Registro: HKEY_LOCAL_MACHINE\Offline

    13. No menu Arquivo, clique em Descarregar Hive e, em seguida, clique em Sim na caixa de diálogo Confirmar Descarregamento do Hive.

    14. Saia do editor do Registro.

  2. Reinicie o computador no modo de recuperação.

    1. Selecione Iniciar>configurações>Atualização e recuperação de segurança>
    2. No painel do lado direito, clique em Reiniciar agora em Inicialização avançada.
    3. Depois que o computador for reiniciado, selecione Solucionar problemas e, em seguida, selecione Prompt de comando.
    4. Selecione um usuário administrador local e insira a senha.

    Observação

    Isso reinicia o computador no modo de recuperação e fornece uma janela de prompt de comando.

  3. Importe a chave do Registro salva da etapa 1.

    1. No prompt de comando, digite regedit e pressione Enter

    2. Localize e selecione HKEY_LOCAL_MACHINE

    3. Ativado no menu Arquivo , clique em Carregar Hive.

    4. Localize e selecione o C:\Windows\System32\Config\System arquivo e clique em Abrir.

    5. Na caixa de diálogo Carregar Hive, digite Offline e clique em OK

    6. Expanda Offline.

    7. Localize e clique na seguinte subchave do Registro: ControlSet001\Services\W32Time\

    8. Clique em Arquivo>Importar.

    9. Na caixa de diálogo Importar Arquivo do Registro, selecione o local onde você salvou a cópia de backup, selecione o arquivo de backup e clique em Abrir.

    10. Localize e clique na seguinte subchave do Registro: HKEY_LOCAL_MACHINE\Offline

    11. No menu Arquivo, clique em Descarregar Hive e, em seguida, clique em Sim na caixa de diálogo Confirmar Descarregamento do Hive.

    12. Saia do Editor do Registro e reinicie o computador no modo Normal.

Verificar os resultados da solução alternativa

Para verificar se o serviço de Tempo do Windows agora pode preservar sua configuração, siga estas etapas:

  1. Execute DCDiag.exe em DCs para garantir que eles estejam anunciando como um servidor de horário.

  2. Certifique-se de que os DCs ou servidores NTP autoritativos respondam às solicitações do cliente NTP sem erros. Por exemplo, a saída do comando é semelhante à seguinte:

    c:< w32tm / stripchart / computador:< myTimeServer>
    Rastreando <myTimeServer> [10.1.1.100:123].
    A hora atual é DateTime>.<
    <DateTime> d:+00.0013494s o:-00.0891868s [ * ]

  3. Para usuários avançados, consulte a configuração do W32time e verifique se os provedores de tempo estão configurados conforme o esperado. Se você usou o Método 1 como solução alternativa, poderá comparar a configuração pós-atualização com os dados de pré-configuração salvos. Por exemplo, a saída do comando é semelhante à seguinte:

    c:\ >w32tm /query /configuration /verbose > PostUpgradeW32timeConfiguration.txt

Referências

Para obter mais informações sobre problemas relacionados ao Netlogon, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft:
3201247 serviço Netlogon não retém as configurações após a atualização para o Windows Server 2016