Observação
O acesso a essa página exige autorização. Você pode tentar entrar ou alterar diretórios.
O acesso a essa página exige autorização. Você pode tentar alterar os diretórios.
Este artigo descreve um problema em que o arquivo CBS.log registra entradas quando um arquivo estático é alterado. Como o arquivo estático não é protegido pelo recurso Proteção de Recursos do Windows, o recurso relata a alteração no arquivo CBS.log.
Número original do KB: 954402
Sintomas
Você executa o utilitário SFC (Verificador de Arquivos do Sistema) (Sfc.exe) para verificar se há alterações nos arquivos de sistema do Windows em um computador baseado no Windows Server 2008. Ao executar o utilitário SFC, você pode receber a seguinte mensagem:
Todos os arquivos e chaves do Registro listados nesta transação foram reparados com êxito.
No entanto, ao exibir o arquivo %windir%\Logs\CBS\CBS.log gerado pelo programa Sfc.exe, você poderá ver as seguintes entradas:
<Data><Hora>, Informações CSI 00000142 [SR] Reparando 1 componentes
<Data><Hora>, Informações CSI 00000143 [SR] Iniciando a transação de verificação e reparo
<Data><e hora>, informações CSI 00000145 [SR] Não é possível reparar o arquivo de membro [l:18{9}]"img11.jpg" do Microsoft-Windows-Shell-Wallpaper-Common, versão = 6.0.5720.0, pA = PROCESSOR_ARCHITECTURE_INTEL (0), cultura neutra, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, tipo neutro, TypeName neutro, PublicKey neutro no repositório, incompatibilidade de hash
<Data><e hora>, informações CSI 00000147 [SR] Não é possível reparar o arquivo de membro [l:18{9}]"img11.jpg" de Microsoft-Windows-Shell-Wallpaper-Common, Versão = 6.0.5720.0, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Cultura neutra, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Tipo neutro, TypeName neutro, PublicKey neutro no repositório, incompatibilidade de hash
<Data><Hora>, Informações CSI 00000149 [SR] Reparação concluída
<Data><Hora>, Informações CSI 0000014a [SR] Confirmando transação
<Data><Hora>, Informações CSI 0000014e [SR] Verificar e reparar Transação concluída. Todos os arquivos e chaves do Registro listados nesta transação foram reparados com êxito
Motivo
Arquivos estáticos e arquivos mutáveis são os dois tipos de arquivos definidos no sistema. Arquivos estáticos não podem ser alterados. Arquivos mutáveis podem ser alterados. Arquivos de registro e arquivos de log são exemplos de arquivos mutáveis. O recurso WRP (Proteção de Recursos do Windows) não verifica arquivos mutáveis. O recurso WRP verifica arquivos estáticos quando o utilitário SFC verifica o computador. O recurso WRP ajuda a proteger a maioria dos arquivos estáticos. No entanto, nesse caso, o recurso WRP não protege o arquivo estático Img11.jpg. Se um arquivo estático for alterado quando o recurso WRP verificar o arquivo, a alteração será registrada no arquivo CBS.log. Como o recurso WRP não protege o arquivo estático Img11.jpg, o recurso WRP não tem outra opção a não ser relatar a alteração no arquivo CBS.log.
Mais informações
O programa Sfc.exe grava os detalhes de cada operação de verificação e de cada operação de reparo no arquivo CBS.log. Cada entrada de programa SFC.exe no arquivo CBS.log tem uma tag [SR].
Observação
O serviço Windows Modules Installer também grava no arquivo CBS.log. O serviço Windows Modules Installer instala recursos opcionais, atualizações e service packs.
Você pode pesquisar tags [SR] para ajudar a localizar SFC.exe entradas do programa. Para pesquisar tags [SR] e redirecionar os resultados da pesquisa para um arquivo de texto, siga estas etapas:
Clique em Iniciar, digite cmd na caixa Iniciar Pesquisa, clique com o botão direito do mouse em cmd na lista Programas e clique em Executar como administrador.
Se for solicitada uma senha de administrador ou confirmação, digite a senha ou clique em Continuar.
No prompt de comando, digite o seguinte comando e pressione ENTER:
findstr /c:"[SR]" %windir%\logs\cbs\cbs.log >sfcdetails.txt
Observação
O arquivo Sfcdetails.txt inclui as entradas que são registradas sempre que o programa SFC.exe é executado no computador.
Digite exit e pressione ENTER para fechar a janela do prompt de comando.
Coleta de dados
Se você precisar de ajuda do suporte da Microsoft, recomendamos coletar as informações seguindo as etapas mencionadas em Coletar informações usando o TSS para problemas relacionados à implantação.