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Este artigo fornece uma solução para um problema em que a Área de Trabalho Remota não pode se conectar a um computador remoto baseado em VDI (Virtual Desktop Infrastructure).
Aplica-se a: Windows 7 Service Pack 1, Windows Server 2008 R2 Service Pack 1
Número original do KB: 2820155
Sintomas
Depois de instalar o Adaptador de Vídeo 3D RemoteFX em uma máquina física baseada em VDI ou em uma máquina virtual hospedada em um servidor Hyper-V, quando você tenta se conectar à máquina usando a conexão de Área de Trabalho Remota, ele pode falhar. Além disso, você pode receber a mensagem de erro semelhante à seguinte:
A Área de Trabalho Remota não pode se conectar ao computador remoto por um dos seguintes motivos:
- O acesso remoto ao servidor não está habilitado
- O computador remoto está desligado
- O computador remoto não está disponível na rede
Verifique se o computador remoto está ligado e conectado à rede e que o acesso remoto está habilitado.
Você também pode receber o seguinte erro no Log de Eventos do Windows:
Nome do log: Microsoft-Windows-TerminalServices-LocalSessionManager/Operational
Fonte: Microsoft-Windows-TerminalServices-LocalSessionManager
Data: <Data><e hora>
ID do evento: 17
Nível: Erro
Usuário: SYSTEM
Computador: machinename.domain.com
Descrição:
Falha no início do Serviço de Área de Trabalho Remota. O código de status relevante foi 0x800706b5.
Observação
Você pode se conectar ao computador usando RDP se remover o Adaptador de Vídeo 3D RemoteFX da VM.
Causa
Com o lançamento do Service Pack 1 para Windows 7 e Windows Server 2008 R2, uma nova regra do Firewall do Windows foi adicionada para o RemoteFX. Esse problema ocorre se a regra do Firewall do Windows RemoteFX não estiver habilitada.
Para obter mais informações sobre o Microsoft RemoteFX, visite o seguinte site da Microsoft:
Resolução
Para resolver o problema, você deve habilitar a regra do Firewall do Windows RemoteFX manualmente.
Para habilitar a regra RemoteFX usando o Firewall do Windows com Segurança Avançada
- Clique no botão Iniciar e clique em Painel de Controle.
- Nas janelas do Painel de Controle, clique em Firewall do Windows.
- No painel esquerdo, clique em Permitir um programa ou recurso por meio do Firewall do Windows.
- Clique em Alterar configurações. Caso uma senha de administrador ou uma confirmação seja solicitada, digite a senha ou forneça a confirmação.
- Em Programas e recursos permitidos, marque a caixa de seleção ao lado de Área de Trabalho Remota - RemoteFX e use as caixas de seleção nas colunas para selecionar os tipos de local de rede nos quais você deseja permitir a comunicação.
- Clique em OK.
Como alternativa, se você habilitar a Área de Trabalho Remota usando a janela Propriedades do sistema, a regra será habilitada automaticamente.
Clique no botão Iniciar e clique em Painel de Controle.
Clique no ícone Sistema .
Em Página inicial do Painel de Controle, clique em Configurações remotas.
Clique na guia Remoto . Em Área de Trabalho Remota, selecione Não permitir conexões com este computador e clique em Aplicar.
Agora selecione qualquer uma das opções, dependendo de seus requisitos de segurança:
- Permitir conexões de computadores que executam qualquer versão da Área de Trabalho Remota (menos segura)
- Permitir conexões somente de computadores que executam a Área de Trabalho Remota com Autenticação em Nível de Rede (mais seguro)
Clique em Aplicar e depois em OK.
Mais informações
Você deve habilitar a regra do Firewall do Windows RemoteFX manualmente se habilitar a Área de Trabalho Remota da máquina VDI usando um dos métodos:
Usando o comando WMI:
wmic rdtoggle where (AllowTSConnections=0) call SetAllowTSConnections 1
Alternando o registro:
REG.exe ADD "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server" /v fDenyTSConnections /t REG_DWORD /d 0
Habilitando exceções de firewall para área de trabalho remota usando
netsh
o comando ou APIs do Firewall do Windows:netsh advfirewall firewall set rule group="remote desktop" new enable=Yes
Usando o script do PowerShell fornecido no Microsoft TechNet Script Center para configurar áreas de trabalho VDI.
Atualizando para o Windows 7 com SP1 em uma área de trabalho virtual que já tinha a Área de Trabalho Remota habilitada.