Observação
O acesso a essa página exige autorização. Você pode tentar entrar ou alterar diretórios.
O acesso a essa página exige autorização. Você pode tentar alterar os diretórios.
Este artigo fornece uma solução para um problema em que a alteração de status da chave Caps Lock disparada por um aplicativo em um computador remoto não é sincronizada de volta com o computador cliente.
Número original do KB: 3120433
Sintomas
Suponha que você se conecte a um computador remoto em uma sessão de área de trabalho remota. Se um aplicativo, como winword.exe ou osk.exe, alterar o status da tecla Caps Lock, essa alteração não será sincronizada de volta com o computador cliente.
Por exemplo, em uma sessão de área de trabalho remota, quando você abre o Microsoft Word, digite h, ative Caps Lock pressionando o teclado e digite ELLO, a palavra é hELLO. Em seguida, você pressiona a tecla Enter. Nessa situação, o hELLO no Word será corrigido para Hello automaticamente e o Caps Lock será desativado na sessão da área de trabalho remota. No entanto, no teclado físico do cliente, a luz Caps Lock ainda está acesa e ainda está no status Caps Lock On. Ele não está sincronizado com o status da tecla Caps Lock da sessão da área de trabalho remota.
Observação
O recurso do Word que aciona esse problema é chamado de uso acidental correto da teclaLOCK de cAPs nas opções de AutoCorreção .
Em uma sessão de área de trabalho remota em um computador baseado no Windows Server 2008 R2, se executarmos as mesmas etapas, a tecla Caps Lock no teclado físico do cliente também mudará para o status desativado, que é sincronizado com a sessão de área de trabalho remota.
Motivo
Esse problema ocorre porque o Windows Server 2012 e o Windows Server 2012 R2 usam o Dispositivo de Teclado da Área de Trabalho Remota para lidar com as entradas de teclado em sessões de área de trabalho remota.
Resolução
Para fazer com que o cliente e a sessão da área de trabalho remota sincronizem a tecla Caps Lock novamente, você precisa minimizar a janela da sessão da área de trabalho remota ou clicar com o mouse fora da janela da sessão da área de trabalho remota e, em seguida, clicar nela novamente.
Para aplicativos do Office, você pode desabilitar o uso acidental correto da tecla LOCK de cAPs nas opções de AutoCorreção para corrigir o problema. Por exemplo, siga estas etapas para o Word 2016.
- Inicie o Word 2016, selecione ARQUIVO e, em seguida, selecione Opções.
- Selecione Revisão.
- Selecione o botão Opções de AutoCorreção.
- Desmarque a caixa de seleção Corrigir uso acidental da tecla LOCK de cAPs.
- Clique em OK.