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Às vezes, a conexão da área de trabalho remota fica travada na tela Protegendo a conexão remota

Este artigo fornece uma solução para o problema em que a conexão da área de trabalho remota permanece no status conectando-se a.

Número original do KB: 2915774

Sintomas

Suponha um cenário no qual você use uma conexão de área de trabalho remota para o sistema operacional Windows 7 ou versões posteriores. Nesse cenário, a conexão da área de trabalho remota fica travada por vários segundos quando exibe os seguintes textos:

Conexões de Área de Trabalho Remota
Conectando-se a:
Protegendo a conexão remota...

O processo de conexão de uma área de trabalho remota.

Motivo

A conexão de área de trabalho remota usa o método de criptografia de nível de segurança mais alto possível entre a origem e o destino.

No Windows 7 ou versões posteriores, a conexão de área de trabalho remota usa o protocolo SSL (TLS 1.0) e a criptografia é baseada em certificado.

Isso significa que a autenticação é executada usando certificados autoassinados (padrão) ou um certificado emitido por uma autoridade de certificação instalada no servidor host de sessão remota (Terminal Server).

Se você usar um certificado autoassinado, o sistema tentará recuperar a lista de autoridades de certificação confiáveis da Internet para verificar o status de publicação e revogação do certificado. Portanto, a tela Protegendo a conexão remota pode aparecer por um tempo.

Solução alternativa

Para contornar esse comportamento, use um dos seguintes métodos:

Método 1

  • Se você estiver usando um certificado autoassinado, importe o certificado para a origem. Para fazer isso, siga estas etapas no destino:

    1. Entre como administrador no destino, selecione Iniciar, digite mmc na caixa Pesquisar programas e arquivos e execute o Console de Gerenciamento Microsoft.
    2. No menu Arquivo, selecione a opção Adicionar/Remover Snap-in.
    3. Na lista de snap-ins disponíveis, selecione Certificados e, em seguida, selecione o botão Adicionar.
    4. Na tela Snap-in de Certificado, marque a caixa de seleção Conta de computador e selecione Avançar.
    5. Na tela Selecionar Computador , selecione Computador Local e, em seguida, selecione o botão Concluir .
    6. Volte para a caixa de diálogo Adicionar/Remover Snap-In e selecione o botão OK .
    7. No painel esquerdo da janela do console, expanda Certificados de Rota>do Console (Computador Local)>Certificados de Área de Trabalho>Remota.
    8. Clique duas vezes no Certificado no painel do meio para abri-lo.
    9. Na guia Detalhe, selecione o botão Copiar para Arquivo....
    10. O Assistente para Exportação de Certificados será aberto. Deixe as configurações padrão e salve o arquivo em qualquer pasta.
    11. Copie o arquivo exportado para o computador de origem.
  • Em seguida, siga estas etapas na fonte:

    1. Entre como administrador na origem, selecione Iniciar, digite mmc na caixa Pesquisar programas e arquivos e execute o mmc.exe.

    2. Selecione o menu Arquivo e, em seguida, selecione a opção Adicionar/Remover Snap-in .

    3. Na lista de snap-ins disponíveis, selecione Certificados e, em seguida, selecione o botão Adicionar.

    4. Na tela Snap-in de Certificado, marque a caixa de seleção Conta de computador e selecione Avançar.

    5. Na tela Selecionar Computador , selecione Computador Local e, em seguida, selecione o botão Concluir .

    6. Volte para a caixa de diálogo Adicionar/Remover Snap-In e selecione o botão OK .

    7. No painel esquerdo da janela do console, expanda Certificados (Computador Local)>Certificados de Autoridades>de Certificação Raiz Confiáveis. Clique com o botão direito do mouse para selecionar Todas as Tarefas e, em seguida, selecione Importar... no menu.

    8. O Assistente de Importação de Certificado será aberto. Siga as instruções do assistente para iniciar a importação.

      1. Na janela Arquivo de certificado a ser importado, especifique o arquivo que foi copiado do computador de destino.

      2. Na janela Repositório de certificados, verifique se:

        • Colocar todos os certificados no repositório a seguir está selecionado
        • O Repositório de Certificados lista as Autoridades de Certificação Raiz Confiáveis.

    Observação

    Por padrão, o certificado autoassinado expira em seis meses. Se tiver expirado, o certificado será recriado. Você deve importar o certificado recriado para a origem novamente.

Método 2

Implante um Objeto de Política de Grupo no cliente para desativar a Atualização Automática de Certificados Raiz. Para fazer isso, siga estas etapas em um computador baseado no Windows Server 2012 R2:

  1. Abra o Console de gerenciamento de política de grupo. Para fazer isso, segure a tecla Windows e pressione a tecla r. Digite Gpmc.msc na caixa Executar e selecione OK.
  2. Crie um novo GPO (Objeto de Política de Grupo) ou selecione um GPO (Objeto de Política de Grupo) existente para alterar.
  3. Clique com o botão direito do mouse no GPO (Objeto de Política de Grupo) selecionado e selecione Editar e navegue até a seguinte Política de Grupo:
    Configuração>do computador Modelos>administrativos Sistema>Gerenciamento de comunicação com a Internet Configurações de>comunicação com a Internet
  4. No painel de detalhes, clique duas vezes em Desativar Atualização Automática de Certificados Raiz e selecione Habilitado.