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O SSO com pré-login falha durante o logon do usuário após uma reinicialização

Este artigo fornece uma solução para um problema em que o perfil de SSO (Logon Único) com pré-logon falha durante o logon do usuário após uma reinicialização.

Número original da base de conhecimento: 3063910

Sintomas

A autenticação 802.1x sem fio e com fio falhará na primeira tentativa de logon após uma reinicialização do sistema se o sistema cliente estiver configurado para usar um perfil SSO com pré-login. Nessa situação, o usuário recebe a seguinte mensagem de erro:

No momento, não há servidores de logon disponíveis para atender à solicitação de logon.

A janela de mensagem é semelhante à captura de tela a seguir.

A captura de tela mostra os servidores sem logon disponíveis para atender ao erro de solicitação de logon.

Motivo

Esse problema é causado por uma condição de corrida que ocorre durante a sequência de inicialização entre o filtro de logon PLAP (Pre-Logon Authentication Provider) e o serviço Wired Autoconfig (para conexões com fio) ou o serviço WLAN Autoconfig (para conexões sem fio). O filtro de logon consulta perfis de SSO. No entanto, se o respectivo serviço Autoconfig não for totalmente inicializado no momento da consulta, o cliente não será configurado para SSO. Portanto, os usuários não podem fazer logon usando o SSO.

Solução alternativa

Para contornar esse problema, conecte os usuários por meio de uma rede não protegida por 802.1x para armazenar em cache suas credenciais durante o primeiro logon.

Status

A Microsoft confirmou que esse é um problema nos produtos da Microsoft listados no início deste artigo.

Mais informações

Esse problema geralmente não ocorre. No entanto, se você encontrar esse problema, recomendamos que você abra um caso de suporte e colete as informações de log relevantes. Para fazer isso, siga estas etapas:

  1. Abra um prompt de comando com privilégios elevados.

  2. Execute o comando a seguir:

    netsh trace start persistent=yes overwrite=yes maxsize=4096 tracefile=c:\net_plap.etl provider={2CF38663-F760-46AC-AAFA-2DDE7F9DB417} keywords=0xffffffffffffffff level=0xff provider="Microsoft-Windows-L2NACP" keywords=0xffffffffffffffff level=0xff
    
  3. Reinicie o computador.

  4. Reproduza o problema de logon.

  5. Conecte-se a uma rede desprotegida para fazer logon com êxito e interromper o rastreamento. Para fazer isso, execute o seguinte comando:

    netsh trace stop
    

    Isso gera o arquivo de rastreamento: c:\net_plap.etl.