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O SSO com pré-início de sessão falha durante o início de sessão do utilizador após um reinício

Este artigo fornece uma solução para um problema em que o perfil de Início de Sessão Único (SSO) com pré-início de sessão falha durante o início de sessão do utilizador após um reinício.

Número original da BDC: 3063910

Sintomas

A Autenticação Sem Fios e Com Fios 802.1x falha na primeira tentativa de início de sessão após um reinício do sistema se o sistema cliente estiver configurado para utilizar um perfil SSO com pré-início de sessão. Nesta situação, o utilizador recebe a seguinte mensagem de erro:

Atualmente, não existem servidores de início de sessão disponíveis para atender ao pedido de início de sessão.

A janela da mensagem é semelhante à seguinte captura de ecrã.

Captura de ecrã a mostrar os servidores de início de sessão não disponíveis para atender ao erro de pedido de início de sessão.

Motivo

Este problema é causado por uma condição race que ocorre durante a sequência de arranque entre o filtro de início de sessão do Fornecedor de Autenticação pré-início de sessão (PLAP) e o serviço de Configuração Automática com Fios (para ligações com fios) ou o serviço de Configuração Automática WLAN (para ligações sem fios). As consultas de filtro de início de sessão para perfis SSO. No entanto, se o respetivo serviço de Configuração Automática não estiver totalmente inicializado no momento da consulta, o cliente não será configurado com SSO. Por conseguinte, os utilizadores não podem iniciar sessão com o SSO.

Solução alternativa

Para contornar este problema, ligue os utilizadores através de uma rede não protegida por 802,1x para colocar em cache as respetivas credenciais durante o primeiro início de sessão.

Status

A Microsoft confirmou que se trata de um problema nos produtos Microsoft listados no início deste artigo.

Mais informações

Normalmente, este problema não ocorre. No entanto, se encontrar este problema, recomendamos que abra um pedido de suporte e recolha as informações de registo relevantes. Para fazer isso, siga estas etapas:

  1. Abra um prompt de comando com privilégios elevados.

  2. Execute o seguinte comando:

    netsh trace start persistent=yes overwrite=yes maxsize=4096 tracefile=c:\net_plap.etl provider={2CF38663-F760-46AC-AAFA-2DDE7F9DB417} keywords=0xffffffffffffffff level=0xff provider="Microsoft-Windows-L2NACP" keywords=0xffffffffffffffff level=0xff
    
  3. Reinicie o computador.

  4. Reproduza o problema de início de sessão.

  5. Ligue a uma rede desprotegida para iniciar sessão com êxito e parar o rastreio. Para fazer isso, execute o seguinte comando:

    netsh trace stop
    

    Isto gera o ficheiro de rastreio: c:\net_plap.etl.