Configurar um novo projeto OpenXR com MRTK

A maneira mais fácil de configurar seu projeto do Unity para realidade misturada é com o MRTK (kit de ferramentas de Realidade Misturada). O MRTK para Unity é um kit de desenvolvimento multiplataforma de software livre projetado para facilitar a criação de aplicativos de realidade misturada incríveis.

Infográfico mostrando alguns dos recursos do kit de ferramentas Realidade Misturada.

O MRTK fornece um sistema de entrada multiplataforma, componentes básicos e blocos de construção comuns para interações espaciais. Ele pode ajudá-lo a acelerar o desenvolvimento de aplicativos para Microsoft HoloLens, Windows Mixed Reality headsets imersivos (VR) e muitos outros dispositivos VR/AR. O projeto visa reduzir as barreiras à entrada, permitindo que todos criem aplicativos de realidade misturada e contribuam de volta para a comunidade à medida que todos crescemos.

O MRTK dá suporte a uma ampla variedade de plataformas, incluindo:

  • Microsoft HoloLens

  • Microsoft HoloLens 2

  • Headsets do Windows Mixed Reality

  • Headsets do OpenVR (HTC Vive/Oculus Rift)

  • Acompanhamento de mãos Ultraleap

  • Dispositivos Android e iOS

Observação

Recentemente, apresentamos o MRTK3, a terceira geração do Microsoft Realidade Misturada Toolkit para Unity criada com base no sistema de Gerenciamento XR do Unity e no Kit de Ferramentas de Interação XR, com melhor suporte para uma variedade de dispositivos compatíveis com OpenXR e uma nova linguagem de design. Para obter mais informações, confira a documentação do MRTK3.

Observação

Você também pode configurar um novo projeto OpenXR sem MRTK.

Outras opções de configuração não OpenXR a serem consideradas

Windows XR: a Microsoft não recomenda usar o plug-in do Windows XR para novos projetos no Unity 2020. Em vez disso, você deve usar o plug-in Realidade Misturada OpenXR. No entanto, se você estiver usando o Unity 2019 e precisar do AR Foundation 2.0 para compatibilidade com dispositivos ARCore/ARKit, esse plug-in habilitará esse suporte.

Importante

O uso desse plug-in no Unity 2019 não é compatível com âncoras espaciais do Azure.

XR herdado:

Se você ainda estiver no Unity 2019 ou anterior, a Microsoft recomendará o uso do suporte XR interno herdado. Embora o plug-in do Windows XR esteja funcional no Unity 2019, não recomendamos isso porque ele não é compatível com âncoras espaciais do Azure no Unity 2019.

Se você estiver iniciando um novo projeto, recomendamos que você instale o Unity 2020 e use o plug-in Realidade Misturada OpenXR.

Introdução ao OpenXR: criar um novo projeto do Unity

  1. Inicie o Hub do Unity.

  2. Na guia Projetos, clique em Novo Projeto.

    Captura de tela do Hub do Unity na guia Projetos com o botão Novo Projeto realçado.

  3. Clique na lista suspensa abaixo de Novo projeto e selecione a versão do Editor desejada.

    Captura de tela do Hub do Unity com a lista suspensa Versão do editor exibida.

  4. Verifique se o modelo escolhido é 3D Core.

  5. Na caixa Nome do projeto, insira um nome para o projeto – por exemplo, "Tutorial de MRTK".

  6. Na caixa Local, clique no ícone de pasta, navegue até a pasta onde deseja salvar o projeto e selecione-a. Você também pode criar uma pasta.

    Captura de tela do Hub do Unity com 3D, Nome do Projeto, Local e Criar realçados.

  7. Clique em Criar projeto. Isso abre seu projeto no Unity.

    Captura de tela do seu projeto aberto no Unity.

Cuidado

Ao trabalhar no Windows, há um limite MAX_PATH de 255 caracteres. O Unity é afetado por esses limites e, caso qualquer caminho de arquivo tenha mais de 255 caracteres, a compilação poderá falhar. Portanto, recomendamos armazenar seu projeto do Unity o mais próximo possível da raiz da unidade.

Definir seu destino de build

  1. Na barra de menus, selecione Arquivo>Configurações de Build... .

    Para criar um aplicativo para Windows Mixed Reality, você deve escolher um destino de build. As configurações de build para Plataforma Universal do Windows (UWP) visam qualquer dispositivo, incluindo headsets imersivos como o HP Reverb G2. Essa é a melhor opção se você estiver criando para o HoloLens 2; no entanto, se você estiver direcionando o VR da área de trabalho, recomendamos que você use o pc, plataforma Autônoma do Mac & Linux .

  2. Realize um dos seguintes procedimentos:

    Se você estiver direcionando a VR da área de trabalho:

    • Mantenha o computador, a plataforma Autônoma do Mac & Linux , que é selecionada por padrão em um novo projeto do Unity:

    Captura de tela da janela Configurações de Build aberta no editor do Unity com PC, plataforma Autônoma do Mac & realçada

    Se você estiver direcionando o HoloLens 2:

    • Em Plataforma, selecione Plataforma Universal do Windows. Verifique se as seguintes configurações estão ativas:

    Tipo de Build: Projeto D3D

    Versão do SDK de Destino: Última instalação

    Versão Mínima da Plataforma: 10.0.10240.0

    Versão do Visual Studio: Última instalação

    Captura de tela da janela Configurações de Build aberta no editor do Unity com Plataforma Universal do Windows realçado.

  3. Clique no botão Alternar Plataforma. O Unity exibe uma barra de progresso enquanto alterna as plataformas.

  4. Depois que o processo de alternar plataforma for concluído, feche a janela Configurações de Build.

Baixar e instalar a Ferramenta de Recursos do Realidade Misturada

O Realidade Misturada Plug-in OpenXR vem na forma de um pacote para o Unity. A melhor maneira de descobrir, atualizar e importar pacotes de recursos é com a Ferramenta de Recursos Realidade Misturada. Você pode pesquisar pacotes por nome ou categoria, ver suas dependências e visualizar as alterações propostas no arquivo de manifesto do seu projeto antes de importar.

  1. Baixe a versão mais recente do Realidade Misturada Feature Tool no Centro de Download da Microsoft.

  2. Após a conclusão do download, navegue até o arquivo executável MixedRealityFeatureTool.exe e, em seguida, use-o para iniciar a Ferramenta de Recurso Realidade Misturada.

    Captura de tela de abertura do MixedRealityFeatureTool.

Importar os pacotes Realidade Misturada Toolkit e OpenXR

  1. Na Ferramenta de Recurso de Realidade Misturada, selecione Iniciar.

    Captura de tela da tela de abertura da Ferramenta de Recursos de Realidade Misturada.

  2. Selecione o botão Procurar (é o botão de "três pontos" na imagem abaixo), navegue até o seu projeto e abra-o.

    Abrir o projeto

    Observação

    A caixa Caminho do Projeto na Ferramenta deve conter um valor, portanto, ela insere uma barra invertida ("_") por padrão.

    Depois de selecionar uma pasta, a ferramenta verifica se é uma pasta de projeto do Unity válida.

    Captura de tela da tela do Caminho do projeto da ferramenta de recursos da Realidade Misturada.

  3. Selecione Descobrir Recursos.

    Observação: talvez seja necessário aguardar alguns segundos enquanto a ferramenta atualiza os pacotes dos feeds.

  4. Na página descobrir Recursos observe que há uma lista de seis grupos de pacotes.

    Os principais grupos de pacotes na Ferramenta de Recursos de Realidade Misturada

  5. Clique no botão "+" à esquerda de Kit de Ferramentas de Realidade Misturada Toolkit (0 de 10) e selecione a versão mais recente do pacote Mixed Reality Toolkit Foundation.

    Observação

    O pacote Mixed Reality Toolkit Foundation é o único que deve ser importado e configurado para usar o MRTK com seu projeto. Esse pacote inclui os componentes principais necessários para criar um aplicativo de realidade misturada.

  6. Clique no botão "+" à esquerda de Suporte à plataforma (0 de 5) e selecione a versão mais recente do Plug-in OpenXR de Realidade Misturada.

    Captura de tela de seleções de pacotes na Ferramenta de Recursos de Realidade Misturada.

  7. Depois de fazer suas seleções, clique em obter Recursos.

  8. Selecione Validar para validar o pacote. Você deverá ver uma caixa de diálogo informando que Nenhum problema de validação foi detectado. Quando ela aparecer, clique em OK.

  9. Na página importar Recursos, a coluna do lado esquerdo, Recursos, exibe os pacotes que você acabou de selecionar. A coluna do lado direito, Dependências Necessárias, exibe as dependências. Você pode clicar no link Detalhes em qualquer um desses itens para saber mais sobre eles.

  10. Quando estiver pronto para continuar, selecione Importar. Na página Examinar e Aprovar, você pode revisar as informações sobre os pacotes.

  11. Selecione Aprovar.

  12. Retorne ao editor do Unity e clique em uma área em branco na interface do usuário. Você verá uma barra de progresso mostrando que seus pacotes estão sendo importados.

Definir configurações de back-end de entrada

  1. Depois que o Unity importar o pacote, um aviso será exibido perguntando se você deseja habilitar os back-ends reiniciando o editor. Selecione Sim na barra superior.

    Captura de tela da opção de reinicialização do Unity.

Configurar o projeto para o HoloLens 2 por meio da Validação de Projeto (MR OpenXR 1.6+)

Se você estiver desenvolvendo para a VR da área de trabalho, ignore esta seção e vá para Configurar o projeto para VR da área de trabalho.

  1. Na barra de menus, clique em Realidade Misturada > Projeto > Aplicar configurações de projeto recomendadas para o HoloLens 2 para habilitar as regras de validação do HoloLens 2.
  2. Na janela de validação do projeto exibida, verifique se você está na guia plataforma UWP (indicada pelo logotipo do Windows) e clique em Corrigir tudo para resolver os problemas de validação. Observe que pode haver problemas que permanecem após clicar em Corrigir tudo. Nesse caso, tente clicar em Corrigir tudo novamente, ignore todos os problemas marcados como "específicos da cena" (se houver) e passe pelo restante dos problemas (se houver) para ver se há alguma alteração sugerida que você deseja fazer.
  3. O projeto está quase pronto para implantação do HoloLens 2 neste momento. Prossiga para Definir configurações do Player para a próxima etapa.

Configurar o projeto para o HoloLens 2 manualmente

Se você estiver desenvolvendo para a VR da área de trabalho, ignore esta seção e vá para Configurar o projeto para VR da área de trabalho.

  1. Verifique se a janela Configurações do Projeto está aberta. Caso contrário, na barra de menus, selecione Editar>Configurações do Projeto.

  2. Na janela Configurações do Projeto, verifique se você está na página Gerenciamento de Plug-in XR e na guia Plataforma Universal do Windows.

    Captura de tela da janela Configurações do Projeto aberta na página de Gerenciamento de Plugin XR e na guia Plataforma Universal do Windows.

  3. Verifique se Inicializar XR na inicialização está selecionado e, em provedores de Plug-in, clique em OpenXR.

    Captura de tela da janela Configurações do Projeto, dentro do Plataforma Universal do Windows, com Inicializar XR na Inicialização selecionado e o Plug-in OpenXR realçado.

  4. O Plug-in OpenXR é carregado e, em seguida, vários itens aparecem abaixo do OpenXR. Selecione Microsoft HoloLens grupo de recursos.

    Captura de tela da Janela de Configurações do Projeto com o plug-in OpenXR e o grupo de recursos Microsoft HoloLens realçado.

Observe que há um triângulo de aviso amarelo ao lado de OpenXR. Isso indica que você tem configurações incompatíveis que precisam ser resolvidas. Para descobrir como resolver isso, ignore a próxima seção sobre como configurar para VR e continue com a seção a seguir, Resolvendo configurações incompatíveis.

Configurar o projeto para VR da área de trabalho

  1. Verifique se a janela Configurações do Projeto está aberta. Caso contrário, vá para a barra de menus, selecione Editar>Configurações do Projeto.

  2. Na janela Configurações do Projeto , verifique se você está na página Gerenciamento de Plug-in do XR e no computador, & guia Mac Linux Autônomo .

    Captura de tela da janela Configurações do Projeto aberta para a Página de Gerenciamento de Plug-in XR e pc, & guia Mac Linux Autônomo.

  3. Verifique se Inicializar XR na inicialização está selecionado e, em provedores de Plug-in, clique em OpenXR.

    Captura de tela da janela Configurações do Projeto, dentro do computador, & guia Mac Linux Autônomo, com Inicializar XR na Inicialização selecionado e o Plug-in OpenXR realçado.

  4. O Plug-in do OpenXR é carregado e dois itens aparecem abaixo de OpenXR. Selecione o primeiro, Windows Mixed Reality grupo de recursos.

    Captura de tela da janela Configurações do Projeto realçado o Plug-in OpenXR e Windows Mixed Reality grupo de recursos.

Observe que agora há um triângulo amarelo de aviso ao lado de OpenXR. Isso indica que você tem configurações incompatíveis que precisam ser resolvidas. Para descobrir como resolver isso, prossiga para a próxima seção, Resolvendo configurações incompatíveis.

Resolvendo configurações incompatíveis

As imagens nesta seção mostram as opções na guia Plataforma Universal do Windows. No entanto, as instruções são as mesmas para a guia VR da área de trabalho, exceto quando indicado.

  1. Passe o cursor sobre o triângulo de aviso amarelo ao lado de OpenXR, leia a mensagem no pop-up e selecione o triângulo.

    Captura de tela de aviso sobre configurações incompatíveis.

  2. Na janela de Validação do Projeto do OpenXR , há vários problemas listados. Selecione o botão corrigir Tudo. OBSERVAÇÃO: essa lista pode parecer diferente dependendo de qual guia você está.

    Captura de tela do botão Corrigir Tudo na janela de Validação do Projeto OpenXR.

  3. Um problema permanece e informa que você deve adicionar pelo menos um perfil de interação. Para isso, clique em Editar. Você verá as configurações do Plug-in do OpenXR na janela Configurações do Projeto.

    Captura de tela da janela Configurações do Projeto com as configurações do OpenXR exibidas.

  4. Sob os Perfis de Interação, observe o botão com o sinal de mais (+).

    Captura de tela do botão Adicionar Perfil de Interação.

  5. Clique no botão três vezes, cada vez escolhendo um perfil diferente:

    Perfil de Interação do Foco Ocular

    Perfil de Interação Manual da Microsoft

    Perfil do Controlador de Movimento da Microsoft

    Captura de tela de perfis de interação que devem ser adicionados.

    Se o Perfil de Interação de Foco Ocular, ou qualquer outro perfil, aparecer com um triângulo amarelo ao lado dele, selecione o triângulo e, na janela Validação do Projeto do OpenXR, clique em Corrigir. Quando terminar, feche a janela de Validação do Projeto do OpenXR.

    Captura de tela do botão Corrigir do perfil de interação do Foco do Olho.

  6. Na janela de Configurações do Projeto, em Grupos de Recursos do OpenXR, verifique se os itens a seguir estão selecionados:

    Se você estiver na guia VR da área de trabalho:

    Windows Mixed Reality

    Acompanhamento da Mão

    Modelo do controlador de movimento

    Captura de tela dos Grupos de Recursos do OpenXR para a guia VR da Área de Trabalho.

    Se você estiver na guia Plataforma Universal do Windows:

    Microsoft HoloLens

    Acompanhamento da Mão

    Modelo do controlador de movimento

    Captura de tela dos recursos selecionados para o OpenXR.

  7. Clique no menu suspenso Modo de Envio em Profundidade e selecione Profundidade de 16 bits.

    Captura de tela da profundidade de 16 bits selecionada para o Modo de Envio de Profundidade.

    Dica

    Reduzir o formato de intensidade para 16 bits é opcional, mas pode melhorar o desempenho de gráficos em seu projeto. Para saber mais, confira Compartilhamento de buffer de profundidade (HoloLens).

    Observação

    A configuração do Modo de Renderização, localizada logo acima do Modo de Envio e, Profundidade, é definida por padrão para Uma Única Instância do Pass. Em aplicativos de realidade misturada, a cena é renderizada duas vezes, uma para cada olho do usuário. O resultado é uma "visão estereoscópica". Isso dobra a quantidade de computação necessária, portanto, é importante selecionar o caminho de renderização mais eficiente no Unity para economizar em tempo de CPU e GPU. A renderização de passagem única em instância é a melhor opção aqui – recomendamos que você habilite-a por padrão para cada projeto. Para saber mais sobre isso, veja a documentação do Unity.

Definir configurações do Player

  1. Na coluna do lado esquerdo da janela de Configurações do Projeto, selecione Player.

  2. Observe que, na janela Player , a caixa Nome do Produto já está preenchida. Isso é obtido do nome do projeto e será o nome exibido no menu Iniciar do HoloLens.

    Captura de tela das Configurações de Publicação do Unity com a caixa Nome do Projeto preenchida.

    Dica

    Para facilitar a localização do aplicativo durante o desenvolvimento, adicione um sublinhado na frente do nome para classificá-lo na parte superior de qualquer lista.

  3. Clique na lista suspensa Configurações de Publicação e, no campo Nome do pacote, insira um nome adequado.

    Captura de tela das Configurações de Publicação do Unity com a caixa nome do pacote preenchida.

    Observação

    O nome do pacote é o identificador exclusivo do aplicativo. Para evitar a substituição de versões instaladas anteriormente do aplicativo com o mesmo nome, altere esse identificador antes de implantar o aplicativo.

  4. Feche a janela Configurações de Projeto.

Agora você está pronto para começar a desenvolver com o OpenXR no Unity!

Projetos de exemplo do Unity

Confira o repositório de exemplos do OpenXR Realidade Misturada para projetos de exemplo do Unity mostrando como criar aplicativos do Unity para headsets holoLens 2 ou Realidade Misturada usando o plug-in OpenXR Realidade Misturada.

Confira também