2. Configurar o Photon Unity Networking

Neste tutorial, você vai se preparar para criar uma experiência compartilhada usando o PUN (Photon Unity Networking). Você aprenderá a criar um aplicativo PUN, importar ativos PUN para seu projeto do Unity e conectar seu projeto do Unity ao aplicativo PUN.

Objetivos

  • Saiba como criar um aplicativo PUN
  • Saber como encontrar e importar os ativos PUN
  • Saiba como conectar seu projeto do Unity ao aplicativo PUN

Como criar e preparar o projeto do Unity

Nesta seção, você criará um projeto do Unity e o deixará pronto para o desenvolvimento do MRTK.

Primeiro, siga Como inicializar seu projeto e implantar o primeiro aplicativo (excluindo as instruções contidas em Adição de interação manual a um objeto e Criar aplicativo para o seu dispositivo) que incluem as seguintes etapas:

  1. Criar um projeto do Unity e dar a ele um nome adequado, por exemplo, Tutoriais do MRTK
  2. Como alternar a plataforma de build
  3. Como importar os Recursos Essenciais do TextMeshPro
  4. Como importar o Kit de ferramentas de Realidade Misturada e configurar o projeto do Unity
  5. Criação da cena e configuração do MRTK e defina um nome adequado à cena, por exemplo, MultiUserCapabilities

Em seguida, siga as instruções em Alterar a opção de exibição de reconhecimento espacial para:

  1. Alterar o perfil de configuração do MRTK para DefaultHoloLens2ConfigurationProfile
  2. Alterar as opções de exibição da malha de reconhecimento espacial para Oclusão.

Como habilitar funcionalidades adicionais

No menu do Unity, selecione Editar>Configurações de projeto... para abrir a janela Configurações do Player, então localize a seção Player>Configurações de Publicação:

Unity Player settings

Em Configurações de Publicação, role o painel para baixo até a seção Funcionalidades e verifique novamente se as funcionalidades InternetClient, Microphone, SpatialPerception e GazeInput, que você habilitou durante a etapa Como configurar o projeto do Unity acima, estão habilitadas.

Em seguida, habilite as seguintes funcionalidades adicionais:

  • Funcionalidade InternetClientServer
  • Funcionalidade PrivateNetworkClientServer

Unity Capabilities settings

Como importar os ativos do tutorial

Baixe e importe os seguintes pacotes personalizados do Unity na ordem em que estão listados:

Dica

 Para obter um lembrete sobre como importar um pacote personalizado do Unity, você pode consultar as instruções Como importar os ativos de tutorial.

Observação

Depois de importar o pacote de ativos do tutorial de MultiUserCapabilities, você verá vários erros CS0246 na janela do console informando que o tipo ou o namespace está ausente. Isso deve ser esperado e será resolvido na próxima seção quando você importar os ativos PUN.

Como importar os ativos PUN

No menu do Unity, selecione Janela>Asset Store para abrir a janela da Asset Store, pesquise e selecione PUN 2 – GRATUITO em Sair dos Jogos e clique no botão Baixar para baixar o pacote de ativos para a sua conta do Unity.

Quando o download for concluído, clique no botão Importar para abrir a janela Importar Pacote do Unity:

Unity Asset Store with PUN 2 - Free

Na janela Importar Pacote do Unity, clique no botão Todos para garantir que todos os ativos sejam selecionados e clique no botão Importar para importar os ativos:

Unity with PUN 2 import window

Depois que o Unity concluir o processo de importação, a janela do Assistente do PUN será exibida com o menu Instalação do PUN carregado; ignore ou feche essa janela por enquanto:

Unity with PUN Setup window

Como criar o aplicativo PUN

Nesta seção, você criará uma conta do Photon, se ainda não tiver uma, e criará um aplicativo PUN.

Navegue até o painel do Photon e entre nele caso já tenha uma conta que deseja usar; caso contrário, clique no link Criar Uma e siga as instruções para registrar uma nova conta:

Photon login page

Depois que estiver conectado, clique no botão Criar um Aplicativo:

Photon dashboard welcome page

Na página Criar um Aplicativo, insira os seguintes valores:

  • Para o tipo Photon, selecione PUN
  • Em Nome, insira um nome adequado, por exemplo, Tutoriais do MRTK
  • Em Descrição, opcionalmente, insira uma descrição adequada
  • Em URL, deixe o campo vazio

Em seguida, clique no botão Criar para criar o aplicativo:

Photon create application page

Depois que o Photon tiver concluído o processo de criação, o novo aplicativo PUN será exibido no painel:

Photon application page

Como conectar o projeto do Unity ao aplicativo PUN

Nesta seção, você conectará seu projeto do Unity ao aplicativo PUN criado na seção anterior.

No painel do Photon, clique no campo ID do Aplicativo para revelar a ID do aplicativo e, em seguida, copie-o para a área de transferência:

Photon application page with App Id selected

No menu do Unity, selecione Janela>Photon Unity Networking>Assistente do PUN para abrir a janela do Assistente do PUN, clique no botão Projeto de Instalação para abrir o menu Instalação do PUN e configure-o da seguinte maneira:

  • No campo ID do Aplicativo ou Email, cole a ID do aplicativo PUN copiado na etapa anterior

Em seguida, clique no botão Projeto de Instalação para aplicar a ID do aplicativo:

Unity PUN Setup window with AppId filled in

Depois que o Unity terminar o processo de instalação do PUN, o menu Instalação do PUN exibirá a mensagem Concluído! e selecionará automaticamente o ativo PhotonServerSettings na janela Projeto, de modo que as propriedades dele sejam exibidas na janela Inspetor:

Unity PUN Setup window with Setup Project applied

Parabéns

Você criou um aplicativo PUN com êxito e o conectou ao seu projeto do Unity. A próxima etapa será permitir conexões com outros usuários para que vários usuários possam ver uns aos outros.