AI models fail to be imported in a new environment
This article provides a solution to an error that occurs when AI models fail to be imported in a new environment.
Applies to: Power Automate, Power Apps
Symptoms
Your AI models fail to be imported in a new environment.
Cause
AI models are in an error state after importing them in a new environment.
Resolution
Follow these steps to try to resolve the issue:
- Uninstall the solution containing the model(s).
- If your solution is unmanaged, manually delete the models on the AI Builder model page.
- Reinstall the solution containing the model(s).
- Wait for the end of the Importing state for each model.
If these steps don't resolve your issue, you can try to update to a new version of the model:
- Run a new training in the "source" environment.
- When the training is complete, publish the model.
- Export the model to a new version of the solution.
- Import the new solution version into the "target" environment.
If the problem persists (for example, no new model gets fixed by this sequence), contact the support team.
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