При переходе по гиперссылке в программе Outlook появляется сообщение об ошибке

Симптомы

Примечание.

После установки обновлений системы безопасности Outlook Desktop от 11 июля при открытии ссылки в сообщении электронной почты, если путь указывает на полное доменное имя (FQDN) или IP-адрес, вы не сможете открыть ссылку или получить следующее сообщение об ошибке:

Что-то непредвиденное пошло не так с этим URL-адресом

Дополнительные сведения об этой проблеме см. в статье Outlook блокирует открытие гиперссылок полного доменного имени и IP-адресов после установки средств защиты для уязвимости обхода компонентов безопасности Microsoft Outlook, выпущенной 11 июля 2023 г.

Предположим, что Internet Explorer является браузером по умолчанию в системе Windows. При переходе по гиперссылке в Microsoft Outlook отображается одно из следующих сообщений об ошибке в зависимости от версии Outlook:

Операция отменена вследствие действующих на компьютере ограничений. Обратитесь к системному администратору.

Политики организации запрещают автоматическое выполнение этого действия. Для получения дополнительных сведений обратитесь в службу поддержки.

Решение

Для решения этой проблемы воспользуйтесь приведенными ниже способами в указанном порядке. Проверяйте, устранена ли проблема, после использования каждого способа.

Метод 1. Сброс параметров Internet Explorer

Internet Explorer 11 и Internet Explorer 10

Предупреждение

Если вы используете операционную систему Windows 10, Windows 8.1 или Windows 8, перейдите к методу 2.

  1. Запустите Internet Explorer.

  2. Выберите Сервис>Свойства браузера.

  3. Выберите Дополнительно>Сброс.

    Снимок экрана с вкладкой

  4. В окне Сброс параметров настройки Internet Explorer последовательно выберите Удалить личные параметры>Сброс.

    Снимок экрана окна

  5. После завершения нажмите кнопку Закрыть.

    Снимок экрана с параметром

  6. Закройте и перезапустите Internet Explorer.

  7. Выберите Сервис>Свойства браузера.

  8. Выберите Программы>Задать программы.

    Снимок экрана с вкладкой

  9. Выберите Задание программ по умолчанию.

    Снимок экрана с параметром

  10. В списке Программы выберите Microsoft Outlook>Использовать эту программу по умолчанию.

    Снимок экрана окна

  11. Прокрутите список программ по умолчанию вверх, выделите Internet Explorer и нажмите Использовать эту программу по умолчанию.

    Снимок экрана окна

  12. Нажмите кнопку ОК и закройте диалоговое окно Программы по умолчанию.

Internet Explorer 9

  1. Запустите Internet Explorer.

  2. Выберите Сервис>Свойства браузера.

  3. Выберите Дополнительно>Сброс.

    Снимок экрана с кнопкой

  4. В окне Сброс параметров настройки Internet Explorer последовательно выберите Удалить личные параметры>Сброс.

    Снимок экрана с параметром

  5. После завершения нажмите кнопку Закрыть.

    Снимок экрана с параметром

  6. Перезапуск браузера Internet Explorer

  7. Выберите Сервис>Свойства браузера.

  8. Выберите Программы>Задать программы.

    Снимок экрана с параметром

  9. Выберите Задание программ по умолчанию.

    Снимок экрана с заданным параметром

  10. В списке Программы выберите Microsoft Outlook>Использовать эту программу по умолчанию.

  11. Нажмите кнопку ОК и закройте диалоговое окно Программы по умолчанию.

  12. В диалоговом окне Свойства браузера откройте вкладку Программы и выберите Использовать по умолчанию в разделе Браузер по умолчанию.

    Снимок экрана с вкладкой

  13. Нажмите кнопку ОК.

Internet Explorer 8 и Internet Explorer 7

  1. Запустите Internet Explorer.
  2. В меню Сервис выберите Свойства браузера.
  3. Выберите Дополнительно>Сброс.
  4. Выберите Программы>Задать программы.
  5. Нажмите Задание программ по умолчанию.
  6. Выберите пункт Microsoft Outlook>Использовать эту программу по умолчанию.
  7. Нажмите кнопку ОК и закройте диалоговое окно Программы по умолчанию.
  8. В диалоговом окне Свойства браузера откройте вкладку Программы и выберите Использовать по умолчанию в разделе Браузер по умолчанию.
  9. Нажмите OK.

Internet Explorer 6

  1. Запустите Internet Explorer.

  2. В меню Сервис выберите Свойства браузера.

  3. Выберите Программы>Сброс веб-параметров.

  4. Убедитесь, что в разделе Программы Интернета выбрана верная программа электронной почты.

  5. Установите флажок Проверять, является ли Internet Explorer используемым по умолчанию браузером.

  6. Нажмите Применить>OK.

    Примечание.

    При запуске браузера Internet Explorer может появиться следующее сообщение:
    Internet Explorer не является используемым по умолчанию браузером. Использовать его в качестве обозревателя по умолчанию?

    При получении такого сообщения нажмите кнопку Да.

Метод 2. Экспорт и импорт раздела реестра с другого компьютера

Этот раздел предназначен для опытных пользователей. Для получения помощи по расширенному устранению неполадок обратитесь к системному администратору или в службу поддержки Майкрософт.

Важно!

Точно следуйте всем указаниям из этого раздела. Внесение неправильных изменений в реестр может привести к возникновению серьезных проблем. Прежде чем приступить к изменениям, создайте резервную копию реестра для восстановления на случай возникновения проблем.

Примечание.

Используйте этот способ только в том случае, если приведенные выше рекомендации для используемой версии браузера не помогли решить проблему.

Шаг 1. Экспорт разделов реестра с другого компьютера

  1. На компьютере, где подобная проблема не возникает, нажмите Пуск>Выполнить.

  2. В поле Открыть введите regedit и нажмите кнопку ОК.

  3. Найдите и выделите следующий подраздел реестра: HKEY_LOCAL_MACHINE\Software\Classes\htmlfile\shell\open\command.

  4. В меню Файл или Реестр (в зависимости от операционной системы) выберите Экспорт.

    Снимок экрана меню

  5. Запишите расположение для сохранения файла.

  6. Введите уникальное имя файла, затем нажмите Сохранить.

  7. Закройте редактор реестра.

Шаг 2. Импорт раздела реестра

  1. Скопируйте экспортированный раздел реестра на рабочий стол компьютера с проблемой.

  2. Дважды щелкните REG-файл.

    Появится следующее сообщение:

    Windows 10, Windows 8.1 и Windows 8

    Добавление сведений может привести к непреднамеренному изменению или удалению значений и неправильной работе компонентов. Если вы не доверяете источнику этих сведений в папке C:Users<yourlogon>Desktop\regkey.reg, не добавляйте его в реестр.

    Windows 7

    Вы действительно хотите добавить информацию из "диск: место_куда скопирован_файл\имя_файла.reg" в реестр?

  3. Последовательно нажмите Да>OK.

Шаг 3. Убедитесь, что значение string (default) ключа HKEY_CLASSES_ROOT .html имеет значение htmlfile.

  1. Щелкните последовательно Пуск>Выполнить.

  2. В поле Открыть введите regedit и нажмите кнопку ОК.

  3. Найдите и выберите подраздел реестра : HKEY_CLASSES_ROOT \.html.

  4. Убедитесь, что значение string (default) — htmlfile. Если это значение отличается от htmlfile, щелкните правой кнопкой мыши параметр (По умолчанию), выберите команду Изменить, введите htmlfile в поле Значение и нажмите кнопку ОК.

  5. Закройте редактор реестра.