Ошибка разрешения "80040220" при импорте или удалении решения в Microsoft Dynamics 365
Эта статья содержит решение ошибки, возникающее при импорте или удалении решения в Microsoft Dynamics 365.
Применимо к: Microsoft Dynamics 365
Исходный номер базы знаний: 4456770
Симптомы
При попытке установить решение в Dynamics 365 отображается следующее сообщение:
"Не удалось импортировать решение: [имя решения].
Код ошибки 80040220"
В разделе подробных данных показано следующее сообщение:
"У вас нет разрешения на доступ к этим записям. Обратитесь к администратору Microsoft Dynamics 365".
При попытке удалить решение отображается следующее сообщение:
"Недостаточно разрешений
У вас нет разрешения на доступ к этим записям..."
Причина
Эта ошибка возникает, если отсутствуют необходимые привилегии для установки или удаления решения. Эта проблема также может возникнуть, если у вас нет назначенной лицензии.
Решение
Чтобы успешно удалить решение, получите доступ к Dynamics 365 в качестве пользователя с ролью безопасности системного администратора или настройщика системы. Кроме того, убедитесь, что назначена лицензия.
Дополнительные сведения
Если необходимо удалить решение с помощью настраиваемой роли безопасности, нажмите кнопку "Скачать файл журнала" в этой ошибке, чтобы просмотреть сведения о том, какие привилегии отсутствуют. Файл журнала будет содержать сведения об ошибке, например в следующем примере:
"Основной пользователь (Id=<ID>, type=8) отсутствует привилегия prvCreateWebResource (Id=<ID>)"
В приведенном выше примере сообщения указывается, что у пользователя отсутствует привилегия "Создать" для сущности веб-ресурса. Дополнительные сведения об изменении роли безопасности см. в разделе "Изменение роли безопасности".
Примечание.
Если системный администратор предоставляет доступ к отсутствующим привилегиям и импорт продолжает завершаться сбоем с этой ошибкой, продолжайте просматривать журнал ошибок, чтобы узнать, какие другие привилегии отсутствуют.