Ошибка разрешения "80040220" при импорте или удалении решения в Microsoft Dynamics 365

В этой статье описано, как устранить ошибку, возникающую при импорте или удалении решения в Microsoft Dynamics 365.

Применимо к: Microsoft Dynamics 365
Исходный номер базы знаний: 4456770

Симптомы

При попытке установить решение в Dynamics 365 отображается следующее сообщение:

"Сбой импорта решения: [имя решения].
Код ошибки 80040220"

В разделе подробных сведений показано следующее сообщение:

"У вас нет разрешения на доступ к этим записям. Обратитесь к администратору Microsoft Dynamics 365".

При попытке удалить решение отображается следующее сообщение:

"Недостаточные разрешения
У вас нет разрешения на доступ к этим записям..."

Причина

Эта ошибка возникает, если отсутствуют необходимые привилегии для установки или удаления решения. Эта проблема также может возникнуть, если вам не назначена лицензия.

Разрешение

Чтобы успешно удалить решение, получите доступ к Dynamics 365 как пользователь с ролью безопасности "Системный администратор" или "Настройщик системы". Также убедитесь, что у вас назначена лицензия.

Дополнительная информация

Если вам нужно удалить решение с помощью настраиваемой роли безопасности, нажмите кнопку Скачать файл журнала в ошибке, чтобы просмотреть сведения о том, какие привилегии отсутствуют. Файл журнала будет содержать сведения об ошибке, например следующий пример:

"Основной пользователь (Id=<ID>, type=8) отсутствует привилегия prvCreateWebResource (Id=<ID>)"

В приведенном выше примере сообщения указано, что у пользователя отсутствует привилегия "Создать" для сущности веб-ресурса. Дополнительные сведения об изменении роли безопасности см. в разделе Изменение роли безопасности.

Примечание.

Если системный администратор предоставляет доступ к отсутствующим привилегиям и импорт продолжает завершать сбой с этой ошибкой, продолжайте просматривать журнал ошибок, чтобы узнать, какие другие привилегии отсутствуют.