"Предоставить управление" не работает при совместном использовании экрана в Teams
Симптомы
Вы делитесь экраном с другим пользователем на настольном клиенте Microsoft Teams, а другой пользователь запрашивает управление вашим экраном. В этой ситуации вы видите запрос пользователя на панели инструментов Общего доступа. Однако вы не видите вариант одобрить или отклонить запрос. Даже меню "Предоставить управление" не реагирует при попытке его открыть.
Причина
Эта проблема возникает из-за того, что используемое устройство не имеет установленного графического процессора (GPU), а ускорение аппаратного обеспечения GPU отключено. Раскрывающееся меню "Предоставление управления" не работает, если аппаратное ускорение не поддерживается в системе. Такое поведение является особенностью данного продукта.
Решение
Чтобы предотвратить такое поведение, убедитесь, что ваша система поддерживает аппаратное ускорение. Чтобы проверить то же самое, вы можете просмотреть edge://gpu/
в Microsoft Edge или chrome://gpu/
в Google Chrome. Если вы видите, что в нем для какого-либо значения установлено "только программное обеспечение" или "аппаратное ускорение недоступно", это означает, что система не поддерживает его. Для получения дополнительных сведений мы рекомендуем обратиться к поставщику оборудования.
Дополнительная информация
При возникновении этой проблемы в журналах клиентов Teams можно увидеть следующую информацию:
info -- [screenSharing][control] appSharingToolbar: AppSharingToolbar created with hardware acceleration: false
Примечание
Чтобы собрать журналы на компьютере с Windows, перейдите к %appdata%\Microsoft\Teams\media-stack\*.*
. На компьютере с Mac перейдите к ~Library/Application Support/Microsoft/Teams/media-stack/*.*
.
Требуется дополнительная помощь? Зайдите на сайт сообщества Майкрософт.