Службы отчетов в SQL Server Data Tools (SSDT)

Применимо к: SQL Server 2016 (13.x) и более поздние версии службы отчетов (Reporting Services)

SQL Server Data Tools (SSDT) — это среда Microsoft Visual Studio для создания решений бизнес-аналитики. SSDT включает среду разработки отчетов конструктор отчетов. Вы можете использовать конструктор отчетов для открытия, изменения, предварительного просмотра, сохранения и развертывания определений отчетов с разбивкой на страницы SQL Server Reporting Services (SSRS), общих источников данных, общих наборов данных и частей отчета.

Примечание.

Фрагменты отчетов объявлены устаревшими во всех выпусках SQL Server Reporting Services, начиная с SQL Server Reporting Services 2019, и во всех выпусках Сервер отчетов Power BI, начиная с Сервер отчетов Power BI September 2022.

В этой статье описываются решения SSDT, проекты, шаблоны проектов и конфигурации, используемые для SSRS. В нем также описываются представления, меню, панели инструментов и ярлыки, которые можно использовать в конструктор отчетов.

Установка SSDT

SSDT не входит в состав SQL Server. Необходимо установить SSDT отдельно. Инструкции см. в разделе "Установка SSDT" с помощью Visual Studio.

Чтобы использовать шаблоны конструктор отчетов, также необходимо установить расширение SSRS для Visual Studio. Инструкции см. в разделе "Установка расширений" для служб Analysis Services, Integration Services и Reporting Services.

Чтобы приступить к разработке отчетов, см. статью Создание разбитых на страницы отчетов Reporting Services в конструкторе отчетов (SSRS).

Проекты и решения

Проект отчета выступает в качестве контейнера для определений отчета и ресурсов. Когда проект развернут, каждый файл проекта отчета публикуется на сервере отчетов. При первом создании проекта также создается решение в качестве контейнера для проекта. К одному решению можно добавить несколько проектов.

Конфигурации

Чтобы создать несколько наборов свойств проекта для вариантов развертывания, таких как корпоративные, тестовые и рабочие серверы отчетов, используйте функцию Configuration Manager в Visual Studio. Дополнительные сведения см. в разделе "Развертывание и поддержка версий" в SQL Server Data Tools (SSRS).

Проекты сервера отчетов

При установке расширения SSRS для Visual Studio, как описано ранее в установке SSDT, доступны следующие шаблоны проектов в SSDT:

  • Проект сервера отчетов. При использовании шаблона проекта сервера отчетов конструктор отчетов откроется. Этот шаблон проекта бизнес-аналитики можно найти в диалоговом окне "Создание проекта ". Дополнительные сведения см. в разделе "Создание проекта сервера отчетов".

    Свойства проекта сервера отчетов применяются ко всем отчетам и всем общим источникам данных в проекте SSDT. В число этих свойств входит URL-адрес сервера отчетов и имена папок для отчетов и общих источников данных. Диалоговое окно "Страницы свойств проекта" можно использовать для просмотра текущих значений свойств. Чтобы открыть это диалоговое окно, перейдите в меню "Проект " и выберите пункт "Свойства".

  • Мастер проекта сервера отчетов. При использовании шаблона проекта мастера сервера отчетов проект сервера отчетов создается автоматически, и откроется мастер отчетов. В мастере можно создать отчет, следуя инструкциям на каждой странице. Инструкции описывают, как:

    • Создайте строка подключения в источник данных.
    • Задайте учетные данные источника данных.
    • Создайте запрос.
    • Добавьте область данных таблицы или матрицы.
    • Укажите данные отчета и группы.
    • Выберите шрифт и стиль цвета.
    • Опубликуйте отчет на сервере отчетов.
    • Просмотрите отчет локально.

    После создания отчета с помощью мастера можно изменить данные отчета и структуру отчета с помощью конструктор отчетов в проекте сервера отчетов.

Окна и панели конструктора отчетов

конструктор отчетов предлагает несколько окон и панелей, которые помогают создавать отчеты и просматривать отрисованные отчеты.

Область данных отчета

В области данных отчета отображаются объекты данных, которые можно использовать в отчете.

Чтобы открыть область данных отчета, необходимо перевести фокус в область разработки. Затем в меню "Вид " выберите "Данные отчета".

На панели данных отчета доступны следующие типы объектов:

  • Встроенные поля. Эти поля содержат предопределенные сведения о отчете, такие как имя отчета или время обработки отчета.
  • Источники данных. Источник данных представляет имя и сведения о подключении для источника данных.
  • Наборы данных. Каждый набор данных содержит запрос, указывающий, какие данные следует извлечь из источника данных. Вы можете развернуть набор данных, чтобы просмотреть коллекцию полей, заданных запросом набора данных. В некоторых конструкторах запросов для многомерных наборов данных на панели «Фильтры» можно задать фильтры и указать, следует ли создавать параметры отчета. Если указать параметр отчета, автоматически создается специальный набор данных для заполнения списка допустимых значений параметра. По умолчанию набор данных не отображается в области данных отчета. Дополнительные сведения см. в разделе "Показать скрытые наборы данных" для значений параметров — многомерных данных.
  • Параметры отчета. Параметры отчета можно создавать вручную или автоматически, если запрос набора данных включает параметры запроса.
  • Изображения. Изображения из этого списка можно включить в отчет как элементы отчета типа «Изображение».

Источники и наборы данных в области данных отчета представляют элементы в определении отчета. Область данных отчета — это функция, которая поддерживает несколько сред разработки отчетов.

  • В построитель отчетов это единственная область, доступная для управления источниками данных и наборами данных.
  • В конструкторе отчетов область данных отчета работает вместе с обозревателем решений, в котором общие источники и наборы данных отображаются в виде файлов. Общие источники данных и общие наборы данных на панели "Данные отчета" должны ссылаться на соответствующие общие источники данных и общие наборы данных в обозревателе решений. Элементы панели «Данные отчета» затем содержат ссылки на файлы данных в обозревателе решений. Свойства проекта определяют, должны ли общие источники и наборы данных развертываться на сервере отчетов или на сайте SharePoint. Дополнительные сведения см. в разделе "Преобразование источников данных" (построитель отчетов и SSRS).

Если область данных отчета отображается как плавающее окно, ее можно закрепить. Дополнительные сведения см. в разделе "Закрепление данных отчета" в конструктор отчетов (SSRS).

Панель группирования

Область группирования используется для определения групп для области данных табликса. Можно определить группы строк и группы сведений для таблиц, а также определить группы строк и столбцов для матриц. Панель группирования нельзя использовать для определения групп для диаграмм или других регионов данных. Дополнительные сведения см. в разделе Группы в отчете с разбивкой на страницы в Построителе отчетов.

Панель группирования имеет два режима:

  • По умолчанию. Режим по умолчанию используется для отображения всех групп строк и столбцов в иерархическом формате, в котором показаны связи между родительскими группами, дочерними группами, смежными группами и группами сведений. Дочерняя группа отображается под родительской группой со сдвигом вправо на один уровень отступа. Смежная группа отображается на том же уровне отступа, что и соседние или родственные группы.

    Вы также используете режим по умолчанию для добавления, редактирования или удаления групп. Для групп на основе одного поля набора данных перетащите поле в область "Группы строк" или "Группы столбцов". Вы можете вставить группу рядом с существующей группой. Чтобы добавить смежную группу, используйте контекстное меню группы с братом. Чтобы отобразить ячейки табликса, принадлежащие группе, выберите группу в области группировки.

  • Расширенный Вы используете расширенный режим для отображения статических и динамических элементов группы строк и столбцов выбранной области данных табликса. В расширенном режиме можно также задать свойства, управляющие видимостью строк и столбцов, связанных с группой или членом группы. Эти свойства определяют правила, используемые отрисовщиками, чтобы попытаться объединить группы на странице. Элементы группы отображаются на поверхности конструктора в виде ячеек в областях группировки строк и столбцов.

Примечание.

Чтобы переключиться между режимами по умолчанию и расширенными режимами, щелкните правой кнопкой мыши стрелку вниз справа от значка "Группы столбцов ".

Дополнительные сведения см. в разделе Панель группировки.

Панель инструментов

Область «Панель элементов» содержит элементы отчета, которые можно перетащить в область разработки.

  • Области данных — это элементы отчета, с помощью которых упорядочиваются данные отчета. Примеры областей данных включают таблицу, матрицу, список, диаграмму, датчик, панель данных, спарклайн и индикатор.
  • Другие элементы отчета включают карту, текстовое поле, прямоугольник, линию, изображение и вложенный отчет.
  • Пользовательские элементы отчета также могут отображаться на панели «Toolbox», если системный администратор установит и зарегистрирует их.

Область свойств

Область "Свойства" — это стандартное окно Visual Studio, в котором отображаются имена и значения свойств для текущего выбранного элемента отчета в области разработки.

Чтобы отобразить область "Свойства", перейдите в меню "Вид " и выберите "Окно свойств". Вы можете открепить эту панель и переместить её в другую область окна SSDT или отобразить её в виде вкладки на поверхности конструктора.

В большинстве случаев имена свойств соответствуют элементам и атрибутам, которые хранятся в файле на языке определения отчетов (RDL). Вы можете задать наиболее часто используемые свойства с помощью диалогового окна "Свойства" для выбранного элемента. Чтобы открыть диалоговое окно "Свойства" элемента, выберите элемент и нажмите кнопку "Страницы свойств" на панели инструментов панели "Свойства". Опытные пользователи могут задавать значения свойств непосредственно на панели свойств.

Область "Свойства" можно использовать для следующих задач:

  • Задайте свойства для выбранного элемента на поверхности конструктора. Некоторые свойства предоставляют раскрывающийся список значений. Можно также ввести значение непосредственно в ячейке. Некоторые свойства содержат коллекцию значений, что обозначается как (Коллекция). Большинство свойств могут принимать выражение. Сложные выражения обозначаются значением <expression>. Чтобы открыть диалоговое окно "Выражение", нажмите кнопку "Выражение" (fx). Дополнительные сведения см. в диалоговом окне "Выражение".
  • Используйте кнопки панели инструментов панели свойств, чтобы изменить сетку из представления категорий в алфавитное представление. В представлении категорий может потребоваться развернуть категорию, чтобы просмотреть все свойства под ним. Чтобы открыть диалоговое окно "Свойства элемента", нажмите кнопку "Страницы свойств" на панели инструментов. Вы также можете щелкнуть элемент правой кнопкой мыши и выбрать пункт "Свойства".
  • Задайте свойства для выбранного в данный момент элемента группы в области "Группирование". Свойства элемента группы позволяют управлять тем, как строки верхнего и нижнего колонтитула статической группы повторяются для каждого экземпляра группы. Дополнительные сведения см. в разделе Отображение верхних и нижних колонтитулов с группой в нумерованном отчете (Построитель отчетов).

Обозреватель решений

Обозреватель решений — это стандартный компонент Visual Studio, который отображает все элементы проекта. Для проекта сервера отчетов этот список элементов включает папки для организации общих источников данных, общих наборов данных, отчетов и ресурсов. Элементы в папках автоматически упорядочиваются по алфавиту при открытии файла решения. Чтобы просмотреть свойства элемента на панели "Свойства", выделите этот элемент.

Окно выходных данных

В окне вывода отображаются ошибки обработки, возникающие при предварительном просмотре отчета. В этом окне также отображаются ошибки публикации, возникающие при развертывании отчета или общего источника данных.

Окно вывода можно использовать для отладки ошибок в выражениях.

Область структуры документа

В области структуры документа отображается иерархический список всех элементов отчета в определении отчета. Чтобы открыть область «Структура документа», можно выбрать Вид>Другие окна>Структура документа.

Область структуры документа полезна для идентификации текстовых полей и других элементов отчета по имени. При выборе элемента на панели "Структура документа" этот элемент также выбирается на поверхности конструктора.

Вы также можете использовать панель структуры документа для отладки ошибок в выражениях.

Окно списка задач

В окне списка задач отображаются ошибки сборки, возникающие при импорте отчета из другого приложения. Например, если вы импортируете отчет из Microsoft Access и отчет содержит функцию, которая не поддерживает SSRS, в окне списка задач сообщается ошибка.

Представления конструктора отчетов

Конструктор отчетов поддерживает два представления:

  • Проектирование, определение данных и макета отчета
  • Предварительный просмотр, чтобы отобразить отрисованное представление отчета

Представление конструирования

При создании проекта сервера отчетов конструктор отчетов по умолчанию открывается в режиме конструктора, при этом отображается область разработки. По умолчанию в области конструктора отображаются тело отчета, а также фон отчета.

Фон области конструктора содержит контекстное меню. Это меню предоставляет параметры добавления колонтитула страницы и нижнего колонтитула страницы. Он также содержит меню "Вид ", которое можно использовать для отображения линейки, панели группирования и области параметров.

Вы можете использовать элемент управления масштабированием для увеличения или уменьшения увеличения отчета.

Чтобы спроектировать отчет, перетащите элементы отчета из области «Панель элементов» в область конструктора. Затем вы настроите их свойства и измените их расположение в отчете.

Режим предварительного просмотра

В режиме предварительного просмотра вы запускаете отчет и просматриваете сформированный отчет в средстве просмотра отчетов. Вы также можете задать свойства конфигурации для запуска отчета в режиме отладки с помощью браузера.

При предварительном просмотре отчета конструктор отчетов:

  • Подключается к источникам данных отчета.
  • Выполняет запросы набора данных.
  • Кэширует данные на локальном компьютере.
  • Обрабатывает отчет, объединяя данные и оформление.
  • Формирует отчет.

При использовании представления предварительного просмотра следует учитывать несколько моментов.

  • Параметризованные отчеты. При предварительном просмотре отчеты обрабатываются автоматически, если все параметры отчета имеют допустимые значения по умолчанию. Если один или несколько параметров отчета не имеют допустимого значения по умолчанию, необходимо выбрать значение для каждого неназначенных параметра. На панели инструментов отчета необходимо выбрать представление отчета.
  • Локальный кэш данных. При предварительном просмотре отчета обработчик отчетов выполняет все запросы к наборам данных в отчете с помощью текущих параметров по умолчанию. Он сохраняет результаты в виде локального кэша данных (RDL.data). Если запросы набора данных отчета и параметры отчета не изменились, то можно воспользоваться уже полученными данными из кэша и продолжать конструирование отчета без дополнительной нагрузки на ресурсы для их повторного получения.
  • Диспетчер конфигурации и отладка. В SSDT свойства проекта определяют способ развертывания и отладки отчетов. Эти свойства относятся ко всем отчетам и общим источникам данных проекта. Чтобы задать свойства проекта, перейдите в меню "Проект " и выберите "Свойства". В диалоговом окне "Страницы свойств" выберите Configuration Manager. Эти параметры можно использовать для тестирования отчетов и их публикации на сервере отчетов.
  • Панель вывода. Если при предварительном просмотре отчета обработчик обнаруживает проблему, он выводит сообщения об ошибках на панель вывода.

меню конструктор отчетов

Если проект конструктор отчетов активен в SSDT, в главное меню добавляются следующие меню.

Меню форматирования

При выборе элемента в области конструктора меню Формат содержит следующие команды:

Вариант Назначение
Цвет переднего плана Выберите цвет текста. Цвет по умолчанию — черный.
Цвет фона Выберите цвет фона для текстовых полей и областей данных.
Font Укажите, является ли текст полужирным, курсивом или подчеркнут.
Оправдывать Укажите, выравнивается ли текст по правому краю, по центру или по левому краю.
Выравнивание Укажите, как выбранные объекты выровнены по отношению друг к другу в отчете.
Сделать тот же размер Настройте размер выбранных объектов в отчете.
Горизонтальные интервалы Настройте горизонтальный интервал между выбранными объектами в отчете.
Вертикальный интервал Настройте вертикальный интервал между выбранными объектами в отчете.
Центр в форме Отцентрируйте выбранный объект по вертикали и по горизонтали относительно окна конструктора отчётов.
Заказ Перемещение выбранных объектов в фоновый или передний план.

Меню отчета и контекстное меню конструктора

Для настройки параметров, применяемых ко всему отчету, можно использовать следующие параметры. Доступность и расположение этих параметров зависят от используемой версии Visual Studio:

  • В более ранних версиях эти параметры можно найти в меню "Отчет ".
  • В более поздних версиях большинство параметров находятся в контекстном меню фона области проектирования.
Вариант Назначение
Свойства отчета Откройте диалоговое окно "Свойства отчета", чтобы назначить общие свойства отчета, такие как имя автора, интервалы сетки, количество столбцов и размер страницы. Можно также настроить параметры пользовательского кода, ссылки на сборки и классы, а также имена выходных элементов данных, преобразования данных и схемы данных.
Вид Переключайтесь между двумя вкладками конструктора отчетов: «Конструктор» и «Предварительный просмотр». Показать или скрыть линейку, область группировки или область параметров.
Добавление заголовка страницы Добавьте заголовок страницы в отчет или удалите его. При удалении верхнего колонтитула страницы удаляются также все его элементы.
Добавление нижнего колонтитула страницы Добавьте нижний колонтитул страницы в отчет или удалите его. При удалении нижнего колонтитула страницы удаляются также все его элементы.
Публикация частей отчета Выберите части отчета для публикации.

меню "Вид"

Для отображения или скрытия различных конструктор отчетов окон и панелей инструментов можно использовать следующие параметры меню представления:

Вариант Компонент для отображения или скрытия
Список ошибок Ошибки, обнаруженные при публикации или предварительной версии отчета.
Выходные данные Ошибки, обнаруженные при публикации или обработке отчета. Кроме того, подробные сведения об ошибках в выражениях, когда в отчете отображается текст "#Error."
Окно "Свойства" Значения свойств для элемента отчета, выбранного в данный момент в области разработки. Этот параметр можно использовать для просмотра свойств вложенных элементов отчета. Но для последовательного перехода по его иерархии и вложенным элементам нужно несколько раз выбирать элемент отчета. Чтобы узнать, какие свойства элемента отчета отображаются, можно проверить имя элемента в верхней части панели свойств.
Панель инструментов Панель инструментов.
Другие окна>Структура документа Иерархическое представление элементов отчета и их коллекций текстовых полей в отчете.
Панели инструментов Различные панели инструментов, включая границы отчетов и форматирование отчетов. Дополнительные сведения см. в разделе конструктор отчетов панели инструментов.
Данные отчета Область данных отчета, в которой можно добавлять параметры отчета, источники данных, наборы данных и изображения.

Меню "Проект"

Для управления общими источниками данных и отчетами в проекте можно использовать следующие параметры меню "Проект ". При добавлении и удалении элементов отчета иерархическое представление элементов отчета в обозревателе решений обновляется автоматически.

Вариант Назначение
Добавление нового элемента Добавьте в проект новый общий источник данных или новый отчет.
Добавление существующего элемента Добавьте существующий общий источник данных или существующий отчет в проект.
Импорт отчетов Импортируйте отчеты из другого приложения, например Microsoft Access.
Исключить из проекта Исключите элементы из проекта. Этот параметр не удаляет исключенные элементы из файловой системы.
Показать все файлы Отображение всех файлов в проекте.
Обновить элементы панели инструментов проекта Обновите кэш панели элементов при установке новых настраиваемых элементов отчета в проекте.
Свойства Откройте диалоговое окно "Страницы свойств" для этого проекта. Дополнительные сведения см. в диалоговом окне "Страницы свойств проекта".

панели инструментов конструктора отчетов

конструктор отчетов предоставляет следующие специализированные панели инструментов для использования при разработке отчетов:

Панель инструментов Назначение
Отчет Добавьте верхний или нижний колонтитул страницы. Задайте свойства отчета. Показать или скрыть линейку или панель группировки. Используйте элемент управления масштабированием для изменения представления отчета.
Границы отчетов Задайте цвет, стиль и ширину для всех выбранных строк и границ всех выбранных элементов отчета.
Форматирование отчета Задайте формат выбранных элементов отчета. Для текстовых полей можно использовать панель инструментов, чтобы изменить следующие типы форматирования: свойства шрифта, цвет текста, цвет фона и обоснование текста.
Макет Задайте порядок рисования элементов отчета и объединение ячеек в регионе данных.
Стандартные Откройте или сохраните проекты, окна отображения и выберите конфигурацию отладки.

Меню "Вид" можно использовать для отображения или скрытия этих панелей инструментов. Другие панели инструментов Visual Studio могут быть недоступны, если их функциональные возможности не применяются к конструктор отчетов функциям.

Управление исходным кодом

SSDT может интегрироваться с подключаемыми модулями системы управления версиями. На страницах «Управление версиями» в диалоговом окне «Параметры» можно указать подключаемый модуль и настроить его свойства.

Пользовательские шаблоны отчетов

Чтобы использовать пользовательские отчеты в качестве шаблонов для новых отчетов, скопируйте их в папку ReportProject на компьютере, на котором установлен SSDT.

Расположение этой папки по умолчанию зависит от используемой версии и выпуска Visual Studio. Для Visual Studio 2022, 2019 и 2017 эта папка находится в следующем расположении:

%ProgramFiles%\Microsoft Visual Studio\<release-year>\<edition>\Common7\IDE\CommonExtensions\Microsoft\SSRS\ProjectItems\ReportProject

Для Visual Studio 2015 расположение по умолчанию — следующая папка:

%ProgramFiles%\Microsoft Visual Studio 14.0\Common7\IDE\Private Assemblies\ProjectItems\ReportProject

Когда в проект отчета добавляется новый элемент, пользовательский отчет отображается на панели «Шаблоны». Можно также добавить пользовательские стили в мастер отчета.

Поддержка командной строки для SSDT

SSDT основан на Visual Studio и базовом приложении devenv.exe. Это приложение предлагает несколько вариантов командной строки, которые полезны для работы с отчетами.

Прежде чем использовать параметры командной строки, описанные в этом разделе, необходимо задать допустимые значения для следующих двух элементов:

  • Свойства проекта для OverwriteDataSources, TargetDataSourceFolder, TargetReportFolder и TargetServerURL.
  • Как минимум один набор свойств конфигурации, например, Debug или Release.

Дополнительные сведения см. в статье "Публикация источников данных и отчетов".

Для проекта сервера отчетов необходимо задать следующие параметры в командной строке.

  • /deploy: развертывает отчеты с помощью свойств проекта, которые указывает файл конфигурации. Например, следующая команда развертывает отчеты, указанные в файле решения Reports.sln. Используются параметры конфигурации Release, указанные в свойствах проекта:

    devenv.exe "C:\Users\<user-name>\source\repos\Reports\Reports.sln" /deploy "Release"
    
  • /build: создает файл решения, но не развертывает его. Например, следующая команда создает отчеты, которые указывает файл решения Reports.sln. В нем используются параметры конфигурации отладки, указанные в свойствах проекта:

    devenv.exe "C:\Users\<user-name>\source\repos\Reports\Reports.sln" /build "Debug"
    
  • /out: перенаправляет выходные данные, созданные путем создания решения в указанный файл. Например, следующая команда перенаправляет вывод из сборки, созданной в предыдущем примере, в файл mybuildlog.txt.

    devenv.exe "C:\Users\<user-name>\source\repos\Reports\Reports.sln" /build "Debug" /out mybuildlog.txt
    

Сочетания клавиш в SSDT

Сочетания клавиш можно использовать для:

  • Управление окнами и режимами в SSDT:

    Описание Сочетание клавиш
    Выполнить сборку выбранного проекта Ctrl+Shift+B
    Отобразить окно свойств F4
    Отображение окна данных отчета CTRL+ALT+D
    Запуск отладки F5
    Переместиться от одного открытого окна к следующему F6
  • Элементы управления в области конструктора отчета:

    Описание Сочетание клавиш
    Перемещение фокуса с одного элемента отчета на следующий элемент отчета Вкладка
    Перемещение выбранного элемента отчета Клавиши со стрелками
    Сдвинуть выбранный элемент отчета Ctrl+клавиши со стрелками
    Увеличить или уменьшить размер выбранного элемента отчета Ctrl+Shift+клавиши со стрелками
    В текстовом поле переместите курсор в начало отображаемого текста. CTRL+Дом
    В текстовом поле переместите курсор в конец отображаемого текста. CTRL+Конец
    В текстовом поле выделите текст из текущей позиции курсора в начало отображаемого текста. Shift+Home
    В текстовом поле выделите текст из текущей позиции курсора в конец отображаемого текста. SHIFT+END
    В текстовом поле выбрать текст от текущей позиции курсора до начала выражения CTRL+SHIFT+HOME
    В текстовом поле выбрать текст от текущей позиции курсора до конца выражения CTRL+SHIFT+END
    Открыть контекстное меню для выбранного элемента отчета Сдвиг+F10