Поделиться через


Поддерживаемые версии Kubernetes в Службе Azure Kubernetes (AKS)

Сообщество Kubernetes выпускает небольшие версии примерно каждые четыре месяца.

Выпуски дополнительных версий содержат новые функции и улучшения. Исправления выпускаются чаще (иногда еженедельно) и предназначены для устранения критических ошибок в дополнительной версии. Такие выпуски ликвидируют уязвимости в системе безопасности или серьезные ошибки.

Версии Kubernetes

Kubernetes использует для каждой версии стандартную схему семантического версионирования.

[major].[minor].[patch]

Examples:
  1.29.2
  1.29.1

Каждый элемент номера версии указывает на общую совместимость с предыдущей версией:

  • Основные версии изменяются, если несовместимые обновления API или обратная совместимость могут быть нарушены.
  • Дополнительный номер версии изменяется, когда обновляется функциональность и при этом поддерживается обратная совместимость с другими дополнительными выпусками.
  • Номер версии исправления изменяется при исправлении ошибок с сохранением обратной совместимости.

Старайтесь использовать последний выпуск с исправлениями для дополнительной версии, в которой вы работаете. Например, если рабочий кластер включен 1.29.1 и 1.29.2 является последней доступной версией исправлений, доступной для версии 1.29 , необходимо обновить 1.29.2 до ближайшего времени, чтобы убедиться, что кластер полностью исправлен и поддерживается.

Календарь выпуска Kubernetes AKS

Просмотрите предстоящие выпуски версий в календаре выпуска AKS Kubernetes. Чтобы просмотреть обновления состояния выпуска региона и заметки о выпуске версии в режиме реального времени, перейдите на веб-страницу состояния выпуска AKS. Дополнительные сведения о веб-странице состояния выпуска см . в разделе средства отслеживания выпуска AKS.

Примечание.

AKS следует 12 месяцев поддержки общедоступной версии Kubernetes. Чтобы узнать больше о политике поддержки для управления версиями Kubernetes, ознакомьтесь с нашими часто задаваемыми вопросами.

Сведения о прошлом журнале выпусков см . в журнале Kubernetes.

Версия K8s Вышестоящий выпуск Предварительная версия AKS Общедоступная версия AKS Дата прекращения поддержки Поддержка платформы
1,26 Декабрь 2022 г. Февраль 2023 г. Апрель 2023 г. Мар 2024 г. До 1.30 GA
1.27* Апрель 2023 г. Июнь 2023 г. Июль 2023 г. Июль 2024, LTS до 2025 г. До 1.31 GA
1.28 Август 2023 г. Сентябрь 2023 г. Ноябрь 2023 г. Ноябрь 2024 г. До 1.32 GA
1,29 Декабрь 2023 г. Февраль 2024 г. Мар 2024 г. Мар 2025 г. До 1.33 GA
1,30 Апрель 2024 г. Июнь 2024 г. Июль 2024 г. Июль 2025 г. До 1.34 GA

* Указывает, что версия назначена для долгосрочной поддержки

Диаграмма выпуска AKS Kubernetes

Если вы предпочитаете видеть эту информацию визуально, вот диаграмма Ганта со всеми текущими выпусками, отображаемыми:

Диаграмма Ганта, показывающая жизненный цикл всех версий Kubernetes, активных в AKS.

Критические изменения компонентов AKS по версии

Обратите внимание на следующие важные изменения перед обновлением до любой из доступных дополнительных версий:

Версия Kubernetes Управляемые надстройки AKS Компоненты AKS Компоненты ОС Критические изменения Примечания.
1,26 Политика Azure 1.3.0
Метрики-Server 0.6.3
KEDA 2.10.1
Открытие сетки службы 1.2.3
Core DNS версии 1.9.4
Наложение VPA 0.11.0
Azure-Keyvault-SecretProvider 1.4.1
Шлюз приложений контроллер входящего трафика (AGIC) 1.5.3
Image Cleaner версии 1.2.3
Удостоверение рабочей нагрузки Azure версии 1.0.0
MDC Defender 1.0.56
Удостоверение pod Azure Active Directory 1.8.13.6
GitOps 1.7.0
KMS 0.5.0
azurefile-csi-driver 1.26.10
Cilium 1.12.8
CNI 1.4.44
Автомасштабирование кластера 1.8.5.3
Образ ОС Ubuntu 22.04 Cgroups версии 2
Контейнер 1.7
Azure Linux 2.0
Cgroups версии 1
Контейнер 1.6
azurefile-csi-driver 1.26.10 нет
1,27 Политика Azure 1.3.0
драйвер azuredisk-csi версии 1.28.5
драйвер azurefile-csi версии 1.28.10
blob-csi версии 1.22.4
csi-attacher версии 4.3.0
csi-resizer версии 1.8.0
csi-snapshotter версии 6.2.2
моментальный контроллер версии 6.2.2
Метрики-Server 0.6.3
Кеда 2.11.2
Открытие сетки службы 1.2.3
Core DNS версии 1.9.4
Наложение VPA 0.11.0
Azure-Keyvault-SecretProvider 1.4.1
Шлюз приложений контроллер входящего трафика (AGIC) 1.7.2
Image Cleaner версии 1.2.3
Удостоверение рабочей нагрузки Azure версии 1.0.0
MDC Defender 1.0.56
Удостоверение pod Azure Active Directory 1.8.13.6
GitOps 1.7.0
azurefile-csi-driver 1.28.7
KMS 0.5.0
Драйвер хранилища секретов CSI 1.3.4-1
Cilium 1.13.10-1
CNI 1.4.44
Автомасштабирование кластера 1.8.5.3
Образ ОС Ubuntu 22.04 Cgroups версии 2
ContainerD 1.7 для Linux и 1.6 для Windows
Azure Linux 2.0
Cgroups версии 1
Контейнер 1.6
Кеда 2.11.2
Cilium 1.13.10-1
azurefile-csi-driver 1.28.7
драйвер azuredisk-csi версии 1.28.5
blob-csi версии 1.22.4
csi-attacher версии 4.3.0
csi-resizer версии 1.8.0
csi-snapshotter версии 6.2.2
моментальный контроллер версии 6.2.2
Из-за состояния сертификации FIPS Ubuntu 22.04 мы переключим узлы AKS FIPS с 18.04 на 20.04 с 1.27.
1.28 Политика Azure 1.3.0
azurefile-csi-driver 1.29.2
csi-node-driver-registrar версии 2.9.0
csi-livenessprobe 2.11.0
azuredisk-csi-linux версии 1.29.2
azuredisk-csi-windows версии 1.29.2
csi-provisioner версии 3.6.2
csi-attacher версии 4.5.0
csi-resizer версии 1.9.3
csi-snapshotter версии 6.2.2
моментальный контроллер версии 6.2.2
Метрики-Server 0.6.3
KEDA 2.11.2
Открытие сетки службы 1.2.7
Core DNS версии 1.9.4
Наложение VPA 0.13.0
Azure-Keyvault-SecretProvider 1.4.1
Шлюз приложений контроллер входящего трафика (AGIC) 1.7.2
Image Cleaner версии 1.2.3
Удостоверение рабочей нагрузки Azure версии 1.2.0
Издатель безопасности MDC Defender 1.0.68
Драйвер хранилища секретов CSI 1.3.4-1
Старый файл В Защитнике MDC 1.3.68
Сборщик pod в Защитнике MDC 1.0.78
Сборщик низкого уровня MDC Defender 1.3.81
Удостоверение pod Azure Active Directory 1.8.13.6
GitOps 1.8.1
Cilium 1.13.10-1
CNI версии 1.4.43.1 (по умолчанию)/v1.5.11 (наложение Azure CNI)
Автомасштабирование кластера 1.27.3
Tigera-Operator 1.28.13
Образ ОС Ubuntu 22.04 Cgroups версии 2
ContainerD 1.7.5 для Linux и 1.7.1 для Windows
Azure Linux 2.0
Cgroups версии 1
Контейнер 1.6
azurefile-csi-driver 1.29.2
csi-resizer версии 1.9.3
csi-attacher версии 4.4.2
csi-provisioner версии 4.4.2
blob-csi версии 1.23.2
драйвер azurefile-csi версии 1.29.2
драйвер azuredisk-csi версии 1.29.2
csi-livenessprobe версии 2.11.0
csi-node-driver-registrar версии 2.9.0
нет
1,29 Политика Azure 1.3.0
csi-provisioner версии 4.0.0
csi-attacher версии 4.5.0
csi-snapshotter версии 6.3.3
моментальный контроллер версии 6.3.3
Метрики-Server 0.6.3
KEDA 2.11.2
Открытие сетки службы 1.2.7
Core DNS версии 1.9.4
Наложение VPA 0.13.0
Azure-Keyvault-SecretProvider 1.4.1
Шлюз приложений контроллер входящего трафика (AGIC) 1.7.2
Image Cleaner версии 1.2.3
Удостоверение рабочей нагрузки Azure версии 1.2.0
Издатель безопасности MDC Defender 1.0.68
Старый файл В Защитнике MDC 1.3.68
Сборщик pod в Защитнике MDC 1.0.78
Сборщик низкого уровня MDC Defender 1.3.81
Удостоверение pod Azure Active Directory 1.8.13.6
GitOps 1.8.1
Драйвер хранилища секретов CSI 1.3.4-1
azurefile-csi-driver 1.29.3
Cilium 1.13.5
CNI версии 1.4.43.1 (по умолчанию)/v1.5.11 (наложение Azure CNI)
Автомасштабирование кластера 1.27.3
Tigera-Operator 1.30.7
Образ ОС Ubuntu 22.04 Cgroups версии 2
ContainerD 1.7.5 для Linux и 1.7.1 для Windows
Azure Linux 2.0
Cgroups версии 2
Контейнер 1.6
Tigera-Operator 1.30.7
csi-provisioner версии 4.0.0
csi-attacher версии 4.5.0
csi-snapshotter версии 6.3.3
моментальный контроллер версии 6.3.3
нет

Дополнительная версия псевдонима

Примечание.

Для дополнительных версий псевдонима требуется Azure CLI версии 2.37 или более поздней, а также версия API 20220401 или более поздней. Для установки последней версии интерфейса командной строки используйте az upgrade.

AKS позволяет создать кластер без указания точной версии исправления. При создании кластера без назначения исправления кластер запускает последнюю версию общедоступной версии. Например, если вы создаете кластер с 1.291.29.2 последней доступной общедоступной версией, кластер будет создан с 1.29.2помощью . Если вы хотите обновить версию исправления в той же дополнительной версии, используйте автоматическое обновление.

Чтобы узнать, какое исправление вы используете, выполните az aks show --resource-group myResourceGroup --name myAKSCluster команду. Свойство currentKubernetesVersion отображает всю версию Kubernetes.

{
 "apiServerAccessProfile": null,
  "autoScalerProfile": null,
  "autoUpgradeProfile": null,
  "azurePortalFqdn": "myaksclust-myresourcegroup.portal.hcp.eastus.azmk8s.io",
  "currentKubernetesVersion": "1.29.2",
}

Политика поддержки версий Kubernetes

AKS определяет общедоступную версию (GA) как версию, доступную во всех регионах, и включенную во всех измерениях SLO или SLA. AKS поддерживает три дополнительные общедоступные версии Kubernetes.

  • Последняя версия общедоступной дополнительной версии, выпущенная в AKS (которая называется N).
  • Две предыдущие дополнительные версии.
    • Каждая поддерживаемая дополнительная версия также поддерживает не более двух стабильных исправлений.

AKS также может поддерживать предварительные версии, которые явно помечены и применяются к предварительным версиям условий.

AKS поддерживает платформу только для одной дополнительной версии Kubernetes с общедоступной версией после обычных поддерживаемых версий. Окно поддержки платформы версий Kubernetes в AKS называется N-3. Дополнительные сведения см . в политике поддержки платформы.

Примечание.

AKS использует методы безопасного развертывания, которые предполагают постепенное развертывание области. Это означает, что для нового выпуска или новой версии в всех регионах может потребоваться до 10 рабочих дней.

Поддерживаемое окно дополнительных версий Kubernetes в AKS называется N-2, где N относится к последнему выпуску, что означает, что два предыдущих дополнительных выпуска также поддерживаются.

Например, в день, когда AKS вводит версию 1.29, поддержка предоставляется для следующих версий:

Новая дополнительная версия Поддерживаемый список дополнительных версий
1,29 1.29, 1.28, 1.27

Когда выпускается новая дополнительная версия, самая старая поддерживаемая дополнительная версия переводится в разряд нерекомендуемых и удаляется. Например, предположим, что текущий поддерживаемый дополнительный список версий:

1.29
1.28
1.27

Когда AKS выпускает 1.30, все версии 1.27 выходят из поддержки 30 дней спустя.

AKS также поддерживает не более двух выпусков исправлений данной дополнительной версии. Например, учитывая следующие поддерживаемые версии:

Current Supported Version List
------------------------------
1.29.2, 1.29.1, 1.28.7, 1.28.6, 1.27.11, 1.27.10

Если выпускается AKS версий 1.29.3 и 1.28.8, то самые старые версии исправления выводятся из эксплуатации и удаляются, а список поддерживаемых версий выглядит следующим образом:

New Supported Version List
----------------------
1.29.3, 1.29.2, 1.28.8, 1.28.7, 1.27.11, 1.27.10

Политика поддержки платформы

Политика поддержки платформы — это сокращенный план поддержки для некоторых неподдерживаемых версий Kubernetes. Во время поддержки платформы клиенты получают поддержку только от Майкрософт для AKS/Azure, связанных с проблемами, связанными с платформой. Все проблемы, связанные с функциональными возможностями и компонентами Kubernetes, не поддерживаются.

Политика поддержки платформы применяется к кластерам в версии n-3 (где n является последней поддерживаемой дополнительной версией AKS GA), прежде чем кластер удаляется до n-4. Например, Kubernetes версии 1.26 считается поддержкой платформы, когда версия 1.29 является последней версией общедоступной версии. Однако во время выпуска общедоступной версии 1.30 версия 1.26 будет автоматически обновляться до версии 1.27. Если вы работаете с n-2 версией, момент, когда он становится n-3, он также становится устаревшим, и вы вводите политику поддержки платформы.

AKS использует выпуски и исправления из Kubernetes, который является проектом с открытым исходным кодом, который поддерживает только скользящее окно из трех дополнительных версий. AKS может гарантировать полную поддержку , пока эти версии обслуживаются вышестоящими. Так как не существует больше исправлений, создаваемых выше, AKS может либо оставить эти версии неотвеченными или вилками. Из-за этого ограничения поддержка платформы не поддерживает ничего от использования вышестоящего потока Kubernetes.

В этой таблице описаны рекомендации по поддержке сообщества по сравнению с поддержкой платформы.

Категория поддержки Поддержка сообщества (N-2) Поддержка платформы (N-3)
Обновление от N-3 до поддерживаемой версии Поддерживается Поддерживается
Доступность платформы (Azure) Поддерживается Поддерживается
Масштабирование пула узлов Поддерживается Поддерживается
Доступность виртуальной машины Поддерживается Поддерживается
Проблемы, связанные с хранилищем, сетью Поддерживается Поддерживается за исключением исправлений ошибок и устаревших компонентов
Запуск и остановка Поддерживается Поддерживается
Ротация сертификатов Поддерживается Поддерживается
Соглашение об уровне обслуживания инфраструктуры Поддерживается Поддерживается
Соглашение об уровне управления Поддерживается Поддерживается
Соглашение об уровне обслуживания платформы (AKS) Поддерживается Не поддерживается
Компоненты Kubernetes (включая надстройки) Поддерживается Не поддерживается
Обновления компонентов Поддерживается Не поддерживается
Исправления компонентов Поддерживается Не поддерживается
Применение исправлений ошибок Поддерживается Не поддерживается
Применение исправлений безопасности Поддерживается Не поддерживается
Поддержка API Kubernetes Поддерживается Не поддерживается
Создание кластера или пула узлов Поддерживается Не поддерживается
Моментальный снимок пула узлов Поддерживается Не поддерживается
Обновление образа узла Поддерживается Не поддерживается

Примечание.

Приведенная выше таблица подвержена изменению и описанию распространенных сценариев поддержки. Все сценарии, связанные с функциональными возможностями и компонентами Kubernetes, не поддерживаются для N-3. Дополнительные сведения о поддержке см. в разделе "Поддержка и устранение неполадок" для AKS.

Поддерживаемые версии kubectl

Можно использовать одну дополнительную версию старее или новее kubectl относительно имеющейся версии kube-apiserver, которая соответствует требованиям политики поддержки Kubernetes для kubectl.

Например, если сервер kube-apiserver равен 1.28, можно использовать версии 1.27 до 1.29kubectl с этим kube-apiserver.

Чтобы установить или обновить kubectl до последней версии, запустите:

az aks install-cli

Долгосрочная поддержка (LTS)

AKS предоставляет 1 год поддержки сообщества и один год долгосрочной поддержки (LTS) для возврата исправлений безопасности портов из вышестоящего сообщества в нашем общедоступный репозиторий. Наша вышестояющая рабочая группа LTS вносит усилия в сообщество, чтобы предоставить нашим клиентам более длительное окно поддержки.

Дополнительные сведения о LTS см. в долгосрочной поддержке Служба Azure Kubernetes (AKS).

Процесс выпуска и перевода версий в разряд нерекомендуемых

В календаре выпусков Kubernetes AKS Kubernetes можно ссылаться на предстоящие выпуски версий и отменять их.

Для новых дополнительных версий Kubernetes

  • AKS публикует объявление с запланированной датой выпуска новой версии и соответствующей старой версией нерекомендуемой в заметках о выпуске AKS не менее 30 дней до удаления.
  • AKS использует Azure Advisor для оповещения о том, что новая версия может вызвать проблемы в кластере из-за устаревших API. Помощник по Azure также оповещает вас, если вы не поддерживаете
  • AKS публикует уведомление о работоспособности службы, доступное всем пользователям с доступом к AKS и порталу, и отправляет сообщение электронной почты администраторам подписки с запланированными датами удаления версий.

    Примечание.

    Чтобы узнать, кто является администратором подписки, или сменить его, ознакомьтесь со статьей об управлении подписками Azure.

  • У вас есть 30 дней после удаления версии для обновления до поддерживаемого дополнительного выпуска версии для продолжения получения поддержки.

Для новых версий Kubernetes с исправлениями

  • Из-за срочного характера исправлений они могут быть добавлены в службу, как только станут доступны. После доступности исправления имеют два месяца минимального жизненного цикла.
  • Как правило, AKS широко не сообщает о выпуске новых версий исправлений. Однако AKS постоянно отслеживает и проверяет наличие доступных исправлений CVE, чтобы своевременно применять их в AKS. Если обнаружен критически важный исправление или требуется действие пользователя, AKS уведомляет вас об обновлении до нового доступного исправления.
  • У вас есть 30 дней после удаления исправления из AKS для обновления до поддерживаемого исправления и продолжения получения поддержки. Однако вы больше не сможете создавать кластеры или пулы узлов после удаления версии.

Исключения из политики поддержки версий

AKS оставляет за собой право без предварительного уведомления добавлять и удалять новые и существующие версии с одной или несколькими критическими ошибками или проблемами безопасности, которые влияют на рабочую среду.

Определенные выпуски исправлений могут быть пропущены или развернуты в зависимости от серьезности ошибки или проблемы безопасности.

Версии на портале Azure и в CLI

При развертывании кластера AKS с портал Azure, Azure CLI, Azure PowerShell кластер по умолчанию используется для дополнительной версии N-1 и последней исправления. Например, если AKS поддерживает 1.29.2, 1.29.1, 1.28.7, 1.28.6, 1.27.11 и 1.27.10, выбрана по умолчанию версия 1.28.7.

Чтобы узнать, какие версии доступны в настоящее время для вашей подписки и региона, используйте az aks get-versions команду. В следующем примере перечислены доступные версии Kubernetes для региона EastUS:

az aks get-versions --location eastus --output table

Вопросы и ответы

Как корпорация Майкрософт уведомляет о новых версиях Kubernetes?

Команда AKS публикует объявления с запланированными датами новых версий Kubernetes в нашей документации, GitHub и в сообщениях электронной почты администраторам подписок, которым будут принадлежать кластеры, которые будут выпадать из поддержки. AKS также использует Помощник по Azure для оповещения вас в портал Azure, если вы не поддерживаете и сообщаете о устаревших API, которые могут повлиять на процесс разработки приложения или разработки.

Как часто следует ждать обновления версий Kubernetes, чтобы поддерживать продукт в актуальном состоянии?

Начиная с Kubernetes 1.19, открытый код сообщество расширило поддержку до одного года. AKS стремится предоставлять исправления и поддержку в соответствии с вышестоящими обязательствами. Для кластеров AKS в версии 1.19 и более поздних версий можно обновить как минимум один раз в год, чтобы оставаться в поддерживаемой версии.

Что происходит при обновлении кластера Kubernetes с дополнительной версией, которая не поддерживается?

Если вы используете версию n-3 или более раннюю, это означает, что ваша версия не поддерживается, и вам будет предложено выполнить обновление. Успешно выполнив обновление с версии n-3 до n-2, вы снова сможете получать поддержку согласно нашей политике. Например:

  • Если самая старая поддерживаемая версия AKS — 1.27 , и вы находитесь в версии 1.26 или более ранней версии, вы находитесь вне поддержки.
  • При успешном обновлении с версии 1.26 до версии 1.27 или более поздней версии вы снова находитесь в наших политиках поддержки.

Понижение не поддерживается.

Что означает "Вне поддержки"?

Формулировка "поддержка не обеспечивается" означает следующее:

  • Используемая версия не входит в список поддерживаемых.
  • При запросе поддержки вам будет предложено обновить кластер до поддерживаемой версии, если вы не воспользовались 30-дневным периодом отсрочки после перевода текущей версии в разряд нерекомендуемых.

Кроме того, AKS не предоставляет среду выполнения или другие гарантии относительно кластеров с неподдерживаемыми версиями.

Что происходит при масштабировании кластера Kubernetes с дополнительной версией, которая не поддерживается?

Увеличение или уменьшение масштаба развертывания для неподдерживаемых AKS дополнительных версий должно выполняться без сбоев. Так как нет гарантий качества обслуживания, рекомендуется обновить кластер, чтобы вернуть кластер в поддержку.

Можете ли вы остаться на версии Kubernetes навсегда?

Если поддержка не обеспечивается уже более чем для трех (3) дополнительных версий и обнаружены угрозы безопасности, Azure отправляет предупреждение о необходимости обновления кластера. Если вы не выполняете дальнейшие действия, Azure резервирует право автоматически обновлять кластер от вашего имени.

Что произойдет, если масштабировать кластер Kubernetes с дополнительной версией, которая не поддерживается?

Увеличение или уменьшение масштаба развертывания для неподдерживаемых AKS дополнительных версий должно выполняться без сбоев. Так как нет гарантий качества обслуживания, рекомендуется обновить кластер, чтобы вернуть кластер в поддержку.

Какая версия поддерживает плоскость управления, если пул узлов не входит в одну из поддерживаемых версий AKS?

Уровень управления должен находиться в пределах окна версий для всех пулов узлов. Дополнительные сведения об обновлении уровня управления или пулов узлов см. в документации по обновлению пулов узлов.

Что такое допустимое различие в версиях между плоскости управления и пулом узлов?

Политика отклонений версий теперь позволяет различать до 3 версий между плоскостью управления и пулами агентов. AKS следует этому изменению политики версий, начиная с версии 1.28, начиная с версии 1.28.

Можно ли пропустить несколько версий AKS во время обновления кластера?

После обновления поддерживаемого кластера AKS дополнительные номера версии Kubernetes невозможно пропустить. Политика отклонений версий плоскостей управления Kubernetes не поддерживает пропуск дополнительных версий. Правила обновления действуют следующим образом:

  • 1.28.x ->1.29.x: разрешено.
  • 1.27.x ->1.28.x: разрешено.
  • 1.27.x ->1.29.x: запрещено.

Обновление с версии 1.27.x ->1.29.x:

  1. Обновление с версии 1.27.x ->1.28.x.
  2. Обновление с версии 1.28.x ->1.29.x.

Пропуск нескольких версий может выполняться только при обновлении с неподдерживаемой версии до минимальной поддерживаемой версии. Например, можно обновить с неподдерживаемой версии 1.25.x до поддерживаемой версии 1.27.x , если 1.27 является минимальной поддерживаемой дополнительной версией.

При выполнении обновления из неподдерживаемой версии , пропускающей две или более дополнительных версий, обновление выполняется без каких-либо гарантий функциональности и исключается из соглашений об уровне обслуживания и ограниченной гарантии. Кластеры под управлением неподдерживаемой версии имеют гибкость разъединения обновлений уровня управления при обновлении пула узлов. Однако если версия устарела, рекомендуется повторно создать кластер.

Можно ли создать новый кластер 1.xx.x в течение 30-дневного периода поддержки?

№ После удаления версии невозможно создать кластер с этой версией. По мере развертывания изменений вы начнете видеть старую версию, удаленную из списка версий. Этот процесс может занять до двух недель от объявления, постепенно по регионам.

Я нерекомендуемая версия, можно ли добавить новые пулы узлов? Или потребуется выполнить обновление?

№ Невозможно добавить пулы узлов устаревшей версии в кластер. Создание или обновление пулов узлов до неподдерживаемой версии уровня управления версиями допускается независимо от разницы версий между пулом узлов и плоскости управления. Разрешены только незначительные обновления псевдонимов.

Как часто нужно обновлять исправления?

Минимальный жизненный цикл обновлений — два месяца. Чтобы поддерживать актуальность выпуска новых исправлений, следуйте заметкам о выпуске AKS.

Следующие шаги

Сведения о том, как обновить кластер, см. в статье: