условие ошибки CANNOT_LOAD_STATE_STORE

SQLSTATE: 58030

Произошла ошибка во время состояния загрузки.

АВТО_ВОССТАНОВЛЕНИЕ_СНИМКОВ_НЕ_УДАЛОСЬ

Не удалось загрузить версию моментального снимка <latestSnapshot> для хранилища состояния <stateStoreId>. Попытка автоматического восстановления с помощью версий моментальных снимков () из доступных моментальных снимков (<selectedSnapshots><eligibleSnapshots>) также завершилась ошибкой.

CANNOT_FIND_BASE_SNAPSHOT_CHECKPOINT

Не удается найти базовую контрольную точку моментального снимка с происхождением: <lineage>.

CANNOT_READ_CHECKPOINT

Не удается прочитать метаданные контрольной точки RocksDB. Ожидалось <expectedVersion>, но найдено <actualVersion>.

CANNOT_READ_DELTA_FILE_KEY_SIZE

Ошибка чтения разностного файла <fileToRead><clazz>: размер ключа не может быть равен <keySize>.

CANNOT_READ_DELTA_FILE_NOT_EXISTS

Ошибка чтения разностного файла <fileToRead> из <clazz>: <fileToRead> не существует.

CANNOT_READ_MISSING_SNAPSHOT_FILE

Ошибка чтения файла моментального снимка <fileToRead><clazz>: <fileToRead> не существует.

CANNOT_READ_SNAPSHOT_FILE_KEY_SIZE

Ошибка чтения файла моментального снимка <fileToRead><clazz>: размер ключа не может быть <keySize>.

CANNOT_READ_SNAPSHOT_FILE_VALUE_SIZE

Ошибка чтения файла моментального снимка <fileToRead> из <clazz>: размер значения не может быть <valueSize>.

CANNOT_READ_STREAMING_STATE_FILE

Ошибка чтения файла состояния потоковой передачи <clazz>: <fileToRead> не существует. Если задание потока перезапускается с помощью новой или обновленной операции состояния, создайте новое расположение контрольной точки или очистите существующее расположение контрольной точки.

CANNOT_WRITE_STREAMING_STATE_FILE

Не удалось записать файл хранилища состояния потокового потока, потому что местоположение контрольной точки только для чтения или идентичность не имеет права на запись. Убедитесь, что местоположение контрольного пункта пригодно для записи. Сообщение об ошибке: <errorMsg>

ПРОВЕРКА КОНТРОЛЬНОЙ СУММЫ ФАЙЛА ВЫЗВАЛА ОШИБКУ

<originalMessage>

CONFIGURATION_MISMATCH

Не удалось загрузить хранилище состояний, так как конфигурация хранилища состояний не соответствует конфигурации в контрольной точке. Сообщение об ошибке: <errorMsg>

CONNECTION_POOL_SHUT_DOWN

Не удалось загрузить хранилище состояний с идентификатором "<stateStoreId>" от поставщика "<stateStoreProviderName>". Полученное сообщение об ошибке: <errorMsg>

Соединение_отклонено

Не удалось загрузить хранилище состояний с идентификатором <stateStoreId> от поставщика <stateStoreProviderName> из-за ошибки отказа в подключении. Сообщение об ошибке: <errorMsg>

FAILED_TO_GET_CHANGELOG_WRITER

Не удалось получить запись журнала изменений для хранилища состояний в версии <version>.

HDFS_STORE_PROVIDER_OUT_OF_MEMORY

Не удалось загрузить хранилище состояний HDFS с идентификатором <stateStoreId> из-за исключения из памяти.

INCORRECT_NUMBER_FORMAT

Не удалось загрузить хранилище состояний. Полученное сообщение об ошибке: <errorMsg>

INVALID_CHANGE_LOG_READER_VERSION

Версия средства чтения журналов изменений не может быть <version>. Возможно, контрольная точка создана будущей версией Spark, пожалуйста, обновите Spark.

INVALID_CHANGE_LOG_WRITER_VERSION

Версия записи журнала изменений не может быть <version>.

Недействительная родословная контрольной точки

Недопустимая последовательность контрольных точек: <lineage>. <message>

KEY_ROW_FORMAT_VALIDATION_FAILURE

<msg>

LOCAL_DISK_ERROR

Не удалось загрузить хранилище состояний с идентификатором <stateStoreId> поставщика <stateStoreProviderName> из-за ошибки локального диска. Распространенной причиной этого может быть нехватка места на локальном диске исполнителя.

ROCKSDB_STORE_PROVIDER_OUT_OF_MEMORY

Не удалось загрузить хранилище состояний RocksDB с идентификатором <stateStoreId> из-за исключения недостатка памяти.

ПРОВЕРКА_КОНТРОЛЬНОЙ_СУММЫ_СТРОК_НЕУДАЧНАЯ

<originalMessage>

SNAPSHOT_PARTITION_ID_NOT_FOUND

Идентификатор раздела <snapshotPartitionId> не найден для состояния оператора <operatorId> в <checkpointLocation>.

UNCATEGORIZED

UNEXPECTED_FILE_SIZE

Скопировано из <dfsFile> в <localFile>, ожидалось <expectedSize> байтов, обнаружено <localFileSize> байтов.

UNEXPECTED_VERSION

Версия не может быть <version> , так как она меньше 0.

UNRELEASED_THREAD_ERROR

<loggingId>: экземпляр RocksDB не удалось получить для <newAcquiredThreadInfo> operationType=<operationType> так как он не был выпущен <acquiredThreadInfo> после <timeWaitedMs> ms.

Поток, удерживающий блокировку, имеет трассировку: <stackTraceOutput>

VALUE_ROW_FORMAT_VALIDATION_FAILURE

<msg>

VERSIONID_MISMATCH

Идентификатор версии локального файла RocksDB не соответствует идентификатору, созданному в версии <version>.