Поделиться через


Outlook не удается получить доступ к общедоступным папкам, размещенным на серверах Exchange прежних версий

Оригинальный номер базы знаний: 3177600

Симптомы

Рассмотрим следующий сценарий.

В этом сценарии пользователи с почтовым ящиком на основе Exchange 2013 или Exchange 2016 не могут получить доступ к общедоступным папкам с помощью Microsoft Outlook.

Причина

Эта проблема возникает, если база данных почтовых ящиков, в которую размещается почтовый ящик пользователя, настроена для базы данных общедоступных папок, которая отличается от базы данных почтовых ящиков обнаружения общедоступных папок.

Разрешение

Чтобы устранить эту проблему, настройте базу данных почтовых ящиков пользователя на использование той же базы данных общедоступных папок, что и почтовый ящик обнаружения:

  1. Назначьте почтовый ящик обнаружения общедоступных папок почтовому ящику пользователя с помощью командлета Set-Mailbox следующим образом:

    Set-Mailbox <User> -DefaultPublicFolderMailbox <ProxyMailbox>
    
  2. Назначьте базу данных общедоступных папок для базы данных почтовых ящиков пользователя с помощью командлета Set-MailboxDatabase следующим образом:

    Set-MailboxDatabase (Get-Mailbox <User>).Database -PublicFolderDatabase (Get-MailboxDatabase (Get-Mailbox <ProxyMailbox>).Database).PublicFolderDatabase
    
  3. Выполните следующий командлет, чтобы перезапустить службу клиентского доступа Microsoft Exchange Rpc на сервере, на котором выполняются Exchange Server, на котором размещены общедоступные папки:

    Restart-Service MSExchangeRPC