Поделиться через


При обходе контента в базе данных Exchange Server 2010 года сохраняется состояние индекса контента

Исходный номер базы знаний: 2820817

Симптомы

В базе данных Microsoft Exchange Server 2010 состояние индекса содержимого отображается как "обход контента", и он никогда не достигает состояния "работоспособный". Кроме того, несмотря на то, что счетчик производительности Число документов, успешно индексированных, показывает постепенное увеличение числа индексированных документов, значение в счетчике Число почтовых ящиков, оставленных для обхода контента, не уменьшается должным образом.

В этом случае в журнале приложений регистрируются следующие события:

Time:
ID: 102
Level: Error
Source: MSExchange Search Indexer
Machine: Mailboxserver.contoso.com
Message: Exchange Search Indexer has failed to crawl the mailbox (8832ee80-47b8-4b0e-a98f-c4a239794707) in database (Database1) due to error: (Microsoft.Exchange.Search.MailboxCrawlFailedException: Failed to logon to mailbox). This mailbox will be retried later.
Time:
ID: 5617
Level: Error
Source: CI Troubleshooter
Machine: Mailboxserver.contoso.com
Message: CI troubleshooter exchange search service restart attempt 81.

Причина

Эта проблема возникает, когда System Center Operations Manager выполняет скрипт Toubleshoot-CI.ps1. Это приводит к перезапуску служба Exchange до завершения процесса индексирования.

Разрешение

Чтобы устранить эту проблему, запретите запуск скрипта Troubleshoot-CI.ps1 на сервере System Center Operations Manager следующим образом:

  1. Откройте System Center Operations Manager.
  2. Щелкните Монитор объектов> пакета управления.
  3. В поле Поиск введите устранение неполадок и нажмите кнопку Найти.
  4. Найдите элемент, соответствующий Troubleshoot-CI.ps1 скрипту, щелкните его правой кнопкой мыши и выберите пункт Свойства.
  5. На вкладке Переопределение щелкните Переопределить.
  6. Установите флажок Включено проверка, задайте для параметра Переопределить значениеFalse и нажмите кнопку ОК.

Дополнительная информация

Как правило, System Center Operations Manager выполняет скрипт Troubleshoot-CI.ps1 каждые два часа. Однако если скрипт Troubleshoot-CI.ps1 обнаруживает один из следующих симптомов, он активирует перезапуск службы поиска Exchange:

  • Взаимоблокировка: взаимоблокировки поиска Exchange во время ожидания потоков из MSSearch.
  • Повреждение: один или несколько индексов поиска повреждены.
  • Стойло: напоминает взаимоблокировку, так как индексы не обновляются.
  • Невыполненная работа. Каталог поиска находится в невыполненной записи, поэтому запланированный поиск по индексу не выполняется должным образом.

Ниже приведен пример события, которое регистрируется при выполнении скрипта Troubleshoot-CI.ps1:

Time:
ID: 5611
Level: Error
Source: CI Troubleshooter
Machine: Mailboxserver.contoso.com
Message: Indexing backlog reached a critical limit of 48 hours or the number of items in the retry queue is greater than 10000 for one or more databases: Database1 (0, 12572, 0)Database1 (0, 31859, 0)

Если базы данных имеют большие почтовые ящики или почтовые ящики с высоким числом элементов, процесс индексирования обычно занимает больше двух часов. После перезапуска службы поиска Exchange почтовые ящики возвращаются в список для повторной индексации. В этой ситуации процесс обхода контента может никогда не получить шанс завершить.