Поделиться через


Не удается удалить элементы из общедоступной папки в Outlook в Интернете

Симптомы

При попытке удалить элементы в общедоступной папке с помощью Outlook в Интернете (OWA) удаленные элементы снова появляются после закрытия и повторного открытия Outlook в Интернете. При возникновении этой проблемы сообщение об ошибке не отображается.

Причина

Почтовый ящик общедоступной папки, в котором размещается общедоступная папка, мог достичь квоты на элементы, доступные для восстановления. Вы можете собрать трассировку сети при воспроизведении проблемы в OWA. Выполните поиск по "action=DeleteItem", чтобы найти URL-адрес OWA. Может появиться следующий полный ответ:

{"Header":{"ServerVersionInfo":{"MajorVersion":15,"MinorVersion":20,"MajorBuildNumber":2991,"MinorBuildNumber":0,"Version":"V2018_01_08"}},"Body":{"__type":"DeleteItemResponse:#Exchange","ResponseMessages":{"Items":[{"__type":"DeleteItemResponseMessage:#Exchange","MessageText":"Произошла внутренняя ошибка сервера. Операция завершилась сбоем.","ResponseCode":"ErrorInternalServerError","MessageXml":"<?xml version=\"1.0\"?>\r\n<XmlNodeArray xmlns:t=\"http://schemas.microsoft.com/exchange/services/2006/types\" xmlns:m=\"http://schemas.microsoft.com/exchange/services/2006/messages\">\r\n <t:Value Name=\"InnerErrorMessageText\">Не удается удалить сообщение, так как целевая папка превышена.</t:Value>\r\n t:Value Name=\"InnerErrorResponseCode\">ErrorQuotaExceedededOnDelete</t:Value>\r\n <t:Value Name=\"InnerErrorDescriptiveLinkKey\">0</t:Value>\r\n</XmlNodeArray>","ResponseClass":"Error"}}<}}

Разрешение

Очистите удаленные элементы из общедоступной папки, чтобы освободить хранилище, а затем повторите попытку, чтобы удалить элемент:

  1. Подключитесь к общедоступной папке с помощью классического клиента Outlook.
  2. Перейдите в общедоступную папку и выберите Восстановить удаленные элементы на ленте.
  3. Выберите элементы для удаления, выберите Очистить выбранные элементы, а затем нажмите кнопку ОК.
  4. Удалите эти элементы еще раз.

Дополнительная информация

Если вы выполняете поиск определенных элементов в общедоступной папке с помощью Outlook в Интернете и удаляете элементы из результатов поиска, удаленные элементы снова появляются после закрытия и повторного открытия Outlook в Интернете. Действие удаления результатов поиска в OWA не поддерживается для элементов общедоступных папок. Удалите элемент общедоступной папки напрямую без его поиска или используйте Microsoft Outlook для удаления элемента.