Устранение неполадок с политикой условного доступа

Copilot Studio поддерживает аутентификацию и авторизацию конечных пользователей с помощью Microsoft Entra ID, поэтому пользователи агентов могут использовать свои учетные данные Microsoft Entra ID для проверки подлинности. Ваша организация управляет этими учетными данными.

Однако пользователи могут столкнуться с проблемами, связанными с политиками Conditional Access которые влияют на эффективное использование Copilot Studio агентов.

Признаки

Агенты могут не отвечать конечным пользователям на определённых каналах, таких как Teams, из-за политик условного доступа, реализованных через Microsoft Entra ID.

Пользователи ваших агентов могут увидеть пустую страницу в окне чата или получить сообщение об ошибке, указывающее, что агент недоступен, и тестовый чат не отвечает на запросы.

Причина

Исполнение политики: Благодаря недавним обновлениям безопасности, которые обеспечивают усиление контроля аутентификации, Copilot Studio агент получает токен аутентификации, специфичный для конкретного клиента.

При введении этих правил агенты не начинают разговор и не отвечают конечным пользователям, если политики условного доступа блокируют получение токена аутентификации.

Принудительное применение применяется к существующим агентам, созданным в клиентах с политиками условного доступа, которые ранее не мешали агенту отвечать конечным пользователям.

Устранение

Вы можете увидеть, какая политика условного доступа блокирует запрос, чтобы провести расследование и принять соответствующие меры. Для получения рекомендаций по решению проблем или изменению политик условного доступа смотрите другие ресурсы в конце этой статьи.

Кроме того, может потребоваться разрешить определенные IP-адреса и диапазоны IP-адресов, которые используются службами Copilot Studio, Power Platform или другими службами Microsoft.

Вы можете получить доступ к логам условного доступа для конкретного агента Copilot Studio через регистрацию приложения агента в Microsoft Entra. Вы также можете просмотреть журналы для всех агентов, вручную отфильтровав их в разделе Identity (Идентификация) в Entra.

Совет

В зависимости от того, кто сделал запрос, связанный журнал может относиться к одной из нескольких категорий входа в Entra.

Проверьте каждую вкладку на странице журналов входа с условным доступом.

Получение журналов условного доступа для всех агентов Copilot Studio

  1. Войдите в центр администрирования Microsoft Entra как минимум в качестве читателя отчетов.

  2. Откройте раздел Идентификатор в боковом меню. Выберите Мониторинг и работоспособность, затем выберите Журналы аудита.

  3. Выберите диапазон дат, который вы хотите запросить.

  4. Выберите « Добавить фильтры » над списком входов, а затем выбрать «Приложение». Установите фильтр на Приложение содержит: Copilot Studio.

  5. Таким же образом добавьте фильтр Условный доступ и задайте для него значение Сбой. Выберите Применить.

    Снимок экрана страницы событий входа в Microsoft Entra с добавленным фильтром условного доступа, выделенным над списком входов.

Получение журналов условного доступа для конкретного агента Copilot Studio

  1. Войдите в центр администрирования Microsoft Entra.
  2. Откройте раздел Регистрации приложений в боковом меню, на главной странице или выполнив поиск в строке поиска в верхней части экрана.
  3. Откройте регистрацию агента, которого вы хотите просмотреть.
  4. На странице Обзор в разделе Основные сведения выберите ссылку на Управляемое приложение в локальном каталоге. Появляется предварительно отфильтрованный список логов условного доступа для этого агента.

Выявление и устранение сбоев политик

По умолчанию в журналах аудита отображаются все действия. Откройте фильтр Действия, чтобы при необходимости сузить круг действий. Для списка деятельности в журнале аудита для условного доступа см. Microsoft Entra задачи журнала аудита в документации Entra Conditional Access .

  1. Просмотрите действия на каждой вкладке, чтобы найти те, для которых произошел сбой политики условного доступа для Copilot Studio.

  2. Выберите запись, чтобы открыть панель «Информация о активности », затем перейдите на вкладку «Условный доступ ». Перечислены соответствующие политики, вызвавшие проблему, вместе с действиями, принятыми в результате этой политики, например , блокировка.

После того как вы определите соответствующий полис, проведите диагностику, чтобы определить, что вам нужно сделать. Например, вы можете по-прежнему разрешать политике блокировать взаимодействия с агентами, изменять область действия политики, изменять или отключать политику.

В следующих статьях в документации по условному доступу Microsoft Entra подробно описаны дальнейшие действия, которые можно предпринять в Entra для решения проблемы: