Поделиться через


Учетные данные не работают для содержимого, защищенного IRM

Симптомы

При попытке открыть защищенный IRM документ, книгу, сообщение электронной почты или другой элемент, вы обнаружите, что у вас нет доступа к элементу, даже если вы правильно вошли в Microsoft Office. Кроме того, вам будет предложено войти, но вы по-прежнему не можете получить доступ к содержимому, когда вы должны иметь доступ к нему.

Обычно этот симптом заключается в том, что вам будет предложено войти, но учетные данные не работают.

Причина

Это происходит при выполнении следующих условий:

  • Ваша среда настроена для междоменной проверки подлинности.
  • Домен, в котором создается содержимое, настроен на требования к условному доступу.
  • Проверка подлинности завершается ошибкой.

Например, John@contoso.com защищает содержимое и отправляет его в Jenny@fabrikam.com. Чтобы получить доступ к защищенному содержимому, необходимо пройти проверку подлинности, Jenny@fabrikam.com чтобы contoso.com получить ключ для расшифровки содержимого. Если contoso.com имеет требования к условному доступу, эта проверка подлинности может завершиться ошибкой.

Большинство проблем с условным доступом требуют подготовки пользователя в клиенте ресурса (contoso.com). Если гостевой пользователь (Jenny@fabrikam.com) явно приглашен и приглашение активировано, Jenny@fabrikam.com подготавливается в contoso.com клиента ресурса. Если пользователь является пользователем сквозной передачи, код проверки условного доступа, обслуживающий contoso.com , не имеет способа удовлетворить проблемы, поэтому запрос завершается ошибкой. Это ожидаемое и безопасное поведение. Во многих случаях это поведение приводит к тому, что клиентский код Office запрашивает вход, чтобы пользователь смог предоставить учетные данные для открытия файла из-за сбоя проверки подлинности.

Справочные материалы

Дополнительные сведения о политиках условного доступа см. в следующем блоге:

Политики условного доступа для Azure Information Protection