Поделиться через


Невозможно запустить Outlook в кэшированном режиме или создать новый профиль кэшированного режима

Исходный номер базы знаний: 3046189

Признак

При запуске Microsoft Outlook в кэшированном режиме появляется следующее сообщение об ошибке:

Невозможно запустить Microsoft Outlook. Невозможно открыть окно Outlook. Не удается открыть набор папок. Недостаточно памяти для выполнения операции.

Примечание.

Это сообщение об ошибке также отображается при попытке создать новый профиль Outlook, настроенный для использования кэшированного режима.

Причина

Эта проблема возникает из-за того, что скрытое PR_OST_OSTID свойство в почтовом ящике превышает 32 килобайта (КБ).

Это свойство находится в верхней части хранилища сведений в хранилище по умолчанию. Каждый раз, когда вы создаете новый профиль режима кэширования для почтового ящика, в это свойство добавляется около 20 байт данных. В конечном итоге размер данных в свойстве превышает примерно 32 720 байт, и вы начнете получать ошибку.

Разрешение

Чтобы устранить эту проблему, удалите данные в двоичном свойстве PR_OST_OSTID. Для этого выполните следующие действия:

  1. Скачайте и извлеките средство MFCMAPI .

  2. Запустите Mfcmapi.exe, а затем нажмите кнопку ОК , чтобы перейти по экрану введения.

  3. В меню Инструменты выберите пункт Параметры.

  4. Включите следующие параметры и нажмите кнопку ОК:

    • Использовать флаг MDB_ONLINE при вызове OpenMsgStore
    • Использовать MAPI_NO_CACHE при вызове OpenEntry
  5. В меню Сеанс выберите пункт Вход.

  6. Выберите профиль режима кэширования Outlook для почтового ящика и нажмите кнопку ОК.

  7. Дважды щелкните адрес электронной почты, представляющий соответствующий почтовый ящик.

  8. В области навигации разверните узел Корневой контейнер, а затем выберите Top of Information Store.

  9. На правой панели найдите PR_OST_OSTID свойство .

    Примечание.

    Вы можете увидеть PR_OST_OSTID в столбце Имена свойств или в столбце Другие имена . Если он находится в столбце Имена свойств, значение в столбце Тег будет 0x7C040102. Если PR_OST_OSTID находится в столбце Другие имена , значение в столбце Тег будет 0x7C04000A.

    1. Если значение в столбце Тег 0x7C040102, дважды щелкнитеPR_OST_OSTID, чтобы открыть Редактор Свойства.
    2. Если значение в столбце Тег 0x7C04000A, щелкните правой кнопкой мыши PR_OST_OSTID, выберите Изменить как поток, а затем — Двоичный.
  10. Щелкните правой кнопкой мыши данные в разделе Двоичные свойства Редактор и выберите Выбрать все.

    Снимок экрана: двоичное свойство PR_OST_OSTID.

  11. Щелкните правой кнопкой мыши выбранные данные в разделе Двоичный файл и выберите команду Удалить.

  12. Нажмите ОК.

  13. Закройте средство MFCMAPI и запустите Outlook.

Дополнительная информация

Существует несколько сценариев, в которых может возникнуть такая ситуация:

  1. Многие пользователи многократно входят в почтовый ящик. (Например, многие пользователи входят в почтовый ящик, который используется для ответов на общедоступные или служебные сообщения.)
  2. Многие пользователи открывают почтовый ящик общего ресурса, когда в профиле Outlook включена загрузка общих папок .
  3. Кто-то неоднократно создает новые профили режима кэширования для своего почтового ящика. (Это происходит редко.)