Поделиться через


Ошибка "Не удалось скачать" при скачивании файлов с защищенных веб-сайтов в Internet Explorer 9 и более поздних версиях

Предупреждение

Устаревшее и не поддерживаемое классическое приложение Internet Explorer 11 было окончательно отключено путем обновления Microsoft Edge в некоторых версиях Windows 10. Дополнительные сведения см. в разделе "Часто задаваемые вопросы о завершении поддержки настольного приложения Internet Explorer 11".

В этой статье содержатся сведения об устранении ошибки, возникающей при попытке скачать файлы с помощью Internet Explorer 9 или более поздней версии.

Исходная версия продукта: Internet Explorer 9 и более поздних версий
Исходный номер базы знаний: 2549423

Симптомы

Файлы или файлы нельзя скачать с веб-сайта при подключении к сайту по протоколу HTTPS (безопасные сайты) с помощью Internet Explorer 9 или более поздней версии. Например, вы посещаете безопасный веб-сайт, например банк или другое финансовое учреждение, и пытаетесь скачать или просмотреть PDF-файл. Файл не отображается в Internet Explorer и может появиться сообщение об ошибке, аналогичное следующему:

Сообщение об ошибке 1

Internet Explorer не удается скачать

Сообщение об ошибке 2

<Не удалось скачать файл>

Эта проблема возникает, если выбран параметр "Не сохранять зашифрованные страницы на диске " в Internet Explorer.

Примечание.

Сведения о сообщении об ошибке "Не удается загрузить Internet Explorer" в Internet Explorer 8 при использовании URL-адреса HTTPS для открытия документа Office или PDF-файла см. в разделе "Internet Explorer Cannot Download" error message when you use an HTTPS URL to open an office document or PDF file.

Причина

Чтобы скачать файлы, Internet Explorer должен создать кэш или временный файл. В Internet Explorer 9 или более поздней версии, если файл поставляется по протоколу HTTPS, а заголовки ответов настроены для предотвращения кэширования, и если параметр "Не сохранять зашифрованные страницы на диск " установлен, файл кэша не создается. Поэтому скачивание завершается ошибкой.

Решение — метод 1

Чтобы устранить эту проблему, сначала попробуйте использовать метод 1. Если метод 1 завершается ошибкой, перейдите к методу 2.

  1. В меню "Сервис" в Internet Explorer 9 или более поздней версии выберите пункт "Параметры браузера" и перейдите на вкладку "Дополнительно ".
  2. Щелкните, чтобы снять флажок из флажка "Не сохранять зашифрованные страницы" на диск в области безопасности , а затем нажмите кнопку "ОК". (Это параметр Internet Explorer по умолчанию.)

Снимок экрана: окно

Разрешение — метод 2

  1. Откройте редактор реестра.

  2. Для настройки каждого пользователя найдите следующий раздел реестра:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

    Для настройки на уровне каждого компьютера найдите следующий ключ реестра:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

  3. В меню "Изменить " нажмите кнопку "Добавить значение", а затем добавьте следующее значение:
    BypassSSLNoCacheCheck=Dword:00000001

  4. Закройте редактор реестра.