Поделиться через


При щелчке ссылки в Internet Explorer ничего не происходит

Предупреждение

Устаревшее и не поддерживаемое классическое приложение Internet Explorer 11 было окончательно отключено путем обновления Microsoft Edge в некоторых версиях Windows 10. Дополнительные сведения см. в разделе Часто задаваемые вопросы о выводе из эксплуатации классического приложения Internet Explorer 11.

Эта статья поможет устранить проблему, из-за которой не удается открыть веб-страницу при щелчке гиперссылки в Internet Explorer.

Исходная версия продукта: Internet Explorer 9
Исходный номер базы знаний: 175775

Симптомы

При щелчке гиперссылки на веб-странице или в сообщении электронной почты ничего не происходит. Internet Explorer не открывает веб-страницу.

Примечание.

Эта информация применяется к Internet Explorer 9, Internet Explorer 8 и Internet Explorer 7.

Причина

Это может произойти по одной из указанных ниже причин:

  • Параметр, в котором вы выбираете нужный веб-браузер, поврежден. Это может привести к тому, что Windows неправильно интерпретирует, какой браузер установлен в качестве браузера по умолчанию на вашем компьютере.
  • После установки программного обеспечения были изменены параметры, что может привести к неправильной работе ссылок на веб-страницы.
  • Ранее установленный браузер или надстройка могут конфликтовать с другим программным обеспечением на компьютере.
  • Разделы реестра были изменены или повреждены.

Решение

Этот раздел предназначен для начинающих пользователей компьютера и пользователей со средним уровнем подготовки. Если эти методы не устраняют проблему, можно попробовать методы в разделе "Дополнительное устранение неполадок ". Чтобы решить эту проблему, воспользуйтесь приведенными ниже методами в указанном порядке.

Метод 1. Проверка параметра веб-браузера по умолчанию

В Microsoft Windows вы можете выбрать веб-браузер, который хотите использовать. Чтобы использовать Internet Explorer в качестве браузера по умолчанию, выполните следующие действия:

  1. Чтобы открыть Internet Explorer, нажмите кнопку "Пуск" и выберите Internet Explorer.
  2. Если вам будет предложено подтвердить, что Internet Explorer будет браузером по умолчанию, нажмите кнопку "Да".
  3. В меню "Сервис" выберите пункт "Параметры браузера".
  4. Нажмите кнопку " Программы>сделать по умолчанию>ОК", а затем закройте Internet Explorer.

Примечание.

Изменения вступят в силу при последующем запуске Internet Explorer.

Проверьте, устранена ли проблема. Если проблема устранена, с этой статьей можно закончить. Если проблема не устранена, попробуйте следующий метод.

Метод 2. Изменение типов файлов, которые Internet Explorer открывает по умолчанию

Для Windows 7 и Windows Vista.

  1. Закройте все окна браузера Internet Explorer.
  2. Нажмите кнопку "Пуск" и нажмите кнопку "Панель управления".
  3. Щелкните "Программы" и нажмите кнопку "Задать программы по умолчанию".
  4. В меню "Программы" щелкните Internet Explorer и выберите параметры по умолчанию для этой программы.
  5. Убедитесь, что флажки для .htm, .html и urls выбраны, а затем нажмите Сохранить.
  6. Нажмите кнопку ОК.

Примечание.

Изменения вступят в силу при последующем запуске Internet Explorer.

Для Windows XP

  1. Чтобы открыть проводник Windows, щелкните правой кнопкой мыши "Пуск" и выберите пункт "Мой компьютер".

  2. В меню "Сервис" выберите пункт "Параметры папки" и перейдите на вкладку "Типы файлов ".

  3. Найдите и выберите тип HTM-файла.

  4. Убедитесь, что Internet Explorer выбран в качестве открываемой программы. Если Internet Explorer не выбран, нажмите кнопку "Изменить", выберите Internet Explorer в качестве рекомендуемой программы и нажмите кнопку "ОК".

  5. Повторите шаги 3 и 4 для следующих типов файлов:

    • HTML
    • ITS
    • MHT
    • MTHML
    • XML
    • XSL

Проверьте, устранена ли проблема. Если проблема устранена, с этой статьей можно закончить. Если проблема не устранена, воспользуйтесь следующим методом.

Метод 3. Использование режима без надстроек в Internet Explorer

Хотя надстройки могут улучшить вашу работу с Интернетом, иногда они могут влиять на другое программное обеспечение, установленное на компьютере, или конфликтовать с ним. Однако следует иметь в виду, что некоторые веб-страницы или сам Internet Explorer могут отображать содержимое неправильно, если надстройка отключена. Сначала запустите Internet Explorer с временно отключенными надстройками, чтобы узнать, устранена ли проблема. (Надстройки будут отключены только до тех пор, пока вы не перезапустите Internet Explorer обычным образом). Для этого выполните следующие шаги.

  • Нажмите кнопку "Пуск", введите Internet Explorer в поле поиска и выберите Internet Explorer (без надстроек).

    Примечание.

    Для Windows XP нажмите кнопку "Пуск ", щелкните правой кнопкой мыши значок Internet Explorer и нажмите кнопку "Обзор без надстроек".

Если в Internet Explorer режим без надстроек устраняет проблему, выполните следующие действия, чтобы выявить надстройку браузера, которая вызывает проблему:

  1. Чтобы запустить Internet Explorer, нажмите кнопку "Пуск" и щелкните Internet Explorer.
  2. Нажмите кнопку "Сервис " и нажмите кнопку "Управление надстройками".
  3. Щелкните надстройку в списке имен и нажмите кнопку "Отключить". Проверьте работу браузера Internet Explorer.
  4. Повторяйте шаг 3, пока не определите, какая надстройка вызывает проблему.

Проверьте, устранена ли проблема. Если проблема устранена, с этой статьей можно закончить. Если проблема не устранена, попробуйте следующий метод.

Метод 4. Сброс параметров Internet Explorer

Если проблема вызвана поврежденными или несовместимыми параметрами Internet Explorer или надстройками, эту проблему можно устранить, сбросив параметры Internet Explorer до параметров по умолчанию.

При сбросе параметров Internet Explorer все предыдущие параметры теряются и не могут быть восстановлены. После восстановления параметров по умолчанию Internet Explorer некоторые веб-страницы, зависящие от хранимых в браузере файлов cookie, данных форм, паролей или ранее установленных надстроек, могут начать работать неправильно. Однако при восстановлении параметров по умолчанию в Internet Explorer не удаляется папка «Избранное», веб-каналы и некоторые другие личные настройки.

Чтобы сбросить параметры Internet Explorer, выполните указанные ниже действия:

  1. Закройте все окна браузера Internet Explorer.

  2. Нажмите кнопку "Пуск", введите inetcpl.cpl в поле поиска и щелкните inetcpl.cpl в списке "Программы". Появится диалоговое окно Свойства браузера.

    Примечание.

    для Windows XP нажмите кнопку "Пуск", нажмите кнопку "Запустить", введите inetcpl.cpl в поле "Открыть" и нажмите кнопку "ОК".

  3. Перейдите на вкладку "Дополнительно".

  4. В разделе "Сброс параметров Internet Explorer" нажмите кнопку "Сброс". Затем нажмите «Сброс» ещё раз.

  5. Когда Internet Explorer завершит сброс, нажмите кнопку «Закрыть» в диалоговом окне «Сброс параметров Internet Explorer».

  6. Снова запустите Internet Explorer. Изменения вступят в силу при следующем запуске Internet Explorer.

Метод 5. Повторная регистрация необходимых DLL-файлов в Internet Explorer

Примечание.

Эта информация относится к Windows XP

Чтобы выполнить повторную регистрацию DLL-файлов, выполните следующие действия:

  1. Нажмите кнопку "Пуск", выберите " Все программы", щелкните " Аксессуары", щелкните правой кнопкой мыши cmd и выберите "Запуск от имени администратора". Если вам предлагается пароль администратора или подтверждение, введите пароль или укажите подтверждение.

  2. Введите regsvr32 urlmon.dll в поле "Открыть" и нажмите кнопку "ОК".

  3. Нажмите кнопку "ОК " при получении подтверждения.

  4. Повторите шаги 2 и 3 для следующих команд:

    • regsvr32 mshtml.dll
    • regsvr32 shdocvw.dll
    • regsvr32 browseui.dll
    • regsvr32 msjava.dll

Проверьте, устранена ли проблема. Если проблема устранена, с этой статьей можно закончить. Если проблема не устранена, перейдите к следующему разделу.

Расширенное устранение неисправностей

Этот подраздел предназначен для опытных пользователей.

Метод 1. Создание новой учетной записи пользователя

Дополнительные сведения о профилях пользователей см. в разделе "Сведения о профилях пользователей".

Дополнительные сведения о методах см. на указанных ниже веб-сайтах Майкрософт:

Метод 2. Использование программы восстановления системы

Восстановление системы использует точки восстановления для возврата системных файлов и параметров в более ранний момент времени, не затрагивая личные файлы. Точки восстановления создаются автоматически каждую неделю и сразу перед значимыми системными событиями, такими как установка программы, устройства или драйвера.

Перед началом восстановления системы сохраните все открытые файлы и закройте все программы. После подтверждения точки восстановления программа восстановления системы перезапустит компьютер. Чтобы выполнить восстановление системы, выполните следующие действия:

Windows 7 и Windows Vista

  1. Нажмите кнопку "Пуск", нажмите кнопку "Все программы", выберите " Стандартные", выберите " Системные инструменты", а затем нажмите кнопку "Восстановить систему". Если вам предлагается пароль администратора или подтверждение, введите пароль или укажите подтверждение.

  2. Нажмите кнопку "Далее" на странице "Восстановление системы".

  3. Выберите нужную дату или описание восстановления системы.

    Примечание.

    Если нужные даты не отображаются, выберите «Показать дополнительные даты», а затем выберите нужные даты.

  4. В окне подтверждения нажмите кнопку "Готово". Компьютер будет перезагружен. После завершения процесса отобразится сообщение с подтверждением.

Для Windows XP

  1. Войдите в систему Windows с использованием учетной записи, у которой имеются права администратора.
  2. Нажмите кнопку "Пуск", нажмите кнопку "Все программы", выберите " Стандартные", выберите " Системные инструменты", а затем нажмите кнопку "Восстановить систему".
  3. На странице "Добро пожаловать в системное восстановление" выберите параметр "Восстановить мой компьютер до предыдущего времени ", а затем нажмите кнопку "Далее".
  4. На странице "Выбор точки восстановления" щелкните самую последнюю точку восстановления в этом списке, выберите список точек восстановления и нажмите кнопку "Далее".
  5. На странице выбора точки восстановления нажмите кнопку "Далее". Программа восстановления системы восстановит предыдущую конфигурацию Windows XP и перезагрузит компьютер.
  6. Выполните вход на компьютер от имени администратора. Затем нажмите ОК на странице "Завершение восстановления системы". Компьютер будет перезагружен. После завершения процесса отобразится сообщение с подтверждением.

Если вы используете программу восстановления системы, но проблема по-прежнему не устранена или возникают другие проблемы, операцию восстановления можно отменить. После отмены операции можно попробовать использовать другую точку восстановления. Для отмены операции восстановления системы выполните перечисленные ниже действия:

  1. Нажмите кнопку "Пуск", нажмите кнопку "Все программы", выберите " Стандартные", выберите " Системные инструменты", а затем нажмите кнопку "Восстановить систему".
  2. Нажмите кнопку "Отменить восстановление системы" и нажмите кнопку "Далее".
  3. Просмотрите выбранные варианты и нажмите кнопку "Готово".

Компьютер будет перезагружен. После завершения процесса отобразится подтверждение.

Дополнительные ресурсы

Проверьте, устранена ли проблема. Если проблема устранена, с этой статьей можно закончить. Если проблема не устранена, обратитесь в службу поддержки корпорации Майкрософт для поиска других решений. Служба поддержки корпорации Майкрософт использует следующие методы: