Примечание
Для доступа к этой странице требуется авторизация. Вы можете попробовать войти или изменить каталоги.
Для доступа к этой странице требуется авторизация. Вы можете попробовать изменить каталоги.
В этой статье приводится решение об ошибке, возникающей при попытке подключить Microsoft Dynamics CRM 2013 для Microsoft Office Outlook к CRM Online.
Применимо к: Microsoft Dynamics CRM Online
Исходный номер Базы знаний: 3089686
Симптомы
При попытке подключить Microsoft Dynamics CRM 2013 для Microsoft Office Outlook (Outlook Client) к организации CRM Online вы получите следующую ошибку:
"Не удается подключиться к серверу Microsoft Dynamics CRM, так как мы не можем пройти проверку подлинности ваших учетных данных. Проверьте подключение или обратитесь к администратору, чтобы получить дополнительную помощь".
При выборе сведений вы увидите следующие дополнительные сведения:
значение не может быть равно NULL.
Имя параметра: path1
в System.IO.Path.Combine(String path1, String path2)
в Microsoft.Crm.Passport.IdCrl.FederationLogOnManager..ctor(String environment)
в Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider`1.GetLogonManager()
в Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider`1.SignIn()
at Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory'1.SignIn(Uri endPoint, учетные данные, AuthUIMode uiMode, IClientOrganizationContext context, Form parentWindow, Boolean retryOnError)
в Microsoft.Crm.Application.Outlook.Config.DeploymentsInfo.DeploymentInfo.LoadOrganizations(AuthUIMode uiMode, Form parentWindow, учетные данные)
на сайте Microsoft.Crm.Application.Outlook.Config.DeploymentsInfo.InternalLoadOrganizations(organizationDetailCollection orgs, AuthUIMode uiMode, Form parentWindow)
Причина
Помощник по входу в Microsoft Online Services не установлен или не указан правильный имя пользователя и пароль. Если проблема вызвана неправильным именем пользователя или паролем, это могут быть учетные данные, кэшированные в диспетчере учетных данных Windows.
Решение
Если помощник по входу в Microsoft Online Services не установлен, установите его, используя соответствующую ссылку ниже. После установки закройте и снова откройте мастер настройки Microsoft Dynamics CRM для Microsoft Office Outlook.
Если помощник по входу в Microsoft Online Services уже установлен, и вы по-прежнему получаете эту ошибку, нажмите кнопку "ОК ", и вы увидите запрос на имя пользователя и пароль. Если имя пользователя и пароль уже заполнены, это означает, что учетные данные были кэшированы. Повторно введите правильное имя пользователя и пароль, чтобы убедиться, что неверные учетные данные не используются.
Примечание.
Чтобы просмотреть, хранятся ли учетные данные в диспетчере учетных данных Windows, выберите меню "Пуск " в Windows и введите Диспетчер учетных данных. В области универсальных учетных данных могут отображаться учетные данные, начинающиеся с Microsoft_CRM. Если вы изменили пароль или использовали другую учетную запись пользователя, эти сохраненные учетные данные могут быть неверными. Эти учетные данные можно удалить, что не позволит Microsoft Dynamics CRM для Microsoft Office Outlook использовать их при попытке подключения.
Если ваша организация CRM Online уже обновлена до обновления 2015 (7.0 или более поздней версии), вы можете использовать Microsoft Dynamics CRM 2015 для Microsoft Office Outlook, который не зависит от Помощника по входу в Microsoft Online Services.
Дополнительная информация
Если помощник по входу в Microsoft Online Services не установлен, файл журнала содержит следующую ошибку:
19:23:00| Ошибка| Ошибка при подключении к URL-адресу:
https://disco.crm.dynamics.com/XRMServices/2011/Discovery.svc
Исключение: System.DllNotFoundException: Помощник по входу в веб-службы Microsoft Online Services не установлен. 32-разрядная версия: 64-разрядная версия:https://g.microsoftonline.com/0BX00en/500
https://g.microsoftonline.com/0BX00en/501