Поделиться через


Microsoft Dynamics CRM для телефонов и планшетов не может подключиться к организации Dynamics CRM из-за срока действия токена (TokenLifetime).

В этой статье представлено решение проблемы, связанной с тем, что Microsoft Dynamics CRM для телефонов и планшетов не может подключиться к организации Dynamics CRM из-за длины свойства TokenLifetime.

Область применения: Microsoft Dynamics CRM 2013, Microsoft Dynamics CRM 2013 с пакетом обновления 1 (SP1)
Исходный номер базы знаний: 3034570

Симптомы

При попытке настроить организацию Microsoft Dynamics CRM в любом из мобильных клиентских приложений Microsoft Dynamics CRM проверка подлинности вступает в некончающий цикл, в котором приложение, кажется, пытается выполнить некоторую проверку подлинности, но не завершается.

Причина

Большее значение, чем значение по умолчанию для свойства TokenLifetime в AD FS для доверяющей стороны, может привести к этому циклу проверки подлинности.

Решение

Рекомендуемое значение должно иметь значение TokenLifetimeпо умолчанию 0, что означает 600 минут или 10 часов. Использование параметра SSOLifetime в службе федерации вместо этого может запретить пользователям вводить свои учетные данные слишком часто в этих мобильных приложениях Microsoft Dynamics CRM. Значение по умолчанию SSOLifetime составляет 480 минут или 8 часов.

Дополнительная информация

Как изменить свойство SSO в ADFS, см.: Lifetime.

Как изменить TokenLifetime свойство проверяющей стороны ADFS с помощью PowerShell, см. проверку подлинности на основе утверждений и истечение срока действия маркера безопасности.