Примечание
Для доступа к этой странице требуется авторизация. Вы можете попробовать войти или изменить каталоги.
Для доступа к этой странице требуется авторизация. Вы можете попробовать изменить каталоги.
В этой статье предлагается решение проблемы, которая возникает из-за ошибки при продвижении данного элемента в Microsoft CRM при отслеживании исходящей электронной почты в Microsoft Dynamics CRM для Outlook.
Область применения: Microsoft Dynamics CRM 2011
Исходный номер базы знаний: 2708761
Симптомы
При отслеживании исходящего сообщения электронной почты в клиенте Microsoft Dynamics CRM для Outlook может возникнуть следующая ошибка:
Произошла ошибка при продвижении этого элемента в Microsoft CRM. Не удается связаться с Microsoft CRM Server или у пользователя недостаточно разрешений для выполнения этого действия.
Трассировка на стороне клиента Microsoft Dynamics CRM покажет следующее:
Указанные учетные данные доступа имеют недостаточно разрешений делегата для отправки сообщения электронной почты. Чтобы предоставить необходимые разрешения, обратитесь к администратору Microsoft Exchange.
Причина
Эта ошибка может быть вызвана приведенными ниже причинами.
- Контакт Outlook или предлагаемый контакт имеет отсутствующие свойства, такие как адрес электронной почты или свойства SMTP.
- Функция HidecontactfromExchangeaddresslists в Microsoft Exchange Server используется для адреса отправителя или получателя в сообщении электронной почты. При использовании этой функции вся информация о SMTP и адресе электронной почты удаляется из контакта во время синхронизации с Outlook, который используется в клиенте Microsoft Dynamics CRM для Outlook для продвижения электронной почты. Вместо этого он предоставляет значение Exchange DN в поле отображаемого имени.
По умолчанию Microsoft Dynamics CRM выбирает пользователя, который отслеживает сообщение электронной почты, отображаемое как отправитель электронной почты в Microsoft Dynamics CRM, если он не может найти SMTP-адрес электронной почты отправителя в исходном сообщении электронной почты в Outlook.
Решение
Если свойства MAPI повреждены или отсутствуют, попробуйте переадресовать сообщение электронной почты пользователю, который первоначально получил сообщение электронной почты. Затем настройте параметры в отношении правильного контакта. Кроме того, эти свойства могут быть повторно созданы. Обратитесь в службу поддержки Outlook для получения дополнительных сведений об этом процессе.
Если у контакта в Outlook или предлагаемого контакта отсутствуют какие-либо свойства, добавьте недостающие сведения, такие как адрес электронной почты.
Если вы используете функцию скрытия контакта из списков адресов Exchange Server, этот тип поведения определяется и ожидается в Microsoft Dynamics CRM, так как эта функция Exchange удаляет необходимые сведения, необходимые для Microsoft Dynamics CRM, чтобы найти исходного отправителя электронной почты из Outlook. Электронные письма можно отслеживать вручную с помощью параметра Set Regarding для привязки их к правильному контакту.