Примечание
Для доступа к этой странице требуется авторизация. Вы можете попробовать войти или изменить каталоги.
Для доступа к этой странице требуется авторизация. Вы можете попробовать изменить каталоги.
В этой статье приводится решение об ошибке, возникающей при тестировании доступа в маршрутизаторе электронной почты Microsoft Dynamics CRM.
Область применения: Microsoft Dynamics CRM
Исходный номер базы знаний: 2003033
Симптомы
При выборе тестового доступа в средстве настройки маршрутизатора электронной почты для Microsoft Dynamics CRM вы получите следующую ошибку для входящих сообщений электронной почты:
"Входящее состояние: сбой — удаленный почтовый сервер Microsoft Exchange вернул ошибку "(401) Несанкционированно". Убедитесь, что у вас есть разрешение на подключение к почтовому ящику. Удаленный сервер вернул ошибку: (401) Несанкционированно".
Причина
Одна или несколько следующих условий могут вызвать эту проблему:
- Учетная запись, указанная в профиле входящих данных, не имеет полного доступа к почтовым ящикам пользователей.
- Отсутствуют имена службевых субъектов (SPN) при использовании псевдонима для Microsoft Office Outlook Web Access.
- Последний накопительный пакет обновления для Microsoft Dynamics CRM не применяется.
- Проверка подлинности в виртуальных каталогах Exadmin и Exchange является неправильной.
- URL-адрес Outlook Web Access отсутствует в зоне локальной интрасети в Windows Internet Explorer на сервере, на котором установлен маршрутизатор электронной почты.
Решение 1
Убедитесь, что учетная запись, указанная в профиле входящих данных, имеет полный доступ к почтовым ящикам пользователей. Кроме того, убедитесь, что учетная запись локальной системы запускает службу маршрутизатора электронной почты Microsoft CRM.
Чтобы проверить учетную запись, которая запускает маршрутизатор электронной почты Microsoft CRM, выполните следующие действия на сервере, на котором установлен маршрутизатор электронной почты:
- Нажмите кнопку "Пуск", выберите "Запустить", введите Services.msc и нажмите кнопку "ОК".
-
Найдите службу маршрутизатора электронной почты Microsoft CRM.
Примечание.
Учетная запись, указанная в столбце "Вход в качестве" , а затем убедитесь, что для нее задано значение LocalSystem.
Чтобы проверить учетную запись, указанную для доступа к входящего профиля, выполните следующие действия на компьютере с установленным маршрутизатором электронной почты Microsoft CRM:
Выберите "Пуск", выберите "Все программы", выберите маршрутизатор электронной почты Microsoft Dynamics CRM, а затем выберите Диспетчер конфигурации маршрутизатора электронной почты Microsoft CRM.
Перейдите на вкладку "Профили конфигурации" , дважды щелкните "Входящий профиль" и запишите учетную запись, указанную в поле "Учетные данные доступа". Убедитесь, что эта учетная запись имеет полный доступ к почтовому ящику пользователя.
- Если вы используете параметр "Пересылка почты" для всех пользователей и очередей, рекомендуется использовать учетные данные пересылки в этом поле.
- Если вы используете параметр Маршрутизатора для пользователей и очередей, необходимо убедиться, что учетная запись, указанная в поле "Учетные данные доступа", имеет полный доступ ко всем почтовым ящикам этих пользователей.
Дополнительные сведения о добавлении дополнительных разрешений для почтовых ящиков пользователей см. в следующих статьях:
- Предоставление доступа к почтовому ящику
- Предоставление пользователю полного доступа к почтовому ящику другого пользователя
Решение 2
Если вы используете http://mail.domain.com
для веб-доступа к Outlook, но имя сервера Microsoft Exchange Server — Exchange01, необходимо добавить дополнительные имена субъектов-служб в учетную запись пользователя, для которого работает пул приложений для веб-сайта Exchange.
Чтобы определить учетную запись, которая запускает пул приложений Exchange, выполните следующие действия.
- Войдите в Microsoft Exchange Server.
- Нажмите кнопку "Пуск", выберите "Запустить", введите Inetmgr и нажмите кнопку "ОК".
- Разверните сервер в IIS и выберите пулы приложений.
- Учетная запись под управлением пула приложений Exchange отображается в области предварительной версии.
В учетную запись, которую вы указали на шаге 4, добавьте следующие SPN:
HTTP/Mail
HTTP/Mail.yourdomainname.com
Примечание.
Необходимо изменить эти SPNs, чтобы они соответствовали URL-адресу псевдонима, который пользователи используют для доступа к Outlook Web Access.
Для получения дополнительной информации о добавлении уникальных имен служб посетите следующие веб-сайты Майкрософт:
Резолюция 3
Примечание.
Это разрешение относится только к Microsoft Dynamics CRM 4.0.
Убедитесь, что для Microsoft Dynamics CRM 4.0 установлен хотя бы третий накопительный пакет обновления как на сервере Microsoft Dynamics CRM, так и на маршрутизаторе электронной почты Microsoft Dynamics CRM. Последний пакет накопительных обновлений настоятельно рекомендуется.
Дополнительные сведения и скачивание последнего накопительного пакета обновления для Microsoft Dynamics CRM см. в статье [Обновления и исправления Microsoft Dynamics CRM 4.0].
Резолюция 4
Проверьте следующую проверку подлинности в /Exchange
каталогах и /Exadmin
виртуальных каталогах:
- Убедитесь, что в виртуальной директории
/Exadmin
включены проверка подлинности Basic и проверка подлинности Windows. - Убедитесь, что обычная проверка подлинности включена в виртуальном каталоге
/Exchange
.
Чтобы проверить проверку подлинности в виртуальных каталогах, выполните следующие действия на Сервере Microsoft Exchange Server в соответствии с используемой операционной системой:
В Windows Server 2008:
- Нажмите кнопку "Пуск", выберите "Запустить", введите Inetmgr и нажмите кнопку "ОК".
- Разверните имя сервера, разверните Сайты и разверните сайт Exchange.
- Выберите виртуальный каталог /Exadmin, откройте проверку подлинности в области предварительной версии и убедитесь, что включена обычная проверка подлинности и проверка подлинности Windows.
- Выберите виртуальный каталог /Exchange , откройте проверку подлинности в области предварительной версии и убедитесь, что включена обычная проверка подлинности .
В Windows Server 2003:
- Нажмите кнопку "Пуск", выберите "Запустить", введите Inetmgr и нажмите кнопку "ОК".
- Разверните имя сервера, разверните Сайты и разверните сайт Exchange.
- Щелкните правой кнопкой мыши виртуальный каталог /Exadmin и выберите пункт "Свойства".
- Перейдите на вкладку "Безопасность каталога", выберите "Изменить" в разделе "Проверка подлинности и контроль доступа", а затем убедитесь, что включена обычная проверка подлинности и проверка подлинности Windows.
- Щелкните правой кнопкой мыши виртуальный каталог /Exchange и выберите пункт "Свойства".
- Перейдите на вкладку "Безопасность каталога", выберите "Изменить" в разделе "Проверка подлинности и контроль доступа", а затем убедитесь, что включена обычная проверка подлинности и проверка подлинности Windows.
Решение 5
Добавьте URL-адрес Outlook Web Access в зону локальной интрасети и убедитесь, что на сервере, где установлен маршрутизатор электронной почты Microsoft Dynamics CRM, включен параметр автоматический вход в систему. Для этого выполните следующие шаги:
Войдите на компьютер, на котором установлен маршрутизатор электронной почты CRM, используя учетную запись, указанную в входящего профиля.
Откройте Internet Explorer.
Выберите "Сервис" и выберите "Параметры браузера".
Перейдите на вкладку "Безопасность", выберите "Локальная интрасеть" и выберите "Сайты".
Выберите "Дополнительно", добавьте URL-адрес, используемый для доступа к Outlook Web Access, а затем добавьте URL-адрес для Exchange Server.
Выберите Закрыть, а затем — ОК.
Убедитесь, что выбрана локальная интрасетя, выберите "Пользовательский уровень" и выберите "Автоматически войдите только в зону интрасети".
Дважды нажмите кнопку "ОК ", а затем нажмите кнопку "Применить".
Закройте все сеансы Internet Explorer.
Примечание.
Internet Explorer можно запустить в контексте определенной учетной записи пользователя при входе в Windows в качестве другой учетной записи пользователя. Это можно выполнить, нажав клавишу SHIFT, а затем щелкнув правой кнопкой мыши по исполняемому файлу Internet Explorer, что откроет опцию запуска Internet Explorer под другой учетной записью. Если Internet Explorer запущен в контексте входящей учетной записи профиля на компьютере, на котором установлен маршрутизатор электронной почты, его можно использовать для обхода шагов 1 и 2 выше.