Примечание
Для доступа к этой странице требуется авторизация. Вы можете попробовать войти или изменить каталоги.
Для доступа к этой странице требуется авторизация. Вы можете попробовать изменить каталоги.
В этой статье описано решение одной из проблем, которые могут возникнуть при импорте решения в Microsoft Dynamics CRM.
Область применения: Microsoft Dynamics CRM
Исходный номер базы знаний: 4025529
Симптомы
После обновления организации Microsoft Dynamics CRM 2016, содержащей поток бизнес-процессов, представленный решением Microsoft Dynamics 365, пользователи не смогут импортировать это решение обратно в организацию Microsoft Dynamics CRM 2016, если это решение было упакована с помощью параметра "Экспорт как" из обновленной организации.
Это относится как к интернету, так и к локальным клиентам.
Причина
В Microsoft Dynamics 365 потоки бизнес-процессов представлены сущностями. Эти сущности будут созданы для любых потоков бизнес-процессов, которые существуют в организации при обновлении до Microsoft Dynamics 365. Однако если потоки бизнес-процессов были представлены с помощью решения, то при обновлении это решение не будет автоматически добавлять в него созданные сущности потока бизнес-процессов в рамках процесса обновления. В этом случае, если пользователь выбирает Экспортировать как данное решение в версии 8.1 или 8.0, необходимые зависимости будут отсутствовать в решении, что не позволит его импортировать в среду Microsoft Dynamics CRM 2016.
Решение
Прежде чем пытаться экспортировать такое решение, убедитесь, что для любого потока бизнес-процессов, содержащегося в нем, соответствующая сущность потока бизнес-процессов добавляется в решение в Microsoft Dynamics 365. После этого, создание пакета решения для Microsoft Dynamics CRM 2016 с помощью опции "Экспортировать как" в Microsoft Dynamics 365 создаст рабочее решение, которое можно успешно импортировать.