Примечание.
Для доступа к этой странице требуется авторизация. Вы можете попробовать войти или изменить каталоги.
Для доступа к этой странице требуется авторизация. Вы можете попробовать изменить каталоги.
Область применения:SQL Server
среда выполнения интеграции SSIS в Фабрика данных Azure
Помимо поверхностей конструктора на вкладках конструктора служб SSIS пользовательский интерфейс предоставляет доступ к следующим окнам и диалоговым окнам для добавления функций в пакеты и настройки свойств объектов пакета:
Окна и диалоговые окна, которые используются для добавления в пакеты таких функций, как ведение журнала и конфигурации.
Пользовательские редакторы для задания настроек свойств для объектов пакета. Почти у каждого типа контейнера, задачи и компонента потока данных есть свой собственный редактор.
Диалоговое окно Расширенный редактор — универсальный редактор, содержащий множество параметров конфигурации для многих компонентов потока данных.
SQL Server Data Tools (SSDT) также предоставляет окна и диалоговые окна для настройки среды и работы с пакетами.
Диалоговые окна и окна
После открытия пакета или создания нового пакета в конструкторе служб SSIS доступны следующие диалоговые окна и окна.
В этой таблице перечислены диалоговые окна, доступные в меню служб SSIS и области конструктора служб SSIS .
| Диалоговое окно | Назначение | Доступ |
|---|---|---|
| Начало работы | Доступ к образцам кода, учебникам и видеоматериалам. | В области конструктора на вкладке Поток управления или Поток данных щелкните правой кнопкой мыши, а затем выберите пункт Начало работы. Чтобы автоматически отобразить окно "Начало работы " при создании нового проекта служб Integration Services, выберите Always show in new project в нижней части окна. |
| Настройка журналов служб SSIS | Настройте ведение журнала для пакета и его задач путем добавления журналов и задания параметров записи. | В меню SSIS нажмите Ведение журнала. –или– Щелкните правой кнопкой мыши в любом месте области конструктора на вкладке Поток управления, а затем выберите Регистрация. |
| Организатор конфигураций пакета | Добавьте и измените конфигурации пакета. Из этого диалогового окна запускается мастер настройки пакета. | В меню Службы SSIS выберите команду Конфигурации пакетов. –или– Щелкните правой кнопкой мыши в любом месте на поверхности конструктора вкладки Поток управления, а затем выберите Конфигурации пакетов. |
| Цифровая подпись | Подпишите пакет или удалите подпись из пакета. | В меню Службы SSIS щелкните Цифровая подпись. –или– Щелкните правой кнопкой мыши в любом месте на поверхности конструктора на вкладке Поток управления, а затем выберите Цифровое подписание. |
| Установить точки останова | Включите точки останова в задачах и задайте свойства точек останова. | В рабочей области конструирования на вкладке Поток управления щелкните правой кнопкой мыши задачу или контейнер, а затем выберите Изменить точки останова. Чтобы установить точку останова в пакете, щелкните правой кнопкой мыши в любом месте рабочей области конструирования вкладки Поток управления , а затем выберите Изменить точки останова. |
В окне Приступая к работе представлены ссылки на образцы кода, учебники и видеоматериалы. Чтобы добавить ссылки на дополнительное содержимое, измените файл SamplesSites.xml, включенный в текущий выпуск служб SQL Server Integration Services. Рекомендуется не изменять значение элемента <GettingStartedSamples>, указывающее URL-адрес RSS-канала. Этот файл расположен в папке <диск>:\Program Files\Microsoft SQL Server\110\DTS\Binn. В 64-разрядной системе он расположен в папке <диск>:\Program Files(x86)\Microsoft SQL Server\110\DTS\Binn.
Если файл SamplesSites.xml поврежден, замените текст в нем следующим XML-кодом по умолчанию.
<?xml version="1.0" ?>
- <SamplesSites>
<GettingStartedSamples>https://go.microsoft.com/fwlink/?LinkID=203147</GettingStartedSamples>
- <ToolboxSamples>
<Site>https://go.microsoft.com/fwlink/?LinkID=203286&query=SSIS%20{0}</Site>
</ToolboxSamples>
</SamplesSites>
В этой таблице перечислены окна, доступные из меню SSIS и Вид, а также в областях разработки конструктора SSIS.
| Окно | Назначение | Доступ |
|---|---|---|
| Переменные | Добавление и управление пользовательскими переменными. | В меню SSIS щелкните Переменные. –или– Щелкните правой кнопкой мыши в любом месте рабочей области конструирования на вкладках Поток управления и Поток данных , а затем выберите Переменные. –или– В меню Вид укажите Другие окнаи щелкните Переменные. |
| Регистрация событий | Просмотр журнала событий во время выполнения. | В меню SSIS выберите пункт Запись событий. –или– Щелкните правой кнопкой мыши в любом месте рабочей области конструирования на вкладках Поток управления и Поток данных , а затем выберите Регистрация событий. –или– В меню Вид укажите Другие окнаи щелкните Регистрация событий. |
Пользовательские редакторы
Службы Integration Services предоставляют настраиваемое диалоговое окно для большинства контейнеров, задач, источников, преобразований и назначений.
В следующей таблице показано, как получить доступ к пользовательским диалоговым окнам.
| Тип редактора | Доступ |
|---|---|
| Контейнер. Дополнительные сведения см. в статье Контейнеры служб интеграции. | В рабочей области конструирования на вкладке Поток управления дважды щелкните контейнер. |
| Задача. Дополнительные сведения см. в разделе Integration Services Tasks. | В рабочей области конструирования на вкладке Поток управления дважды щелкните задачу. |
| Источник. | На поверхности конструктора на вкладке Поток данных дважды щелкните источник. |
| Преобразование. Дополнительные сведения см. в статье Integration Services Transformations. | На поверхности конструктора на вкладке Поток данных дважды щелкните преобразование. |
| Назначение. | На поверхности конструктора вкладки Поток данных дважды щелкните компонент назначения. |
Расширенный редактор
Диалоговое окно Расширенный редактор — это пользовательский интерфейс для настройки компонентов потока данных. Он отражает свойства компонента с использованием универсального макета. Диалоговое окно «Расширенный редактор» недоступно для преобразований Integration Services с несколькими входами.
Чтобы открыть этот редактор, щелкните Показать расширенный редактор в окне Свойства или щелкните правой кнопкой мыши компонент потока данных, а затем выберите Показать расширенный редактор.
Если вы создаёте собственный источник, преобразование или приёмник, но не хотите разрабатывать собственный пользовательский интерфейс, вместо этого можно использовать Расширенный редактор.
Возможности SQL Server Data Tools
SQL Server Data Tools (SSDT) предоставляет окна, диалоговые окна и параметры меню для работы с пакетами служб Integration Services.
Ниже приводится сводка доступных окон и меню.
В окне Обозреватель решений перечислены проекты, включая проект Служб Integration Services, в котором вы разрабатываете пакеты служб Integration Services и файлы проектов.
Чтобы отсортировать пакеты, содержащиеся в проекте, по имени, щелкните правой кнопкой мыши узел Пакеты служб SSIS и выберите команду Сортировать по имени.
В окне Панель элементов отображаются элементы потока управления и потока данных для создания потоков управления и потоков данных.
В окне Свойства перечисляются свойства объекта.
В меню Формат предоставляются параметры для изменения размера и выравнивания элементов управления в пакете.
Меню Правка содержит команды копирования и вставки для работы с объектами на поверхностях конструктора.
Меню Вид содержит команды для изменения графического представления объектов в конструкторе SSIS
Дополнительные сведения о дополнительных окнах и меню см. в документации по Visual Studio.
Связанные задачи
Сведения о создании пакетов в SQL Server Data Tools (SSDT) см. в статье "Создание пакетов в SQL Server Data Tools"