Примечание.
Для доступа к этой странице требуется авторизация. Вы можете попробовать войти или изменить каталоги.
Для доступа к этой странице требуется авторизация. Вы можете попробовать изменить каталоги.
В этом руководстве вы создадите круговую диаграмму в пагинированном отчете Reporting Services. Вы добавите процентные значения и объедините несколько небольших секторов в один сектор.
Круговые и кольцевые диаграммы отображают данные как долю от целого. У них нет топоров. После добавления числового поля на круговую диаграмму в этой диаграмме вычисляется процентная доля каждого значения в общей сумме.
На этом рисунке показана круговая диаграмма, созданная в этом руководстве.
Если на круговой диаграмме расположено слишком много точек данных, метки точек данных могут располагаться близко друг к другу, и их будет трудно читать. В этом случае рассмотрите возможность объединения нескольких небольших срезов в один более крупный срез. Круговые диаграммы более читаемы, если ваши данные агрегированы в несколько точек данных.
Примечание.
В этом учебнике шаги для мастера объединены в две процедуры. Пошаговые инструкции по переходу к серверу отчетов, добавлению источника данных и добавлению набора данных см. в первом руководстве из этого ряда. Руководство. Создание базового отчета таблицы (построитель отчетов)).
Предполагаемое время для выполнения заданий этого учебника: 10 минут
Требования
Дополнительные сведения о требованиях см. в "Предварительные требования для руководств (Report Builder)".
1. Создание круговой диаграммы из мастера диаграмм
В этом разделе вы создадите внедренный набор данных с помощью мастера диаграмм, выберите общий источник данных и создадите круговую диаграмму.
Запустите построитель отчетов на компьютере, веб-портале Служб Reporting Services или в режиме интеграции с SharePoint.
Откроется диалоговое окно Создать отчет или набор данных .
Если диалоговое окно Новый отчет или набор данных не появилось, в меню Файл выберите команду >Создать.
Убедитесь, что на левой панели выбран Новый отчет .
В правой области выберите мастер диаграмм.
На странице "Выбор набора данных" нажмите кнопку "Создать набор данных" и нажмите кнопку "Далее".
На странице выбора подключения к источнику данных выберите существующий источник данных или перейдите к серверу отчетов и выберите источник данных, а затем нажмите кнопку "Далее". Возможно, вам потребуется ввести имя пользователя и пароль.
Примечание.
При наличии необходимых разрешений выбор источника данных не имеет существенного значения. Вы не будете получать данные из источника данных. Дополнительные сведения см. в статье "Альтернативные способы получения подключения к данным" (построитель отчетов).
На странице "Конструктор запроса" выберите "Изменить как текст".
На панель запроса вставьте следующий запрос:
Примечание.
В этом учебнике запрос уже содержит значения данных, поэтому внешний источник данных не требуется. В связи с этим запрос получается длинным. В рабочей среде запрос не будет содержать данные. Это предназначено только для учебных целей.
SELECT 'Advanced Digital Camera' AS Product, CAST(254995.21 AS money) AS Sales UNION SELECT 'Slim Digital Camera' AS Product, CAST(164499.04 AS money) AS Sales UNION SELECT 'SLR Digital Camera' AS Product, CAST(782176.79 AS money) AS Sales UNION SELECT 'Lens Adapter' AS Product, CAST(36333.08 AS money) AS Sales UNION SELECT 'Macro Zoom Lens' AS Product, CAST(40199.3 AS money) AS Sales UNION SELECT 'USB Cable' AS Product, CAST(53245.5 AS money) AS Sales UNION SELECT 'Independent Filmmaker Camcorder' AS Product, CAST(452288.0 AS money) AS Sales UNION SELECT 'Full Frame Digital Camera' AS Product, CAST(247250.85 AS money) AS Sales(Необязательно) Нажмите кнопку "Запустить" (!), чтобы просмотреть данные, на которых основана ваша диаграмма.
Выберите Далее.
2. Выберите тип диаграммы
Вы можете выбрать различные предопределенные типы диаграмм.
На странице Выбор типа диаграммы выберите Круговая диаграмма, затем выберите Далее. Откроется страница Расположение полей диаграммы .
На странице Расположение полей диаграммы перетащите поле Product на панель Категории . Категории определяют номера срезов в круговой диаграмме. В этом примере существует восемь срезов, по одному для каждого продукта.
Перетащите поле Sales на панель Значения . Поле Sales представляет объем продаж по подкатегории. На панели Значения отображается выражение
[Sum(Sales)], так как на диаграмме отображается агрегат для каждого из продуктов.Нажмите Далее, чтобы просмотреть предварительную версию.
Выберите Готово.
Диаграмма добавляется на поверхность макета. Фактические значения круговой диаграммы не отображаются. Вы видите продукт 1, продукт 2 и т. д., чтобы дать представление о том, как должна выглядеть диаграмма.
Выберите диаграмму, чтобы показать элементы управления диаграммой. Перетащите правый нижний угол диаграммы, чтобы увеличить ее. Поверхность конструктора отчета также увеличивается, чтобы вместить размеры диаграммы.
Выберите "Запустить ", чтобы просмотреть отчет.
В отчете отображается круговая диаграмма с восемью срезами, по одному для каждого продукта. Теперь вы видите реальные продукты, и размер каждого сектора отражает продажи этого продукта. Три из срезов тонкие.
3. Отображение процентных значений в каждом срезе
На каждом срезе круговой диаграммы можно отобразить процент для этого среза относительно полной круговой диаграммы.
Переключитесь в режим макета отчета.
Щелкните правой кнопкой мыши круговую диаграмму и выберите пункт Отобразить метки данных. На диаграмме появятся метки данных.
Щелкните правой кнопкой мыши метку, а затем выберите "Свойства метки серии".
В поле Данные метки введите #PERCENT.
(Необязательно) Чтобы указать, сколько десятичных разрядов отображается метка, в поле данных метки после #PERCENT введите {Pn} , где n — число десятичных разрядов для отображения. Например, чтобы не отображать десятичные знаки, введите #PERCENT{P0}.
Чтобы значения отображались в виде процентов, свойство UseValueAsLabel должно иметь значение false. Если вам будет предложено задать это значение в диалоговом окне "Подтверждение действия ", нажмите кнопку "Да".
Примечание.
ПолеФормат чисел в диалоговом окне Свойства метки ряда не имеет значения, если выбрано форматирование в процентах. Это форматирует метки в виде процентов, но не вычисляет процент, который представляет каждый срез круговой диаграммы.
Нажмите ОК.
Выберите "Запустить ", чтобы просмотреть отчет.
В отчете отображается процент от целого для каждого среза круговой диаграммы.
4. Объединение небольших срезов в один срез
Три из срезов в пироге небольшие. Можно объединить несколько небольших секторов в один большой сектор "Прочие", который отражает все три.
Переключитесь в режим макета отчета.
Если в области свойств ничего не отображается, на вкладке Вид в группе >Показать/Скрыть выберите >.
В области конструктора выберите любой срез круговой диаграммы. На панели свойств отображаются свойства серии.
В разделе Общие разверните узел CustomAttributes .
Присвойте свойству CollectedStyle значение SingleSlice.
Убедитесь в том, что свойство CollectedThreshold имеет значение 5.
Убедитесь в том, что свойство CollectedThresholdUsePercent имеет значение True.
На вкладке "Главная" выберите "Запустить ", чтобы просмотреть отчет.
В легенде теперь отображается категория "Прочее". Новый срез круговой диаграммы объединяет все срезы, имеющие размер менее 5%, в один срез, имеющий размер 6% от всей круговой диаграммы.
Начинайте значения круговой диаграммы с верхней точки.
По умолчанию в круговых диаграммах первое значение набора данных отсчитывается с 90-го градуса от верхней части диаграммы. Это можно видеть на круговой диаграмме в предыдущих разделах.
В этом разделе устанавливается первое значение, начиная с верхней части.
Переключитесь в режим макета отчета.
Выберите саму диаграмму.
На панели "Свойства" в области Настраиваемые атрибутыизмените значение PieStartAngle с 0 на 270.
Выберите "Запустить " для предварительного просмотра отчета.
Теперь секторы круговой диаграммы следуют в алфавитном порядке, начиная сверху и заканчивая сектором "Прочее".
6. Добавление заголовка отчета
Так как круговая диаграмма является единственной визуализацией в отчете, ей не требуется собственный заголовок. Заголовок отчета хорошо.
На диаграмме выберите поле "Заголовок диаграммы" и нажмите клавишу DELETE.
В области конструктора выберите Щелкните, чтобы добавить заголовок.
Введите Продажи камер и видеокамер, нажмите клавишу ВВОД, а затем введите В процентах от общего объема продаж, чтобы выглядело следующим образом:
Продажи фотоаппаратов и видеокамер
В процентах от общего объема продаж
Выберите "Продажи камер и видеокамер", а на вкладке Главная в разделе > выберите >.
Выделите текст В процентах от общего объема продаж, а затем на вкладке Главная в разделе > выберите размер шрифта 10.
(Необязательно) Для размещения двух строк текста может потребоваться сделать текстовое поле заголовка более высоким.
Этот заголовок отображается в верхней части отчета. Если заголовок страницы не определен, элементы в верхней части текста отчета эквивалентны заголовку отчета.
Выберите "Запустить ", чтобы просмотреть отчет.
7. Сохранение отчета
Сохранение отчета
Переключитесь в режим макета отчета.
В меню File (Файл) выберите пункт Save (Сохранить).
В поле "Имя" введите Sales Pie Chart.
Выберите Сохранить.
Отчет будет сохранен на сервере отчетов.