Руководство. Добавление ключевого показателя эффективности в отчет (построитель отчетов)

В этом учебнике о построителе отчетов вы добавите ключевой показатель эффективности в отчет с разбивкой на страницы в службах Reporting Services.

Ключевые показатели эффективности представляют собой измеримые значения, имеющие значимость для бизнеса. В данном случае ключевым показателем эффективности является сводка по продажам (по подкатегориям продуктов). Текущее состояние ключевого показателя эффективности отображается с помощью цветов, датчиков и индикаторов.

Рисунок, представленный ниже, аналогичен отчету, который вы создаете в этом руководстве.

Скриншот отчета KPI в программе Report Builder.

Примечание.

В данном учебнике стадии работы мастера объединены в две процедуры: для создания набора данных и для создания таблиц. Пошаговые инструкции по переходу на сервер отчетов, выбор источника данных, создание набора данных и запуск мастера см. в первом руководстве в этой серии: руководство. Создание базового отчета таблицы (построитель отчетов)).

Предполагаемое время для выполнения заданий этого учебника: 15 минут.

Требования

Дополнительные сведения о требованиях см. в "Предварительные требования для руководств (Report Builder)".

1. Создайте отчет таблицы и набор данных с помощью мастера таблиц или матриц

В этом разделе вы выберете общий источник данных, создадите внедренный набор данных и отобразите данные в таблице.

Создание таблицы с внедренным набором данных

  1. Запустите построитель отчетов на компьютере, веб-портале Служб Reporting Services или в режиме интеграции с SharePoint.

    Откроется диалоговое окно Создать отчет или набор данных .

    Если диалоговое окно Новый отчет или набор данных не появилось, в меню Файл выберите команду >Создать.

  2. Убедитесь, что на левой панели выбран Новый отчет .

  3. На панели справа выберите Мастер таблицы или матрицы.

  4. На странице "Выбор набора данных" нажмите кнопку "Создать набор данных".

  5. Выберите Далее.

  6. На странице выбора подключения к источнику данных выберите существующий источник данных. Или перейдите к серверу отчетов и выберите источник данных. Если нет источника данных или у вас нет доступа к серверу отчетов, вместо этого можно использовать внедренный источник данных. Дополнительные сведения см. в руководстве по созданию базового табличного отчета (построитель отчетов).

  7. Выберите Далее.

  8. На странице "Конструктор запроса" выберите "Изменить как текст".

  9. Скопируйте и вставьте на панели запросов следующий запрос:

    Примечание.

    В этом учебнике запрос уже содержит значения данных, поэтому внешний источник данных не требуется. В связи с этим запрос получается весьма длинным. В рабочей среде запрос не будет содержать данные. Это предназначено только для учебных целей.

    SELECT CAST('2015-01-05' AS date) as SalesDate, 'Accessories' as Subcategory,   
       'Carrying Case' as Product, CAST(16996.60 AS money) AS Sales, 68 as Quantity  
    UNION SELECT CAST('2015-01-06' AS date) as SalesDate, 'Accessories' as Subcategory,  
       'Tripod' as Product, CAST(1350.00 AS money) AS Sales, 18 as Quantity  
    UNION SELECT CAST('2015-01-11' AS date) as SalesDate, 'Accessories' as Subcategory,  
       'Lens Adapter' as Product, CAST(1147.50 AS money) AS Sales, 17 as Quantity  
    UNION SELECT CAST('2015-01-05' AS date) as SalesDate, 'Accessories' as Subcategory,  
       'Mini Battery Charger' as Product, CAST(1056.00 AS money) AS Sales, 44 as Quantity  
    UNION SELECT CAST('2015-01-06' AS date) as SalesDate,  'Accessories' as Subcategory,  
       'Telephoto Conversion Lens' as Product, CAST(1380.00 AS money) AS Sales, 18 as Quantity  
    UNION SELECT CAST('2015-01-06' AS date) as SalesDate,'Accessories' as Subcategory,    
       'USB Cable' as Product, CAST(780.00 AS money) AS Sales, 26 as Quantity  
    UNION SELECT CAST('2015-01-08' AS date) as SalesDate, 'Accessories' as Subcategory,   
       'Budget Movie-Maker' as Product, CAST(3798.00 AS money) AS Sales, 9 as Quantity  
    UNION SELECT CAST('2015-01-09' AS date) as SalesDate, 'Camcorders' as Subcategory,   
       'Business Videographer' as Product, CAST(10400.00 AS money) AS Sales, 13 as Quantity  
    UNION SELECT CAST('2015-01-10' AS date) as SalesDate, 'Camcorders' as Subcategory,   
       'Social Videographer' as Product, CAST(3000.00 AS money) AS Sales, 60 as Quantity  
    UNION SELECT CAST('2015-01-11' AS date) as SalesDate,  'Digital' as Subcategory,   
       'Advanced Digital' as Product, CAST(7234.50 AS money) AS Sales, 39 as Quantity  
    UNION SELECT CAST('2015-01-07' AS date) as SalesDate,  'Digital' as Subcategory,   
       'Compact Digital' as Product, CAST(10836.00 AS money) AS Sales, 84 as Quantity  
    UNION SELECT CAST('2015-01-08' AS date) as SalesDate,  'Digital' as Subcategory,   
       'Consumer Digital' as Product, CAST(2550.00 AS money) AS Sales, 17 as Quantity  
    UNION SELECT CAST('2015-01-05' AS date) as SalesDate, 'Digital' as Subcategory,   
       'Slim Digital' as Product, CAST(8357.80 AS money) AS Sales, 44 as Quantity  
    UNION SELECT CAST('2015-01-09' AS date) as SalesDate, 'Digital SLR' as Subcategory,   
       'SLR Camera 35mm' as Product, CAST(18530.00 AS money) AS Sales, 34 as Quantity  
    UNION SELECT CAST('2015-01-07' AS date) as SalesDate, 'Digital SLR' as Subcategory,   
       'SLR Camera' as Product, CAST(26576.00 AS money) AS Sales, 88 as Quantity  
    
  10. На панели инструментов конструктора запросов нажмите кнопку "Выполнить" (!).

  11. Выберите Далее.

2. Организуйте данные и выберите макет в мастере

Мастер таблиц или матриц предоставляет начальный макет для отображения данных. Панель предварительного просмотра в мастере позволяет визуализировать результат группирования данных до завершения конструирования таблицы или матрицы.

Организуйте данные в группы и выберите макет

  1. На странице "Размещение полей" перетащите поле "Продукт" в область Значения.

  2. Перетащите количество в значения и поместите после продукта.

    Сводные значения для поля Quantity вычисляются с помощью функции Sum, которая является функцией по умолчанию для вычисления сводных значений числовых полей.

  3. Перетащите Продажи в значения и разместите после количества.

    Шаги 1, 2 и 3 задают данные, отображаемые в таблице.

  4. Перетащите поле SalesDate в область Группы строк.

  5. Перетащите подкатегорию в группы строк и поместите после SalesDate.

    Шаги 4 и 5 организуют значения полей сначала по дате, а потом по всем продажам для данной даты.

  6. Выберите Далее.

    При выполнении отчета в таблице отображается каждая дата, все заказы для каждой даты и все продукты, количества и итоги по продажам для каждого заказа.

  7. Убедитесь в том, что на странице "Выбор макета" в области Параметрывыбран параметр Показывать подытоги и общие итоги .

  8. Убедитесь в том, что выбрана опция Блокировка, подитог ниже.

  9. Снимите отметку с опции Развернуть/свернуть группы.

    В этом руководстве отчет, который вы создаете, не использует функцию детализации, которая позволяет пользователю расширить родительскую иерархию групп для отображения дочерних строк и строк сведений.

  10. Выберите Далее.

  11. Выберите Готово.

    Таблица добавляется в область конструктора. Таблица содержит пять столбцов и пять строк. Панель "Группы строк" содержит три группы строк: SalesDate, Subcategory и Details. Подробные данные — это все данные, извлекаемые запросом набора данных. Область "Группы столбцов" пуста.

    Снимок экрана: три группы строк в области

  12. Выберите "Запустить ", чтобы просмотреть отчет.

Для каждого продукта, проданного за указанную дату, в таблице отображается название этого продукта, проданное количество и сумма продаж. Данные упорядочиваются сначала по дате продажи, а потом по подкатегории.

Снимок экрана, показывающий базовую таблицу KPI для Построителя отчетов.

Форматирование дат и денежных единиц

Давайте расширим столбцы и зададим формат для дат и денежных единиц.

  1. Выберите конструктор, чтобы вернуться в режим конструктора.

  2. Названия продуктов могут занимать больше места. Чтобы расширить столбец "Продукт", выделите всю таблицу и перетащите правый край маркера столбца в верхней части столбца "Продукт".

  3. Нажмите клавишу CTRL, а затем выберите четыре ячейки, содержащие [Sum(Продажи)].

  4. На вкладке Главная выберите >Число>Валюта. Ячейки меняются, чтобы показать отформатированную валюту.

    Если в качестве региональных настроек компьютера выбран "Английский (США)", текстом по умолчанию образца будет [$12,345.00]. Если вы не видите пример значения валюты в группе Числа, выберите Стили заполнитель>Примерные значения.

    Снимок экрана: параметр

  5. (Необязательно) На вкладке "Главная" в группе "Число " дважды нажмите кнопку "Уменьшить десятичные разряды ", чтобы отобразить цифры доллара без центов.

  6. Выберите ячейку, содержащую [SalesDate].

  7. В группе "Число" выберите "Дата".

    В ячейке отображается пример даты [31.01.2000].

  8. Выберите "Запустить ", чтобы просмотреть отчет.

Снимок экрана отчета KPI в Report Builder с форматированными числами.

3. Использование цветов фона для отображения ключевого показателя эффективности

Цвета фона можно задавать в виде выражений, вычисляемых при запуске отчета.

Отображение текущего состояния ключевого показателя эффективности с помощью цветов фона

  1. В таблице щелкните правой кнопкой мыши вторую [Sum(Sales)] ячейку (строка промежуточных итогов, отображающая продажи для подкатегории), а затем выберите свойства текстового поля.

    Убедитесь, что выбрана ячейка, а не текст в ячейке, чтобы просмотреть свойства текстового поля.

    Снимок экрана — параметр

  2. На вкладке Заливка нажмите кнопку fx рядом с цветом заливки и введите следующее выражение в поле установите выражение для: BackgroundColor:

    =IIF(Sum(Fields!Sales.Value) >= 5000 ,"Lime", IIF(Sum(Fields!Sales.Value) < 2500, "Red","Yellow"))

    Это выражение изменяет цвет фона на "Лайм" зеленый для каждой ячейки с агрегированной суммой для [Sum(Sales)] больше или равно 5000. Значения [Sum(Sales)] в диапазоне от 2500 до 5000 окрашены желтым цветом. Значения менее 2500 окрашены красным цветом.

  3. Нажмите ОК.

  4. Выберите "Запустить ", чтобы просмотреть отчет.

В строке промежуточных итогов, где отображаются продажи для подкатегории, цвет ячейки может быть красным, желтым или зеленым в зависимости от значения суммы продаж.

Снимок экрана отчета KPI Report Builder с цветами в определенных ячейках.

4. Отображение ключевого показателя эффективности с помощью датчика

Датчик показывает одно значение из набора данных. В этом руководстве используется горизонтальная линейная шкала, так как её форма и простота облегчают восприятие, даже если она небольшая и размещена внутри ячейки таблицы. Дополнительные сведения см. в разделе Индикаторы на разбивочном отчете (Report Builder).

Отображение текущего состояния ключевого показателя эффективности с помощью датчика

  1. Вернитесь в режим конструктора.

  2. В таблице щелкните правой кнопкой мыши маркер столбца "Продажи" и выберите пункт >Вставить столбец>Справа. В таблицу добавится новый столбец.

    Снимок экрана, на котором показано, как вставить столбец в отчет KPI в Report Builder.

  3. Введите линейный ключевой показатель эффективности в заголовке столбца.

  4. На вкладке Вставка>Визуализация данных>Индикатор, выберите область дизайна за пределами таблицы.

  5. В диалоговом окне Выбор типа датчика выберите первый тип линейного датчика ( Горизонтальный).

  6. Нажмите ОК.

    На конструкторскую поверхность добавлен индикатор.

  7. Из набора данных в области "Данные отчета" перетащите поле Sales в датчик. Откроется панель Данные измерителя.

    Когда поле Sales перетаскивается на датчик, оно перемещается в список Значения и агрегируется с использованием встроенной функции суммы.

    Снимок экрана, на котором показано, как перетащить поле

  8. В области данных манометра выберите стрелку рядом с LinearPointer1>.

  9. В диалоговом окне Свойства указателя-линии на вкладке >Параметры указателя в поле >Тип указателя убедитесь, что выбрано Бар.

  10. Нажмите ОК.

  11. Щелкните правой кнопкой мыши масштаб в датчике и выберите "Свойства масштабирования".

  12. В диалоговом окне Свойства линейной шкалы на вкладке >Общие выберите для параметра Максимум значение 25000.

    Примечание.

    Вместо константы (например, 25 000) можно использовать выражение для динамического вычисления значения параметра Максимум . Оно является агрегатным выражением агрегатной функции и выглядит аналогично выражению =Max(Sum(Fields!Sales.value), "Tablix1").

  13. На вкладке Метки установите флажок Скрыть метки шкалы.

  14. Нажмите ОК.

  15. Перетащите датчик в таблицу во вторую пустую ячейку столбца "Линейный ключевой показатель эффективности" в строке, в которой приводится подытог продаж для поля Subcategory (рядом с полем, в которое была добавлена формула фонового цвета).

    Примечание.

    Возможно, придется изменить размер столбца, чтобы горизонтальный линейный датчик соответствовал размеру ячейки. Чтобы изменить размер столбцов, выделите таблицу и перетащите маркеры столбцов. Область конструирования отчета изменяется, чтобы соответствовать размеру таблицы.

  16. Выберите "Запустить ", чтобы просмотреть отчет.

    Горизонтальная длина зеленой полосы индикатора изменяется в зависимости от значения КПЭ.

Снимок экрана, показывающий столбец линейного КПЭ, добавленный в отчет Построителя отчетов КПЭ.

5. Отображение ключевого показателя эффективности с помощью индикатора

Индикаторы — это небольшие простые датчики, позволяющие с первого взгляда получить представление о значениях данных. Из-за своего размера и простоты индикаторы часто используются в таблицах и матрицах. Дополнительные сведения см. в разделе "Индикаторы" в отчете с разбивкой на страницы (построитель отчетов).

Отображение текущего состояния ключевого показателя эффективности с помощью индикатора

  1. Переключитесь в режим конструктора.

  2. В таблице щелкните правой кнопкой мыши по заголовку столбца "Линейный ключевой показатель эффективности", который вы добавили в последней процедуре, и выберите >Вставить столбец>справа. В таблицу добавится новый столбец.

  3. Введите Stoplight KPI в заголовке столбца.

  4. Выберите ячейку для подкатегории рядом с линейным индикатором, добавленным в последнюю процедуру.

  5. На вкладке "Вставка" перейдите к визуализациям данных, дважды щелкнув индикатор>

  6. В диалоговом окне Выбор стиля индикатора в разделе Фигурывыберите первый тип фигуры 3 сигнала трафика (без обрамления).

  7. Нажмите ОК.

    Индикатор добавится в ячейку в новом столбце "Ключевой показатель эффективности: стоп-сигналы".

  8. Щелкните индикатор правой кнопкой мыши и выберите "Свойства индикатора".

  9. На вкладке Значения и состояния в поле Значение выберите [Sum(Продажи)]. Не изменяйте другие параметры.

    По умолчанию синхронизация данных происходит в пределах области данных, а значение Tablix1, имя табличной области данных из отчета, отображается в поле Область синхронизации .

    В этом отчете можно также изменить масштаб индикатора, помещенного в ячейку подытога подкатегории, для синхронизации с полем SalesDate.

  10. Нажмите ОК.

  11. Выберите "Запустить ", чтобы просмотреть отчет.

Снимок экрана, на котором показан столбец KPI

6. Добавьте заголовок к отчету

Заголовок отчета отображается в верхней части отчета. Название отчета можно поместить в заголовок отчета или, если заголовок не используется, в текстовое поле в верхней части тела отчета. В этом разделе вы используете текстовое поле, которое автоматически размещается в верхней части текста отчета.

Текст можно улучшить, применяя к отдельным символам различные стили, размеры и цвета шрифта. Дополнительные сведения см. в разделе "Формат текста" в текстовом поле в отчетах с разбивкой на страницы (построитель отчетов).

Добавление заголовка отчета

  1. В области конструктора выберите Нажмите, чтобы добавить заголовок.

  2. Введите ключевые показатели эффективности продаж продуктов и выберите вне текстового поля.

  3. При необходимости щелкните правой кнопкой мыши текстовое поле, содержащее ключевой показатель эффективности продаж продуктов, выберите свойства текстового поля, а затем на вкладке "Шрифт" выберите различные стили шрифтов, размеры и цвета.

  4. Выберите "Запустить ", чтобы просмотреть отчет.

7. Сохранение отчета

Сохраните отчет на сервере отчетов или на своем компьютере. Если отчет не сохраняется на сервере отчетов, многие функции служб Reporting Services, такие как вложенные отчеты, недоступны.

Сохранение отчета на сервере отчетов

  1. В построителе отчетов выберите пункт "Сохранить как".

  2. Выберите последние сайты и серверы.

  3. Выберите или введите имя сервера отчетов, в котором у вас есть разрешение на сохранение отчетов.

    Появится сообщение «Соединение с сервером отчетов». После того как соединение установлено, пользователю представляется содержимое папки, заданной администратором сервера отчетов как место по умолчанию для отчетов.

  4. В поле Имязамените имя по умолчанию фразой Ключевой показатель эффективности продаж товаров.

  5. Выберите Сохранить.

Отчет будет сохранен на сервере отчетов. Имя сервера отчетов, к которому вы подключены, отображается в строке состояния в нижней части окна.

Сохранение отчета на компьютере

  1. В построителе отчетов выберите пункт "Сохранить как".

  2. Выберите "Рабочий стол", "Мои документы" или "Мой компьютер" и перейдите к папке, в которой вы хотите сохранить отчет.

Примечание.

Если у вас нет доступа к серверу отчетов, выберите "Рабочий стол", "Мои документы" или "Мой компьютер " и сохраните отчет на компьютере.

  1. В поле Имязамените имя по умолчанию фразой Ключевой показатель эффективности продаж товаров.

  2. Выберите Сохранить.