Поделиться через


Устранение неполадок, связанных с кодом ошибки SubnetIsFull, во время обновления кластера AKS

В этой статье описывается, как определить и устранить ошибку SubnetIsFull, возникающую при попытке обновить кластер Службы Azure Kubernetes (AKS).

Ниже приведен пример сообщения об ошибке:

Не удалось масштабировать пул узлов <AGENT POOL NAME> в службе Kubernetes «<NAME>». Ошибка: повторная попытка VMSSAgentPoolReconciler не удалась: Code='SubnetIsFull' Message='<SUBNET NAME>\ с адресным префиксом <PREFIX>\ не имеет достаточной емкости для IP-адресов.' Подробности=[]

Предпосылки

Для этой статьи требуется Azure CLI версии 2.0.65 или более поздней версии. Чтобы найти номер версии, выполните команду az --version. Если вам нужно установить или обновить Azure CLI, см. инструкции по установке Azure CLI.

Дополнительные сведения о процессе обновления см. в разделе "Обновление кластера AKS" в документе "Обновление кластера Службы Azure Kubernetes (AKS)".

Симптомы

Обновление кластера AKS завершается сбоем, и вы получите сообщение об ошибке SubnetIsFull.

Причина

Эта ошибка возникает, если в кластере недостаточно IP-адресов для создания нового узла.

При планировании операции обновления или масштабирования рассмотрите количество необходимых IP-адресов. Если диапазон IP-адресов, настроенный в кластере, поддерживает только фиксированное количество узлов, операция обновления или масштабирования завершится ошибкой. Дополнительные сведения см. в статье о планировании IP-адресов для кластеров Службы Azure Kubernetes (AKS).

Решение

Уменьшите узлы кластера, чтобы зарезервировать IP-адреса для обновления.

Если масштабирование не является вариантом, и CIDR виртуальной сети имеет достаточно IP-адресов, попробуйте добавить пул узлов с уникальной подсетью:

  1. Добавьте новый пул узлов пользователя в виртуальную сеть в более крупной подсети.
  2. Переключите исходный пул узлов на тип пула системных узлов.
  3. Увеличьте масштаб пула узлов пользователя.
  4. Уменьшение масштаба исходного пула узлов.

Дополнительные сведения

Свяжитесь с нами для получения помощи

Если у вас есть вопросы, вы можете обратиться в службу поддержки сообщества Azure. Вы также можете отправить отзыв о продукте в сообщество отзывов Azure.