Поделиться через


Код ошибки 0x80090016 . Набор ключей не существует в средстве просмотра событий или журналах агента

В этой статье объясняется, как устранить ошибку 0x80090016 "Набор ключей не существует" при попытке подключиться к средству просмотра событий или журналам агента.

Симптомы

При попытке подключиться к рабочей области Log Analytics через Microsoft Monitoring Agent (MMA) подключение завершается сбоем, и в журнале просмотра событий Operations Manager регистрируется одна из следующих записей об ошибке:

Event ID:      7022 
Description:   The Health Service has downloaded secure configuration for management
               group AOI-00000000-0000-0000-0000-000000000000, and processing the 
               configuration failed with error code Keyset does not exist(0x80090016). 
Event ID:      3009  
Description:   Loading the private key for the client authentication certificate for
               service "Log Analytics - ed4Customer-WorkspaceID" failed with error 
               "Keyset does not exist" (0x80090016). Connections to the service may
               be made without authentication. This can cause failures if the service
               requires the agent to be authenticated. The agent will continue to 
               periodically retry loading the authentication configuration.

Причина

Сервер был клонирован из золотого образа (также известного как образ master), на котором уже установлен и настроен агент Windows Log Analytics. Сбой подключения, так как сертификаты содержат имя исходного сервера, который был клонирован, а не имя, которое в настоящее время используется Windows. (Примечание. Клонирование компьютера с уже настроенным агентом Log Analytics не поддерживается.)

Решение

Чтобы устранить эти ошибки, очистите и обновите сертификаты MMA следующим образом:

  1. Чтобы открыть оснастку Службы, нажмите кнопку Пуск, введите services.msc и нажмите клавишу ВВОД.

  2. Чтобы остановить службу, выберите Microsoft Monitoring Agent и щелкните значок Остановить службу .

  3. Чтобы открыть консоль управления (MMC), нажмите кнопку Пуск, введитеmmc.exeи нажмите клавишу ВВОД.

  4. Чтобы добавить оснастку "Сертификаты", выберите Добавление файла>и удаление оснасток>Сертификаты>Добавить>учетную запись> компьютераСледующий>локальный компьютер>Готово>ОК.

  5. Чтобы просмотреть существующие сертификаты MMA в MMC, перейдите в раздел Сертификаты>Microsoft Monitoring AgentCertificates (Сертификаты агента > мониторинга Майкрософт).

  6. Рекомендуется экспортировать каждый сертификат, чтобы иметь резервную копию для обеспечения безопасности и аудита. Для этого выполните следующие действия:

    1. Выберите и щелкните правой кнопкой мыши каждый указанный сертификат по отдельности, а затем выберите Все задачи>Экспортировать>следующий>нет, не экспортировать закрытый ключ.

    2. На странице Формат файла экспорта выберите X.509 в кодировке Base-64 (. CER)>Далее.

    3. На странице Экспортируемый файл в поле имя файла введите имя файла сертификата, а затем перейдите к расположению, куда нужно экспортировать сертификат. Затем выберите Сохранить>следующее>готово.

  7. После экспорта резервных копий сертификатов, перечисленных в средней области, как описано на шаге 6, удалите сертификаты из MMC. Не закрывайте консоль.

  8. В оснастке Службы выберите Microsoft Monitoring Agent и щелкните значок Запустить службу , чтобы перезапустить его.

  9. Подождите одну минуту. Затем в MMC выберите оснастку Сертификаты и щелкните значок Обновить или F5 для обновления. Вы должны увидеть новые сертификаты.

Просмотрите агент, журналы событий и рабочую область Log Analytics, чтобы определить, удалось ли устранить проблему с помощью этих действий.

Дополнительная информация

Настройка microsoft Monitoring Agent

Общие сведения об агенте Log Analytics: параметры установки

Свяжитесь с нами для получения помощи

Если у вас есть вопросы или вам нужна помощь, создайте запрос в службу поддержки или обратитесь за поддержкой сообщества Azure. Вы также можете отправить отзыв о продукте в сообщество отзывов Azure.