Надстройка интеграции с Office Team Foundation Server не запускается

Эта статья поможет устранить ошибку, которая возникает, когда надстройка Office Team Foundation Server 2015 не работает.

Исходная версия продукта: Team Foundation Server
Исходный номер базы знаний: 3192409

Симптомы

Вы обнаружите, что надстройка Office Team Foundation Server 2015 не работает, так как она не подписана доверенным издателем. Эта проблема возникает при выполнении следующих условий:

  • Вы используете 32-разрядную версию Office на 64-разрядном компьютере.

  • У вас есть версия Team Foundation Server, более ранняя, чем Team Foundation Server 2015 с обновлением 3.

  • В параметрах Office флажок Обязательные надстройки приложений, подписанные доверенным издателем проверка, установлен в разделе Файл ->Параметры - Центр управления безопасностью> - Параметры .>

Причина

Эта проблема возникает, если в поле Расположение надстройки есть кавычки. Это не позволит Office проверить издателя. Чтобы убедиться, что это является причиной вашей проблемы, перейдите в раздел Файл ->Параметры ->Надстройки, выберите надстройку Team Foundation, а затем просмотрите поле Расположение, чтобы увидеть, находится ли путь к расположению в кавычках.

Снимок экрана: пример проверка поле

Разрешение

Исправление этой проблемы включено в Team Foundation Server 2015 с обновлением 3 и более поздних версий Team Foundation Server. Рассмотрите возможность обновления до обновления 3, чтобы устранить эту проблему.

Если у вас есть более ранняя сборка, вы можете удалить кавычки из соответствующего раздела реестра. Перед изменением раздела реестра обязательно создайте резервную копию.

Для этого можно использовать файл скрипта .reg или вручную изменить строку в реестре Редактор. Чтобы вручную изменить строку, выполните следующие действия.

  1. Нажмите кнопку Пуск, нажмите кнопку Выполнить, а затем введите regedit.

  2. Перейдите к следующему подразделу Team Foundation Server 2015:

    [HKEY_CLASSES_ROOT\WOW6432Node\CLSID\{04986E13-556D-463F-ADBD-9D8CAD03707B}\InprocServer32]

  3. Щелкните правой кнопкой мыши запись (по умолчанию), выберите команду Изменить, а затем удалите кавычки в начале и конце значения в столбце Данные .

Дополнительная информация

Если после удаления кавычек по-прежнему возникают ошибки, убедитесь, что корпорация Майкрософт указана в качестве доверенного издателя на вашем компьютере. Если это не так, необходимо установить сертификат Майкрософт.

Свяжитесь с нами для получения помощи

Если у вас есть вопросы или вам нужна помощь, создайте запрос в службу поддержки или обратитесь за поддержкой сообщества Azure. Вы также можете отправить отзыв о продукте в сообщество отзывов Azure.