Поделиться через


Windows отображает ошибку синего экрана при загрузке виртуальной машины Azure

В этой статье описаны ошибки синего экрана, которые могут возникнуть при загрузке виртуальной машины Windows в Microsoft Azure. В ней приведены инструкции по сбору данных для запроса в службу поддержки.

Симптомы

Виртуальная машина Windows не запускается. При проверка снимки экрана загрузки в диагностика загрузки на синем экране отображается одно из следующих сообщений об ошибке:

Компьютер столкнулся с проблемой и должен перезагрузиться. Мы просто собираем некоторые сведения об ошибке, а затем вы можете перезапустить.

Компьютер столкнулся с проблемой и должен перезагрузиться.

Причина

Существует множество причин, по которым возникает стоп-ошибка. Наиболее распространенными причинами являются следующие проблемы:

  • Проблема в драйвере
  • Поврежденный системный файл или память
  • Приложение, обращающееся к запрещенном сектору памяти

Решение

Совет

Если у вас есть недавняя резервная копия виртуальной машины, попробуйте восстановить ее из резервной копии , чтобы устранить проблему с загрузкой.

Чтобы устранить эту проблему, сначала необходимо собрать файл дампа для сбоя, прежде чем обращаться в службу поддержки. Чтобы собрать файл дампа, выполните следующие действия.

Шаг 1. Найдите файл дампа и отправьте запрос в службу поддержки

Часть 1. Подключение диска ОС к виртуальной машине восстановления
  1. Выполните snapshot диска ОС затронутой виртуальной машины, чтобы создать резервную копию. Дополнительные сведения см. в статье Создание snapshot виртуального жесткого диска.

  2. Подключите диск ОС к виртуальной машине восстановления.

  3. Используйте протокол удаленного рабочего стола (RDP) для удаленного подключения к виртуальной машине восстановления.

  4. Если диск ОС затронутой виртуальной машины зашифрован, отключите шифрование, прежде чем переходить к следующему шагу. Дополнительные сведения см. в разделе Расшифровка зашифрованного диска ОС.

Часть 2. Найдите файл дампа и отправьте запрос в службу поддержки
  1. На виртуальной машине восстановления перейдите в папку Windows на подключенном диске ОС. Например, если буква диска, назначенная подключенному диску ОС, — F, перейдите в раздел F:\Windows.

  2. Найдите файл Memory.dmp , а затем отправьте запрос в службу поддержки и вложите файл дампа.

Если файл дампа не удается найти, перейдите к следующим шагам, чтобы включить журнал дампа и последовательную консоль, а затем воспроизведите проблему.

Шаг 2. Включение журнала дампа и последовательной консоли

Важно!

В этот раздел, описание метода или задачи включены действия, содержащие указания по изменению параметров реестра. Однако неправильное изменение параметров реестра может привести к возникновению серьезных проблем. Поэтому следует в точности выполнять приведенные инструкции. Для защиты создайте резервную копию реестра перед его изменением, чтобы в случае возникновения проблем можно было восстановить его. Для получения дополнительной информации о том, как создать резервную копию и восстановить реестр, см. статью Сведения о резервном копировании и восстановлении реестра Windows.

Чтобы включить журнал дампа и последовательную консоль, выполните следующие действия.

  1. Откройте сеанс командной строки с повышенными привилегиями от имени администратора.

  2. Выполните следующие команды BCDEdit с помощью параметров /ems и /emssettings :

    Включите последовательную консоль:

    bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON
    bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
    
  3. Убедитесь, что свободное место на диске ОС больше, чем размер памяти (ОЗУ) на виртуальной машине.

    Если на диске ОС недостаточно места, измените расположение, в котором создается файл дампа памяти, и укажите это расположение на любом диске данных, подключенном к виртуальной машине с достаточным объемом свободного места. Чтобы изменить расположение, замените %SystemRoot% буквой диска данных, например F:, в следующих командах.

    Чтобы включить файл дампа ОС, выполните следующие команды load, add и unloads для реализации предлагаемой конфигурации с помощью средства reg :

    Загрузите куст реестра с поврежденного диска ОС:

    reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
    

    Включить в ControlSet001:

    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

    Включите в ControlSet002:

    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

    Выгрузите неисправный диск ОС:

    reg unload HKLM\<broken-system>
    

Шаг 3. Воспроизведение проблемы

  1. Отключите диск ОС, а затем повторно подключите диск ОС к затронутой виртуальной машине.

  2. Запустите виртуальную машину, чтобы воспроизвести проблему, чтобы создать файл дампа.

  3. Повторите инструкции в разделе Шаг 1. Поиск файла дампа и отправка запроса в службу поддержки .

Свяжитесь с нами для получения помощи

Если у вас есть вопросы или вам нужна помощь, создайте запрос в службу поддержки или обратитесь за поддержкой сообщества Azure. Вы также можете отправить отзыв о продукте в сообщество отзывов Azure.