Поделиться через


Цикл перезагрузки Windows на виртуальной машине Azure

В этой статье описывается цикл перезагрузки, который может возникнуть на виртуальной машине Windows в Microsoft Azure.

Признак

При использовании диагностика загрузки для получения снимков экрана виртуальной машины вы обнаружите, что виртуальная машина загружается, но процесс загрузки прерывается и процесс начинается заново.

Снимок экрана: виртуальная машина загружается.

Причина

Цикл перезагрузки происходит по следующим причинам:

Причина 1

Существует сторонняя служба, которая помечена как критическая и ее невозможно запустить. Это приводит к перезагрузке операционной системы. Чтобы устранить эту проблему, см. раздел Решение для причины 1.

Причина 2

В операционную систему были внесены некоторые изменения. Как правило, они связаны с установкой обновлений, установкой приложения или новой политикой. Для получения дополнительных сведений может потребоваться проверка следующие журналы:

  • Журналы событий
  • CBS.logWindows
  • Update.log

Чтобы устранить эту проблему, см. раздел Решение для причины 2.

Причина 3

Повреждение куста реестра может вызвать эту проблему. Чтобы устранить эту проблему, см. раздел Решение для причины 3.

Решение

Совет

Если у вас есть недавняя резервная копия виртуальной машины, попробуйте восстановить ее из резервной копии , чтобы устранить проблему с загрузкой.

Чтобы устранить эту проблему, создайте резервную копию диска ОС и подключите диск ОС к виртуальной машине спасения, а затем следуйте соответствующим параметрам решения или попробуйте решения по одному.

Решение для причины 1

  1. После подключения диска ОС к рабочей виртуальной машине убедитесь, что в консоли управления дисками диск помечен как "в сети" , и запишите букву диска раздела, в котором хранится папка \Windows .

  2. Если диск установлен в автономном режиме, установите для него значение В сети.

  3. Создайте копию папки \Windows\System32\config на случай, если потребуется откат изменений.

  4. На виртуальной машине спасения откройте Редактор реестра Windows (regedit).

  5. Выберите ключ HKEY_LOCAL_MACHINE , а затем в меню выберите Файл>Загрузить Hive .

  6. Перейдите к файлу SYSTEM в папке \Windows\System32\config .

  7. Выберите Открыть, введите BROKENSYSTEM в поле имя, разверните ключ HKEY_LOCAL_MACHINE , после чего вы увидите дополнительный ключ BROKENSYSTEM.

  8. Проверьте, с какого параметра ControlSet загружается компьютер. Его номер ключа отображается в следующем разделе реестра.

    HKEY_LOCAL_MACHINE\BROKENSYSTEM\Select\Current

  9. Проверьте важность службы агента виртуальной машины с помощью следующего раздела реестра.

    HKEY_LOCAL_MACHINE\BROKENSYSTEM\ControlSet00x\Services\RDAgent\ErrorControl

  10. Если значение раздела реестра не равно 2, перейдите к следующему устранению рисков.

  11. Если для раздела реестра задано значение 2, измените значение с 2 на 1.

  12. Если какой-либо из следующих ключей существует и имеет значение 2 или 3, измените эти значения на 1 соответствующим образом:

    • HKEY_LOCAL_MACHINE\BROKENSYSTEM\ControlSet00x\Services\AzureWLBackupCoordinatorSvc\ErrorControl
    • HKEY_LOCAL_MACHINE\BROKENSYSTEM\ControlSet00x\Services\AzureWLBackupInquirySvc\ErrorControl
    • HKEY_LOCAL_MACHINE\BROKENSYSTEM\ControlSet00x\Services\AzureWLBackupPluginSvc\ErrorControl
  13. Выберите клавишу BROKENSYSTEM , а затем в меню выберите Пункт Выгрузить файл>Hive .

  14. Отсоедините диск ОС от виртуальной машины для устранения неполадок.

  15. Удалите диск из виртуальной машины для устранения неполадок и подождите около 2 минут, пока Azure не освободит этот диск.

  16. Создайте виртуальную машину на диске ОС.

  17. Если проблема устранена, может потребоваться переустановить RDAgent (WaAppAgent.exe).

Решение для причины 2

Восстановите виртуальную машину до последней известной хорошей конфигурации. Выполните действия, описанные в разделе Как запустить виртуальную машину Azure Windows с последней известной хорошей конфигурацией.

Решение для причины 3

Примечание.

Следующая процедура должна использоваться только в качестве последнего ресурса. Хотя восстановление из regback может восстановить доступ к компьютеру, ОПЕРАЦИОННая система не считается стабильной, так как между меткой времени куста и текущим днем в реестре потеряны данные. Необходимо создать новую виртуальную машину и составить планы по переносу данных.

  1. После подключения диска к виртуальной машине для устранения неполадок убедитесь, что в консоли управления дисками он помечается как подключенный .

  2. Создайте копию папки \Windows\System32\config на случай, если потребуется откат изменений.

  3. Скопируйте файлы в папку \Windows\System32\config\regback и замените файлы в папке \Windows\System32\config .

  4. Удалите диск из виртуальной машины для устранения неполадок и подождите около 2 минут, пока Azure не освободит этот диск.

  5. Создайте виртуальную машину на диске ОС.

Свяжитесь с нами для получения помощи

Если у вас есть вопросы или вам нужна помощь, создайте запрос в службу поддержки или обратитесь за поддержкой сообщества Azure. Вы также можете отправить отзыв о продукте в сообщество отзывов Azure.