Поделиться через


Ничего не происходит при щелчке ссылки в Internet Explorer

Предупреждение

Устаревшее и не поддерживаемое классическое приложение Internet Explorer 11 было окончательно отключено путем обновления Microsoft Edge в некоторых версиях Windows 10. Дополнительные сведения см. в разделе Часто задаваемые вопросы о прекращении поддержки программы для настольных компьютеров Internet Explorer 11.

Эта статья поможет устранить проблему, которую не удается открыть веб-страницу при щелчке гиперссылки в Internet Explorer.

Исходная версия продукта: Internet Explorer 9
Исходный номер базы знаний: 175775

Симптомы

Щелкнув гиперссылку на веб-странице или в сообщении электронной почты, ничего не происходит. Internet Explorer не открывает веб-страницу.

Примечание.

Эта информация относится к Internet Explorer 9, Internet Explorer 8 и Internet Explorer 7.

Причина

Это может произойти по одной или нескольким причинам:

  • Параметр, в котором выбирается веб-браузер, который вы хотите использовать, поврежден. Это может привести к неправильному толкованию Windows, который браузер задается как браузер по умолчанию на компьютере.
  • После установки программного обеспечения параметры были изменены, что может привести к неправильной работе ссылок на веб-страницы.
  • Ранее установленный браузер или надстройка могут влиять на другое программное обеспечение на компьютере.
  • Разделы реестра были изменены или повреждены.

Разрешение

Этот раздел предназначен для начала промежуточного пользователя компьютера. Если эти методы не устраняют проблему, можно попробовать методы в разделе "Дополнительное устранение неполадок ". Чтобы устранить проблему, используйте следующие методы в том порядке, в котором они представлены.

Метод 1. Проверка параметров веб-браузера по умолчанию

В Microsoft Windows можно выбрать веб-браузер, который вы хотите использовать. Чтобы сделать Internet Explorer браузером по умолчанию, выполните следующие действия.

  1. Чтобы открыть браузер Internet Explorer, щелкните Пуск, затем выберите Internet Explorer.
  2. Если вам будет предложено подтвердить, что Internet Explorer будет браузером по умолчанию, нажмите кнопку "Да".
  3. В меню "Сервис" выберите пункт "Параметры браузера".
  4. Нажмите кнопку "Программы>сделать по умолчанию>ОК", а затем закройте Internet Explorer.

Примечание.

Изменения вступают в силу при следующем запуске Internet Explorer.

Проверьте, устранена ли проблема. Если проблема устранена, вы закончите работу с этой статьей. Если проблема не устранена, попробуйте следующий метод.

Метод 2. Изменение типов файлов, открываемых Internet Explorer по умолчанию

Для Windows 7 и Windows Vista.

  1. Закройте все окна Internet Explorer.
  2. Нажмите кнопку "Пуск", а затем щелкните панель управления.
  3. Щелкните " Программы" и нажмите кнопку "Задать программы по умолчанию".
  4. В меню "Программы" щелкните Internet Explorer и выберите параметры по умолчанию для этой программы.
  5. Убедитесь, что флажки для .htm, и выбраны, а urls затем нажмите кнопку "Сохранить.html".
  6. Щелкните OK.

Примечание.

Изменения вступают в силу при следующем запуске Internet Explorer.

Для Windows XP

  1. Чтобы открыть проводник Windows, щелкните правой кнопкой мыши " Пуск" и выберите пункт "Мой компьютер".

  2. В меню "Сервис" выберите пункт "Параметры папки" и перейдите на вкладку "Типы файлов".

  3. Найдите и выберите тип файла HTM.

  4. Убедитесь, что Internet Explorer выбран в качестве открываемой программы. Если Internet Explorer не выбран, нажмите кнопку "Изменить", выберите Internet Explorer в качестве рекомендуемой программы и нажмите кнопку "ОК".

  5. Повторите шаги 3 и 4 для следующих типов файлов:

    • HTML
    • ITS
    • MHT
    • MTHML
    • XML
    • XSL

Проверьте, устранена ли проблема. Если проблема устранена, вы закончите работу с этой статьей. Если проблема не устранена, перейдите к следующему методу.

Метод 3. Использование режима "Нет надстроек Internet Explorer"

Хотя надстройки браузера могут улучшить работу в Интернете, они могут иногда вмешиваться или конфликтовать с другим программным обеспечением на компьютере. Однако помните, что некоторые веб-страницы или internet Explorer могут отображаться неправильно, если надстройка отключена. Сначала запустите Internet Explorer с временно отключенными надстройками, чтобы узнать, устранена ли проблема. (Надстройки будут отключены только до тех пор, пока не перезапустите Internet Explorer обычным образом. Для этого выполните следующие шаги.

  • Нажмите кнопку "Пуск", введите Internet Explorer в поле поиска и выберите Internet Explorer (без надстроек).

    Примечание.

    Для Windows XP нажмите кнопку "Пуск", щелкните правой кнопкой мыши значок Internet Explorer и нажмите кнопку "Обзор без надстроек".

Если в Internet Explorer нет режима надстроек устранена проблема, выполните следующие действия, чтобы определить надстройку браузера, которая вызывает проблему:

  1. Чтобы запустить Internet Explorer, нажмите кнопку "Пуск" и щелкните Internet Explorer.
  2. Нажмите кнопку "Сервис " и нажмите кнопку "Управление надстройками".
  3. Щелкните надстройку в списке имен и нажмите кнопку "Отключить". Проверьте Internet Explorer.
  4. Повторите шаг 3, пока не определите надстройку, которая вызывает проблему.

Проверьте, устранена ли проблема. Если проблема устранена, вы закончите работу с этой статьей. Если проблема не устранена, попробуйте следующий метод.

Метод 4. Сброс параметров Internet Explorer

Если проблема вызвана поврежденными или несовместимыми параметрами или надстройками Internet Explorer, обычно можно устранить проблему, сбросив параметры Internet Explorer в параметры по умолчанию.

При сбросе параметров Internet Explorer все предыдущие параметры будут потеряны и не могут быть восстановлены. При восстановлении параметров по умолчанию Internet Explorer некоторые веб-страницы, использующие сохраненные файлы cookie, данные формы, пароли или ранее установленные надстройки браузера, могут работать неправильно. Однако сброс параметров Internet Explorer на параметры по умолчанию не удаляет избранное, веб-каналы и несколько других личных параметров.

Чтобы сбросить параметры Internet Explorer, выполните следующие действия.

  1. Закройте все окна Internet Explorer.

  2. Нажмите кнопку "Пуск", введите inetcpl.cpl в поле поиска и щелкните inetcpl.cpl в списке "Программы". Откроется диалоговое окно «Свойства веб-обозревателя».

    Примечание.

    Для Windows XP нажмите кнопку "Пуск", нажмите кнопку "Запустить", введите inetcpl.cpl в поле "Открыть" и нажмите кнопку "ОК".

  3. Перейдите на вкладку Дополнительно.

  4. В разделе "Сброс параметров Internet Explorer" нажмите кнопку "Сброс". Затем снова нажмите кнопку "Сброс ".

  5. Когда Internet Explorer завершит сброс, нажмите кнопку "Закрыть " в диалоговом окне "Сброс параметров Internet Explorer".

  6. Запустите Internet Explorer еще раз. Изменения вступают в силу при следующем открытии Internet Explorer.

Метод 5. Повторная регистрация необходимых DLL-файлов Internet Explorer

Примечание.

Эта информация относится к Windows XP

Чтобы повторно зарегистрировать файлы DLL, выполните следующие действия.

  1. Нажмите кнопку "Пуск", выберите "Все программы", щелкните "Аксессуары", щелкните правой кнопкой мыши cmd и выберите "Запуск от имени администратора". Если вам предлагается пароль администратора или подтверждение, введите пароль или укажите подтверждение.

  2. Введите regsvr32 urlmon.dll в поле "Открыть" и нажмите кнопку "ОК".

  3. Нажмите кнопку "ОК " при получении подтверждения.

  4. Повторите шаги 2 и 3 для следующих команд:

    • regsvr32 mshtml.dll
    • regsvr32 shdocvw.dll
    • regsvr32 browseui.dll
    • regsvr32 msjava.dll

Проверьте, устранена ли проблема. Если проблема устранена, вы закончите работу с этой статьей. Если проблема не устранена, перейдите к следующему разделу.

Расширенный поиск проблем

Этот раздел предназначен для более сложных пользователей компьютеров.

Метод 1. Создание учетной записи пользователя

Дополнительные сведения о профилях пользователей см. в разделе "Сведения о профилях пользователей".

Дополнительные сведения о методе см. на следующих веб-сайтах Майкрософт:

Метод 2. Использование восстановления системы

Восстановление системы использует точки восстановления для возврата системных файлов и параметров в более ранний момент времени, не затрагивая личные файлы. Точки восстановления создаются автоматически каждую неделю и непосредственно перед значительными системными событиями, такими как установка программы, устройства или драйвера.

Перед началом восстановления системы сохраните все открытые файлы и закройте все программы. После подтверждения точки восстановления системное восстановление перезагрузит компьютер. Чтобы выполнить восстановление системы, выполните следующие действия.

Для Windows 7 и Windows Vista

  1. Нажмите кнопку "Пуск", нажмите кнопку "Все программы", выберите "Стандартные", выберите "Системные инструменты", а затем нажмите кнопку "Восстановить систему". Если вам предлагается пароль администратора или подтверждение, введите пароль или укажите подтверждение.

  2. Нажмите кнопку "Далее" на странице "Восстановление системы".

  3. Выберите нужную дату или описание восстановления системы.

    Примечание.

    Если вы не видите нужную дату, выберите "Показать дополнительные даты" и выберите нужную дату.

  4. В окне подтверждения нажмите кнопку "Готово". Компьютер перезагрузится. По завершении процесса появится сообщение подтверждения.

Для Windows XP

  1. Войдите в Windows с помощью учетной записи с правами администратора.
  2. Нажмите кнопку "Пуск", нажмите кнопку "Все программы", выберите "Стандартные", выберите "Системные инструменты", а затем нажмите кнопку "Восстановить систему".
  3. На странице "Добро пожаловать в системное восстановление" выберите параметр "Восстановить мой компьютер до предыдущего времени ", а затем нажмите кнопку "Далее".
  4. На странице "Выбор точки восстановления" щелкните самую последнюю точку восстановления в этом списке, выберите список точек восстановления и нажмите кнопку "Далее".
  5. На странице выбора точки восстановления нажмите кнопку "Далее". Восстановление системы восстанавливает предыдущую конфигурацию Windows XP, а затем перезагрузит компьютер.
  6. Войдите на компьютер от имени администратора. Затем нажмите кнопку "ОК" на странице "Восстановление восстановления системы". Компьютер перезагрузится. По завершении процесса появится сообщение подтверждения.

Если вы используете восстановление системы, но проблема по-прежнему возникает или другие проблемы, можно отменить операцию восстановления. После отмены операции можно попробовать использовать другую точку восстановления. Чтобы отменить операцию восстановления системы, выполните следующие действия.

  1. Нажмите кнопку "Пуск", нажмите кнопку "Все программы", выберите "Стандартные", выберите "Системные инструменты", а затем нажмите кнопку "Восстановить систему".
  2. Нажмите кнопку "Отменить восстановление системы" и нажмите кнопку "Далее".
  3. Просмотрите выбранные варианты и нажмите кнопку "Готово".

Компьютер перезагрузится. По завершении процесса вы получите подтверждение.

Дополнительные ресурсы

Проверьте, устранена ли проблема. Если проблема устранена, вы закончите работу с этой статьей. Если проблема не устранена, вы также можете использовать службы поддержки клиентов Майкрософт для поиска других решений. служба поддержки Майкрософт службы включают следующие методы:

  • Выполните поиск в базе знаний Майкрософт: найдите сведения о технической поддержке и средства самостоятельной помощи для продуктов Майкрософт.
  • Центры решений: просмотрите вопросы, часто задаваемые вопросы и сведения о поддержке.
  • Сообщество Майкрософт: контакт с коллегами, одноранговыми узлами и наиболее ценными специалистами Майкрософт (MVPs).
  • Другие варианты поддержки: задайте вопрос, обратитесь в службу поддержки клиентов Майкрософт или предоставьте отзыв.