Примечание
Для доступа к этой странице требуется авторизация. Вы можете попробовать войти или изменить каталоги.
Для доступа к этой странице требуется авторизация. Вы можете попробовать изменить каталоги.
Область применения: Visual Studio 2022
Симптомы
После успешного создания минимального макета и тестирования его в системе отображается сообщение об ошибке, например следующее:
Фрагмент кода из журнала:
[3004:0006][<DateTime>] Unable to select suitable download engine.
[3004:0006][<DateTime>] Unable to get download engine: Can not download. No suitable download engine found.
[3004:0006][<DateTime>] Error 0x80131500: Unable to download the channel manifest from https://aka.ms/vs/17/release/channel. at Microsoft.VisualStudio.Setup.ChannelManager.<AddAsync>d__43.MoveNext()
[3004:0006][<DateTime>] Error 0x80131500: Failed to initialize the app in AppInitializerService.InitializeChannelsAsync: Microsoft.VisualStudio.Setup.ChannelManifestDownloadException
Причина
Проблема может возникнуть, если обновление выполняется из нового профиля или содержимое в папке %localappdata%\Microsoft\VisualStudio отсутствует или повреждено. В этой папке размещен файл манифеста канала, содержащий сведения о продукте и его обновлениях.
В идеале это поведение не должно происходить при установке и обновлении Visual Studio с помощью той же учетной записи пользователя. Visual Studio создает папку _channels во время начальной установки в папке C:\ProgramData\Microsoft\VisualStudio\Packages и %localappdata%\Microsoft\VisualStudio\Packages. В процессе обновления Visual Studio сравнивает файлы манифеста каталога и канала из этих расположений, чтобы обеспечить плавное обновление.
Решение
Проблему можно устранить следующим способом.
- Скопируйте папку _channels , расположенную в папке C:\ProgramData\Microsoft\VisualStudio\Packages.
- Создайте папку с именем Packages в каталоге %localappdata%\Microsoft\VisualStudio .
- Вставьте папку _channels в только что созданную папку "Пакеты ".
- Повторите процесс обновления.